• Like 0

    Error in the new update with "linux 4.7-1"


    Hi,
    when a few minutes ago I tried to update the system, I have this negative answer ( sorry, but this is in italian language):

    [[email protected] ~]# pacman -Syu
    :: Sincronizzazione dei database in corso...
     antergos è aggiornato      0,0   B  0,00B/s 00:00 [----------------------]   0%
     core è aggiornato
     extra è aggiornato         0,0   B  0,00B/s 00:00 [----------------------]   0%
     community è aggiornato
     multilib è aggiornato      0,0   B  0,00B/s 00:00 [----------------------]   0%
    :: Aggiornamento del sistema in corso...
    attenzione: perl-sgmls: la versione installata (1.03ii-5) è più recente di quella presente in community (1.1-1)
    risoluzione delle dipendenze in corso...
    ricerca dei pacchetti in conflitto in corso...
    errore: impossibile eseguire l'operazione richiesta (impossibile soddisfare le dipendenze)
    :: nvidia: l'installazione di linux (4.7-1) interrompe la dipendenza 'linux<4.7'
    [[email protected] ~]#
    

    I thank all of you.

  • Like 0

    Actually, the current situation with perl-sgmls package looks rather strange. Beside that, there would be too many questions about your system’s config, DE(s) used, partucular packages installed.

    Three simple steps might help to make potentially long and confusing thread short, tagliandoo la testa al toro.

    1. Backup the whole system with fsarchiver or clonezilla

    2. Upgrade the system, forcing databases update and allowing downgrades:

      sudo pacman -Syyuu
      
    3. If it breaks the system, restore it from backup, made in step 1

    Good luck

  • Like 0

    unbelievable! I have tried the update another time, and everything fell into place in the right way:

    [sudo] password di albert: 
    :: Sincronizzazione dei database in corso...
     antergos è aggiornato      0,0   B  0,00B/s 00:00 [----------------------]   0%
     core è aggiornato
     extra                   1761,1 KiB  1464K/s 00:01 [######################] 100%
     community                  3,6 MiB  1644K/s 00:02 [######################] 100%
     multilib è aggiornato      0,0   B  0,00B/s 00:00 [----------------------]   0%
    :: Aggiornamento del sistema in corso...
    attenzione: perl-sgmls: la versione installata (1.03ii-5) è più recente di quella presente in community (1.1-1)
    risoluzione delle dipendenze in corso...
    ricerca dei pacchetti in conflitto in corso...
    
    Pacchetti (11) evince-3.20.1-2  gd-2.2.3-3  gnome-online-accounts-3.20.3-2
                   gnome-photos-3.20.3-1  gvfs-1.28.3-1  gvfs-mtp-1.28.3-1
                   gvfs-smb-1.28.3-1  iproute2-4.7.0-1  libibus-1.5.14-1
                   linux-4.7-1  nvidia-367.35-2
    
    Dimensione totale dei pacchetti da scaricare:    72,08 MiB
    Dimensione totale dei pacchetti da installare:  117,73 MiB
    Dimensione netta dell'aggiornamento:              1,14 MiB
    
    :: Vuoi procedere con l'installazione? [S/n] s
    :: Download dei pacchetti in corso...
     iproute2-4.7.0-1-x86_64  656,6 KiB  1397K/s 00:00 [######################] 100%
     linux-4.7-1-x86_64        59,5 MiB  1695K/s 00:36 [######################] 100%
     evince-3.20.1-2-x86_64     2,4 MiB  1673K/s 00:01 [######################] 100%
     gd-2.2.3-3-x86_64        146,9 KiB  1130K/s 00:00 [######################] 100%
     gnome-online-accoun...  1043,2 KiB  1138K/s 00:01 [######################] 100%
     gnome-photos-3.20.3...   538,8 KiB  1314K/s 00:00 [######################] 100%
     gvfs-1.28.3-1-x86_64     980,8 KiB  1090K/s 00:01 [######################] 100%
     gvfs-mtp-1.28.3-1-x...    44,3 KiB  1640K/s 00:00 [######################] 100%
     gvfs-smb-1.28.3-1-x...    28,0 KiB  1645K/s 00:00 [######################] 100%
     libibus-1.5.14-1-x86_64  343,0 KiB   972K/s 00:00 [######################] 100%
     nvidia-367.35-2-x86_64     6,5 MiB  1181K/s 00:06 [######################] 100%
    (11/11) verifica delle chiavi presenti nel por...  [######################] 100%
    (11/11) verifica dell'integrità dei pacchetti      [######################] 100%
    (11/11) caricamento dei file dei pacchetti         [######################] 100%
    (11/11) controllo dei conflitti in corso           [######################] 100%
    (11/11) controllo dello spazio disponibile sul...  [######################] 100%
    :: Elaborazione delle modifiche al pacchetto...
    ( 1/11) aggiornamento in corso di evince           [######################] 100%
    ( 2/11) aggiornamento in corso di gd               [######################] 100%
    ( 3/11) aggiornamento in corso di gnome-online...  [######################] 100%
    ( 4/11) aggiornamento in corso di iproute2         [######################] 100%
    ( 5/11) aggiornamento in corso di gnome-photos     [######################] 100%
    ( 6/11) aggiornamento in corso di gvfs             [######################] 100%
    ( 7/11) aggiornamento in corso di gvfs-mtp         [######################] 100%
    ( 8/11) aggiornamento in corso di gvfs-smb         [######################] 100%
    ( 9/11) aggiornamento in corso di libibus          [######################] 100%
    (10/11) aggiornamento in corso di linux            [######################] 100%
    >>> Updating module dependencies. Please wait ...
    >>> Generating initial ramdisk, using mkinitcpio. Please wait...
    ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
      -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
    ==> Starting build: 4.7.0-1-ARCH
      -> Running build hook: [base]
      -> Running build hook: [udev]
      -> Running build hook: [autodetect]
      -> Running build hook: [modconf]
      -> Running build hook: [block]
      -> Running build hook: [keyboard]
      -> Running build hook: [keymap]
      -> Running build hook: [resume]
      -> Running build hook: [filesystems]
      -> Running build hook: [fsck]
    ==> Generating module dependencies
    ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
    ==> Image generation successful
    ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
      -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
    ==> Starting build: 4.7.0-1-ARCH
      -> Running build hook: [base]
      -> Running build hook: [udev]
      -> Running build hook: [modconf]
      -> Running build hook: [block]
    ==> WARNING: Possibly missing firmware for module: aic94xx
    ==> WARNING: Possibly missing firmware for module: wd719x
      -> Running build hook: [keyboard]
      -> Running build hook: [keymap]
      -> Running build hook: [resume]
      -> Running build hook: [filesystems]
      -> Running build hook: [fsck]
    ==> Generating module dependencies
    ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
    ==> Image generation successful
    (11/11) aggiornamento in corso di nvidia           [######################] 100%
    In order to use nvidia module, reboot the system.
    :: Esecuzione degli hook di post-transazione...
    (1/6) Updating GIO module cache...
    (2/6) Compiling GSettings XML schema files...
    (3/6) Updating icon theme caches...
    (4/6) Reloading GVFS config...
    (5/6) Updating manpage index...
    (6/6) Updating the desktop file MIME type cache...
    Done - Press enter to exit
    

    I thank all of you.

error106 4.7-11 Posts 3Views 561
Log in to reply