• Error on update: pacman requires mate-desktop>=1.14


    Hi,
    today trying to do an update, pacman warns about a conflict between mate-panel-gtk3 and mate-panel, also between mate-desktop-gtk3 and mate-desktop, i try to resolve the conflict choosing the gtk3 version of the packages, after that pacman shows an error saying that many packages need mate-desktop>=1.14, actually i have mate 1.14.1 from the antergos repository. what should i do?

    This is the pacman output:

    buscando conflictos entre paquetes…
    :: mate-panel-gtk3 y mate-panel están en conflicto. ¿Quitar mate-panel? [s/N] s
    :: libmateweather-gtk3 y libmateweather están en conflicto. ¿Quitar libmateweather? [s/N] s
    :: mate-desktop-gtk3 y mate-desktop están en conflicto. ¿Quitar mate-desktop? [s/N] s
    error: no se pudo preparar la operación (no se pudieron satisfacer las dependencias)
    :: atril: quitando «mate-desktop» se rompe la dependencia con «mate-desktop>=1.14»
    :: caja: quitando «mate-desktop» se rompe la dependencia con «mate-desktop>=1.14»
    :: eom: quitando «mate-desktop» se rompe la dependencia con «mate-desktop>=1.14»
    :: marco: quitando «mate-desktop» se rompe la dependencia con «mate-desktop>=1.14»
    :: mate-accountsdialog: quitando «mate-desktop» se rompe la dependencia con «mate-desktop»
    :: mate-applet-lockkeys: quitando «mate-panel» se rompe la dependencia con «mate-panel»
    :: mate-applets: quitando «mate-panel» se rompe la dependencia con «mate-panel>=1.14»
    :: mate-control-center: quitando «mate-desktop» se rompe la dependencia con «mate-desktop>=1.14»
    :: mate-media: quitando «mate-desktop» se rompe la dependencia con «mate-desktop>=1.14»
    :: mate-mint-menu: quitando «mate-panel» se rompe la dependencia con «mate-panel>=1.8.0»
    :: mate-power-manager: quitando «mate-desktop» se rompe la dependencia con «mate-desktop>=1.14»
    :: mate-screensaver: quitando «mate-desktop» se rompe la dependencia con «mate-desktop>=1.14»
    :: mate-sensors-applet: quitando «mate-panel» se rompe la dependencia con «mate-panel>=1.14»
    :: mate-session-manager: quitando «mate-desktop» se rompe la dependencia con «mate-desktop>=1.14»
    :: mate-settings-daemon: quitando «mate-desktop» se rompe la dependencia con «mate-desktop>=1.14»
    :: mate-terminal: quitando «mate-desktop» se rompe la dependencia con «mate-desktop>=1.14»
    :: pluma: quitando «mate-desktop» se rompe la dependencia con «mate-desktop>=1.14»
    
  • @Sergio-Alejandro-Bayona-Becerra Mate finally upgrades to 1.14.1 in native Arch repos. So Antergos does, even if the [antergos] repo still has the lowest priority.

    Some package(s) from older Mate 1.12 are in conflict with the newer Mate 1.14. In my case, the offenfing package was mate-applet-streamer. I removed it with:

    sudo pacman -Rcnsu mate-applet-streamer
    

    Though it will be hard to survive without listening to online music without this package, Mate upgrades to 1.14 without a problem after that:

    alt text

    Oh, the mate-mint-menu works perfectly. Cool. I love Gnome 2. And Mate.

  • @Sergio-Alejandro-Bayona-Becerra said in Error on update: pacman requires mate-desktop>=1.14:

    …actually i have mate 1.14.1 from the antergos repository. what should i do?..

    You could also try place the [antergos] repo below other standard Arch repos. Thus, giving it the lowest priority.

    I may be wrong, but probably it was placed two months ago above all other repos (at highest priority) to allow Mate 1.14 installation in Antergos. There was no Mate 1.14 in Arch repos at that time.

    I keep the [antergos] repo at lowest priority, below all other repos, as it was in original Cinnarch and Antergos, and don’t encounter any issue due to it.

  • @just said i

    I may be wrong, but probably it was placed two months ago above all other repos (at highest priority) to allow Mate 1.14 installation in Antergos. There was no Mate 1.14 in Arch repos at that time.

    No, just, you re not wrong.:+1:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @just said in Error on update: pacman requires mate-desktop>=1.14:

    …Some package(s) from older Mate 1.12 are in conflict with the newer Mate 1.14. In my case, the offenfing package was mate-applet-streamer.

    I’m sorry for self-quoting. Upgrading Antergos Mate to 1.14 on another computer I found another offending package - mate-menu.

    Again, once the package has been removed, the upgrade went smoothly.

  • Just wanted to clarify that the Arch Repos have packaged the gtk2 and gtk3 builds (from what I saw when I took a quick look at it). That means that the MATE packages in the antergos repo that have the same name as the one’s in the Arch repo are not the same (Antergos repo is packaging the GTK3 versions as the default…Arch is packaging the GTK2 versions as the default).

    Cheers!

  • Thanks to all!
    I change [antergos] below the other repos and replace several packages from antergos repo that was in conflict with [Community], then, finally, I could upgrade my system.

  • @Sergio-Alejandro-Bayona-Becerra said in Error on update: pacman requires mate-desktop>=1.14 [Solved]:

    Thanks to all!
    I change [antergos] below the other repos…

    Ok, that’s fine.

    Please, remember that it is not an official [antergos] and [antergos-staging] repos’ placement. Both repos have the highest priority (above all other repos) in official Antergos.

    Edit: In other words, this Mate 1.14 is made and arrives directly from Arch. It is not Mate 1.14 prepared and made available by Antergos devs two-three months ago.

requires5 error200 pacman80 Posts 8Views 1697
Log in to reply