• After successful installation, i only get grub prompt


    hi,
    i wish to dual boot win10 and Antergos on a non-UEFI system. i do not wish to have Grub manage it all as i understand it isn’t recommended and when i tried that i lost both OSes.

    i have 4 HDDs, sda being the win10 drive and sdc being the drive i’m trying to install Antergos to, it’s a 3TB GPT drive, it has most of it allocated as data partition in sdc1, sdc2 is \boot, sdc3 is \root, sdc4 is \home and sdc5 is \swap,
    in the installer, i choose advanced setup, set mount points and uncheck the checkbox to install bootloader to sdX. on other installers, it usually prompts a screen in which i can specify where to install it, but not here. (it’s worth to note that i’ve tried to install about 20 times, in every variation i could think about and nothing worked- tried installing bootloader to dev\sdc, dev\sda, dev\sdc2, tried both with and without seperate \boot partition- nothing worked).

    in this method, after the successful installation, one should boot into win10 and add a boot entry, usually using easyBCD etc. i tried specifying it as grub, grub2- nothing works, i just get a grub prompt.
    followed the arch wiki page about grub- specifically the part regarding installing grub to a partition (chrooting into the system, forcing grub install, creating .cnf) and it all appears to go smoothly but nothing changes. even tried the manjaro guide to restore grub, same result.
    when i try to use set root=(hd and working with TAB to figure out where thr linux install is (in the grub prompt), it just lists ntfs partitions.

    truly, i’m at my wit’s end. i’ve spent nearly 3 days on it (on and off) and completely out of ideas. help would be much appreciated.

  • anyone?

    please, any help would be much appreciated.
    according to the grub page on the Arch wiki, as i have a bios system and sdd (my intended linux drive) uses GPT, i had created a bios boot partition with no filesystem using gdisk.
    however, nothing works. I just get grub4dos prompt which doesn’t recognize any ext4 partitions.

    i read somewhere grub has trouble recognizing partitions in a drive after a large one. as my sdd id a 3TB hdd with sdd1 being a2.5TB data ntfs partition, is it possible this is the problem? if so, what can i do to fix it?

  • solved!

    using gparted, i moved 1GB (my original /boot partition) to be before my storage partition (which took approximately 24 hours), then i deleted the and recreated the suggested bios boot partition needed on GPT drives, and when antergos installed (which took a while, as i mentioned in another post) it worked!

successful1 grub69 installation194 prompt4 Posts 3Views 655
Log in to reply