• Shutdown button gone after switching from lightdm to gdm.


    Following https://forum.antergos.com/topic/3082/the-login-screen-for-antergos-is-incredibly-slow I replaced lightdm by gdm. Now my shutdown button is gone. (And more, I don’t remember what the other two did.) I can still shutdown with the command line.

    Rebooting restores the button until I use the lock screen. It usually breaks in two steps, first both locking+preferences are available, and after the second locking only the preferences remain. (see screenshot)

    Any ideas how to get back the missing buttons?

    0_1470313027743_MissingButtons.png

  • If you tried uninstalling and re-installing it again? Just saying an idea, I haven t found anything similar to your issue. Do an upgrade before and after re-installation DO NOT FORGET to enable it before rebooting…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I found that ertan had the same problem and asked here for help. Not sure if that got resolved. I believe the “Status menu buttons” extensions somehow throws an exception and then is disabled by Gnome.

    Rebooting restores the extension, locking it breaks it again. (I’m also adding this to the original post.)

    0_1470343583716_DisabledButtonExtension.png
    The Error can be found through Gnome Looking Glas (Alt+F2 → lg), but I have no experience with debugging Gnome extensions.

    Error: Argument ‘old_child’ (type interface) may not be null

    I did try to follow your steps and will reboot now reboot, but it didn’t change anything.

    sudo pacman -Syu
    sudo pacman -R gdm
    sudo pacman -Syu  
    sudo pacman -S gdm
    sudo systemctl enable gdm
    sudo systemctl start gdm
    sudo pacman -Syu
    
  • Hmmm. Give it another try. Same sequence. But this time run
    sudo pacman -Rns gdm instead of sudo pacman -R gdm
    This command will also remove cache & dependencies

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I seem to have the exact same problem as @rosievers , I got sick of my lack of knowledge wiith light dm to get the lock screen to work so I switched from lightdm to gdm.

    On initial install all 4 buttons are present as usual.
    When I click lock, nothing happens.
    When I use super + l, the lockscreen comes up for a millisecond and then the screen goes blank (I wish it would just stay on the blank screen for a short while).
    When I log back in from the lock screen, the power button is gone as is the hibernate button. All that is left is the unresponsive lock button and the settings button.
    When I lock the screen again (super + l), and then log back in, all that is left is the settings button.
    For completeness sake, if I do it again I still have the settings button.

    In Tweaktools > Extensions, the “Status menu buttons” extension does have an “error loading extension”, with the button greyed out so I can’t turn it off and I can’t seem to remove it. The error is also present on extensions.gnome.org/local/. However uninstalling from here does not actually work.

    I don’t mind moving back to lightdm, as long as there are clear instructions on how to get the lock screen to work, However this is beside the point gdm should not do this.

    I have also tried the above recommended instructions but to no avail, only resetting will bring back the power button.

    I’m also a noob at gnome so I don’t know how to get to all the settings. I really like the gnome desktop but not having a simple thing like the lockscreen work is very annoying.

    Any help would be appreciated.

  • So I’ve found a janky solution to this -

    sudo pacman -Syu
    sudo pacman -S gdm
    sudo systemctl disable lightdm
    sudo systemctl enable gdm
    
    • Restart, to boot into your OS (you should be on the GDM greeter).
    • Disable the extension “Status menu Buttons” from Tweak Tool --> extensions
    • Browse to gnome extensions
    • Install Suspend Button

    Note that Status Menu Buttons does not seem to be removable but at least you have the 4 buttons - Settings, lockscreen, suspend and power off in the suspend menu.

    Also if another noob like me finds this post gnome’s default dim timer, sleep timer (both battery and AC) are set to 300 by default.
    Set them all to what you want by terminal or download dconf-editor (but be careful with how you use it).

    gsettings set org.gnome.settings-daemon.plugins.power sleep-display-ac <value>
    gsettings set org.gnome.settings-daemon.plugins.power sleep-display-battery <value>
    gsettings set org.gnome.desktop.session idle-delay <value>
    
gdm33 gnome214 Posts 6Views 1102
Log in to reply