• Gnome Calendar Missing AM/PM Button in Event Time Pop Up


    While using Gnome Calendar I noticed that the AM/PM button is missing when trying to add an event. I can set the hours and minutes, but not AM/PM. At first I figured I’d just missed where to set it, but then I looked on my Fedora install and it is right next to the hours and minutes in the pop up dialog. Anyone else have this issue and is there a workaround I could use so that I can set the correct time for my events? Thanks!

  • @matt.mccann.8 should be in gnome-tweaks or something like that. I say that since I assume you already looked around the Date & Time settings. I remember there being a switch to change between 24hr time and 12hr time thought right in the Time settings…

    Sys01: Antergos + Mate; GTX 1070 + nvidia package :)
    Sys02: Antergos + Mate on Surface Pro 3

  • @n_mag Thanks. I looked in tweaks and didn’t see anything related to time other than displaying seconds in the top bar. I should have mentioned, all of my systems are set to 12 hour am/pm time in the Date & Time settings.

  • @matt.mccann.8 Strange, have you restarted gnome yet?

    Sys01: Antergos + Mate; GTX 1070 + nvidia package :)
    Sys02: Antergos + Mate on Surface Pro 3

  • I’ve restarted the computers several times since I noticed this issue. I’ll give them another restart after today’s updates and see if anything changes, however, if I flip the time from 12 to 24 hour the change is reflected immediately in Gnome Calendar when I try to set a time for an event.

  • ![alt text](0_1470328566650_Screenshot from 2016-08-04 12-27-01.png image url)

    I did a restart and still don’t have an option to set AM/PM in the event pop up. Very strange.

  • @matt.mccann.8 I wonder if they’re trying a new design for it.

    So if you set it to 14:00, does it show 2:00 PM?

    I think I’m gonna test this on vm soon but with school idk if I can get to that just yet…

    Sys01: Antergos + Mate; GTX 1070 + nvidia package :)
    Sys02: Antergos + Mate on Surface Pro 3

  • Yes if I set my system to 24 hour time it works because it doesn’t require the AM/PM. That’s not ideal of course if I don’t want to run my system in 24 hour time. In Fedora 23 this is how it looks, so I have to imagine it’s a bug in the newer version available in Antergos.

    0_1470354638479_Fedora 23 Calendar.png

  • @matt.mccann.8 perhaps it is a bug. Have you tried, for example, switching to something like:

    1. change to xfce4 DE for the time being
    2. uninstall gnome desktop
    3. using the command yaourt gnome to install gnome from the arch repository instead of Antergos’.
      A) that command will show you a list of apps the word “gnome” relates to and shows which repo it is coming from
    4. choosing the arch repository, installing gnome from there to see if the bug is still present

    This might help to be sure you know?

    Sys01: Antergos + Mate; GTX 1070 + nvidia package :)
    Sys02: Antergos + Mate on Surface Pro 3

  • @n_mag I just took a look at Fedora 24 in a VM and it seems to have the same issue so I don’t think it is specifically and Antergos problem, it seems to be an upstream Gnome issue.

  • As of today’s update to Gnome Calendar (3.20.3) the AM/PM button is back in the hour/minute popover dialog. This issue is fixed.

  • Reinstalled Gnome Calendar (3.20.3-1) several times today.
    For 24-hours time, the “hours” field do not admit values larger than 12.
    For AM/PM, even if PM is selected, it immediately reverts to AM.
    I am afraid the issue is not fixed yet.

  • I have the same issue. When attempting to create an event and selecting PM, it immediately reverts back to AM.

  • Latest update of Gnome Calendar 3.20.4 resolved the issue.

  • Confirmed. However the calendar seems not to check whether start time is before end time or not. Is this documented or is a bug?

gnome calendar1 gnome215 Posts 15Views 1238
Log in to reply