• Like 0

    Make Error 2 When Setting Up DLink DWA 182


    Recently installed Antergos. When using it live I was able to set up the drivers no problem using this here and the commands:

    make clean
    make
    sudo make uninstall
    sudo make install

    I am trying the same process, only Antergos is installed. I have no internet connection on the system so any file transferring can be done via USB. This always leads to Make Error 2. Please let me know if any more info is needed to help fix this.

  • Like 0

    @papaT I think the OP should make sense to you: https://ubuntuforums.org/showthread.php?t=2270202

    Error 2 is basically a super generic return error. Anyways, the OP from the link seems to contain an answer that solved their problem. If not, what are the commands you ran to compile and enable everything?

    Loves me some rolling distro and Antergos-Arch
    Sys: Antergos + Cinnamon; GTX 1070 + nvidia package :)

  • Like 0

    I have tried that before and it didn’t really work but I thought I may try again. On the very first command, replacing the apt-get install with pacman -S and it returns
    error: target not found: linux-headers-generic
    error: target not found: build-essential

    I tried to proceed even with this occurring and once I hit the clone command I am unable to access because I don’t have access to the internet without the adapter.
    I tried to then transfer it over from another computer and the link is a 404.

    Thanks.

  • Like 0

    @papaT To be honest it might be easier on your life to get a kernel supported hardware, so perhaps a wireless adapter brand from tp-link or something with a atheros chipset or the like. Adapters are super cheap on sale and it’d probably be more reliable since plug-and-play and being in the kernel and all. I’ve tried to deal with network drivers before when they didn’t have kernel support and it’s kinda awful overall…

    Loves me some rolling distro and Antergos-Arch
    Sys: Antergos + Cinnamon; GTX 1070 + nvidia package :)

error106 dwa1 1821 dlink2 Posts 4Views 227
Log in to reply