• Cnchi 0.14.130 failure to finish WORKAROUND

    Re: Can't Finish Fetching Packages

    This couldn’t of happened at a worse time. Just wanted to quickly redo laptop and do a service call LoL.
    OK for now lets just do the workaround.

    -Disconnect from network
    -Boot into LiveCD
    -Close Cnchi
    -Once logged in, open terminal do sudo pkill pacman, this kills pacman-boot which would force a cnchi update on network connect
    -Connect to network
    -In terminal do sudo cnchi --disable-update

    Actually finish an install with ISO’s cnchi v0.14.113, yey…

  • @Jebtrix Nice will tyr right away

  • Worked great with live. Tried the minimal first and cnchi just closed after selecting DE and while ranking mirrors.

  • @Tiedemann

    Haven’t attempted with minimal, noted. Could try sudo cnchi --disable-rank-mirrors --disable-update

    1 outta 2 ain’t bad though :)

  • So if I try to install right now, will I have to deal with this bug? I was thinking about doing a fresh install this afternoon, but if it’s going to be problematic, I’ll hold off for a while.

  • @baron_iv Well. I have not encountered any issues with this workaround. I only selected xfce, SMB and AUR support though. Nothing more fancy than that.

  • Did you guys install the default Gnome desktop with this workaround? I just tried this with Cinnamon and it didn’t work. The end result was the same old error:

    Can't install necessary packages. Cnchi can't continue.
    Please reference the following number when reporting this error: 216894

    I chose all other features for the setup, except these three: “Chromium Web Browser”, “Kernel (LTS version)” and “Steam + PlayOnLinux”.

  • @Gladiator

    That wasn’t the error I was working around, it was the list index out of bounds which would make cnchi get stuck on last package. I did try your specified install options in a vbox quick, it gave me an erroneous not enough space error at the very end. Suffice to say cnchi got some serious issues…

  • @Gladiator

    I upped the VM ram to 8GB then I got error 217251 (at the very end of course):

    [ERROR] pac.py(157) finalize_transaction(): Can’t finalize alpm transaction: transaction failed, pm_errno 34 (invalid or corrupted package), []

    Oh the fun…

  • The issue should be resolved in Cnchi 0.14.133. Cheers!

  • Now I’m getting (VM install):

    [ERROR] process.py(132) run(): misc.extra.InstallError: ‘Setup cannot detect size of your device, please use advanced installation routine for partitioning and mounting devices.’

  • @thothix

    I already notified that bug to the dev lots0logs, squashed it in 15min, fixed in 0.14.134. Not sure when it’ll pull automatically.


    Kudos to lots0logs for lightning fast fix!

cnchi161 failure16 workaround3 0.14.1301 Posts 12Views 3142
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.