• Private Internet Access VPN


    I have been chasing my tail trying to get PIA up and running. I installed the PIA package but am unable to connect. I then went with the Openvpn route which I am most familiar with but that doesn’t work as well.

    Any ideas? I figured this would be easier than it seems!

    Thanks.

  • Hi,

    I have no idea how to setup openvpn, but I’ve found this old post (2013!) from Allan McRae that maybe helps you: http://allanmcrae.com/2013/09/routing-traffic-with-openvpn/

    I would also check the Arch wiki: https://wiki.archlinux.org/index.php/OpenVPN

    Hope this helps.

  • Follow the directions in this link exactly:

    https://wiki.archlinux.org/index.php/Private_Internet_Access_VPN

    This is the method I followed and PIA works great.

  • @bmeister
    That is exactly what I did several times using the wiki. I will check the post karasu provided.

    Thanks

    I tried again and get the following error when running pia -a

    pia -a
    Traceback (most recent call last):
      File "/usr/bin/pia", line 9, in <module>
        load_entry_point('pia==2.8.2', 'console_scripts', 'pia')()
      File "/usr/lib/python3.5/site-packages/pia/command_line.py", line 23, in main
        pia.run.run()
      File "/usr/lib/python3.5/site-packages/pia/run.py", line 60, in run
        [globals()[k]() for k, v in props.commandline.__dict__.items() if
      File "/usr/lib/python3.5/site-packages/pia/run.py", line 61, in <listcomp>
        not k == 'hosts' and getattr(props.commandline, k, None)]
      File "/usr/lib/python3.5/site-packages/pia/run.py", line 111, in auto_configure
        app.config(*getattr(openvpn, config))
      File "/usr/lib/python3.5/site-packages/pia/applications/appstrategy.py", line 82, in config
        self.app.config(config_id, filename)
      File "/usr/lib/python3.5/site-packages/pia/applications/hooks.py", line 149, in config
        username, password = get_login_credentials(settings.LOGIN_CONFIG)
      File "/usr/lib/python3.5/site-packages/pia/utils/misc.py", line 67, in get_login_credentials
        with p.open() as f:
      File "/usr/lib/python3.5/pathlib.py", line 1151, in open
        opener=self._opener)
    IsADirectoryError: [Errno 21] Is a directory: '/etc/private-internet-access/login.conf'
    

    Thanks for any help

    Edit: Networkmanager seems to have no daemon per systemd. Is this relevant?

  • Yes, NetworkManager should have a daemon.

    sudo systemctl status NetworkManager
    

    It should be loaded and active. Y
    If it is loaded but not active then:

    sudo systemctl enable NetworkManager
    sudo systemctl start NetworkManager
    

    You also need networkmanager-openvpn installed. Are you running pia-a as root?

    Did you get any errors when PIA was being built from the AUR?

  • Thanks for responding. I hope this helps.

    pia-a is run as root;

    networkmanger-openvpn is installed as well as PIA-tools;

    During installation I get an error at the very end "error: unable to run hook pia-install.hook: could not satisfy dependencies"
    Transaction successfully finished.

    When checking the Networkmanager status I get:

    sudo systemctl status NetworkManager
    ● NetworkManager.service - Network Manager
       Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vend
       Active: active (running) since Wed 2016-07-27 18:41:16 EDT; 2min 59s ago
     Main PID: 375 (NetworkManager)
        Tasks: 3 (limit: 512)
       CGroup: /system.slice/NetworkManager.service
               └─375 /usr/bin/NetworkManager --no-daemon
    

    Edit: In AUR there is a network-openvpn-gtk2. Not sure if that helps.

  • Which desktop are you using?

    I have used Gnome, KDE and Cinnamon all with success using PIA. Currently using KDE (Plasma)

  • Gnome for the first time.

    Edit: Just heard from PIA. They are having the same issue with Anteros as I am. They are going to talk to the developers.

  • You don’t need PIA tools. Remove it. All you need is the private-internet-access-vpn package. You may have a conflict. Remove both and then install private-internet-access-vpn again. Follow wiki I posted earlier.

  • @parkslope said in Private Internet Access VPN:

    Gnome for the first time.

    Edit: Just heard from PIA. They are having the same issue with Anteros as I am. They are going to talk to the developers.

    Interesting, I didn’t see any comments on the package site about it. So you posted on the PIA website?

    Here you can post directly to Arch package maintainer:
    https://aur.archlinux.org/packages/private-internet-access-vpn/

  • Yes, PIA has an Arch guru who has replicated my issue. I tried as you instructed, but no dice. There are unmet dependencies.

    Tomorrow, I will contact AUR/Arch.

    I do appreciate all the time you gave to me. I will report back if PIA can figure this out.

    FYI: I did as you said and uninstalled everything. Rebooted and still can’t connect to PIA.

    Oh well.

  • You’re welcome and I hope they get things resolved soon!

  • Well it took some research but I got PIA to work with the following link for Manjaro. Important to use the manual openvpn config instructions. But it does work.

    https://www.privateinternetaccess.com/forum/discussion/18041/openvpn-step-by-step-setup-for-manjaro-linux-with-video

internet23 vpn17 private2 Posts 13Views 4987
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.