• antergos


    “please reference the following number when reporting this error: 208515” kde , xfce , I’m sorry if I’m bad , I understood just do not know much English I had tried to install and minimal version and full but gave an error cnchi

  • Please, try it again and check /tmp/cnchi.log

  • I have this same problem and this has been going on at least since yesterday (July 23th). I tried to install Antergos Cinnamon for the whole day, trying different mirror servers (Russia, Japan, China, USA, Norway…) and Cnchi versions but the end result was always the same:

    “Can’t install necessary packages. Cnchi can’t continue. Please reference the following number when reporting this error: 208608”

    Here is the end part of my /tmp/cnchi.log:
    http://pastebin.com/2H7GMjsB

    This is an interesting detail from the log too, which occurs for three times in total:

    ...
    2016-07-24 09:11:03 [DEBUG] download_requests.py(255) download_package(): Can't download None, Cnchi will try another mirror.
    ...
    2016-07-24 09:14:22 [DEBUG] download_requests.py(255) download_package(): Can't download None, Cnchi will try another mirror.
    ...
    2016-07-24 09:19:22 [DEBUG] download_requests.py(255) download_package(): Can't download None, Cnchi will try another mirror.
    ...
    

    “Can’t download None”, that can’t be right?

    The reference number that Cnchi gives for the error seems to change a little bit from time to time. Just a moment ago, it was “208623”.

    I have tried to use the latest Chinci version from GitHub (0.14.121) and also an earlier one (0.14.104) but that didn’t change anything.

    $ sudo pacman -S ca-certificates
    $ sudo rm -rf /usr/share/cnchi
    $ git clone https://github.com/antergos/cnchi --depth=1
    $ cd cnchi
    $ ./run
    

    Just a side note but the Cnchi gives the following error message during the guided installation process, at stage “Select Your Keyboard Layout”:

    perl: warning: Setting locale failed.
    perl: warning: Please check that your locale settings:
    	LANGUAGE = (unset),
    	LC_ALL = (unset),
    	LC_PAPER = "en_US.UTF-8",
    	LC_MONETARY = "en_US.UTF-8",
    	LC_NUMERIC = "en_US.UTF-8",
    	LC_COLLATE = "en_US.UTF-8",
    	LC_MEASUREMENT = "en_US.UTF-8",
    	LC_TIME = "en_US.UTF-8",
    	LANG = "fi"
        are supported and installed on your system.
    perl: warning: Falling back to the standard locale ("C").
    

    Also, this is the feature setup that I have selected for my Cinnamon installation:

    [ON] Arch User Repository (AUR) Support
    [ON] Bluetooth Support
    [OFF] Chromium Web Browser
    [ON] Extra Truetype Fonts
    [ON] Firefox Web Browser
    [ON] Flash plugins
    [ON] Graphic drivers (Proprietary)
    [OFF] Kernel (LTS version)
    [ON] LibreOffice
    [ON] Printing Support
    [OFF] Steam + PlayOnLinux
    [ON] Uncomplicated Firewall
    [ON] Windows sharing SMB

    But even the default setup doesn’t work:

    [ON] Bluetooth Support
    [ON] Chromium Web Browser
    [ON] Printing Support

    I guess that all these three recent topics are related to each other with this same problem:
    “antergos”, “Can’t install necessary packages” and “Fail to install…”

    The OP in the topic “Fail to install…” told that packages in “/var/cache/pacman/pkg” were zero in size for him but that is not the case for me.

    So at the moment, it seems impossible to install Antergos with Cinnamon desktop. Any suggestions for how long this problem might last?

  • Hi,

    Let’s see…

    1. If the line Can't download None... is preceded by Package 'whatever' has an empty URL for this mirror. then it’s perfectly fine.

    2. The reference changes each time because it’s a reference to the error so we can check it in our bug server. That’s perfectly fine, too.

    3. 0.14.121 solves the zero size issue, not yours i’m afraid.

    4. That’s another issue, that Cnchi can’t set correct locale in live session. It’s not related to your problem, but thanks for warning us.

    5. In my tests, selecting different features (or none at all) does not help. Do not worry about this.

    6. Yes, I’m afraid it’s not possible atm. I think it’s a mirror problem or a problem with our build server but as each time libalpm (pacman’s library) complains about a different package I do not know what to think.

    In my tests, Gnome worked 100% but there’s a user that reported that it didn’t work for him. If you’re in need of Cinnamon, you can install Gnome and then install Cinnamon with it (they share a lot of packages).

    Sorry as I do not have any good news or any estimation of when this will be solved.

  • @karasu

    Thanks karasu for your excellent reply. The lines Can't download None... are indeed preceded by Package 'whatever' has an empty URL for this mirror.

    I tried the Cinnamon installation once more, just a moment ago, and this time the reference number was “208714”. This really seems to be a difficult issue to narrow down but hopefully it will get solved soon. Antergos Cinnamon is a great operating system once it’s up and running.

  • I didn’t realize this until now… the OP in this thread says that KDE and XFCE desktops didn’t work for him. So, I tried to install KDE, a few hours ago and sure enough, it didn’t work (Reference Number 209479). Then I tried to install a completely default Gnome setup and, ta-daa, it worked. I also tried to install a more custom tailored Gnome setup and it still worked, without any problems.

    This can’t be just a coincidence, especially when the problem doesn’t seem to be related to either Cnchi-versions or mirror-servers. The Gnome installation works just fine and the Antergos Live Desktop Environment just happens to be based on the Gnome desktop. See? Could it be, that the problem is in the latest ISO-image file (antergos-2016.07.19-x86_64.iso)?

    Can someone confirm this and try to install Cinnamon, KDE or XFCE desktop with an older Antergos ISO-file?

  • @Gladiator said in antergos:

    Can someone confirm this and try to install Cinnamon, KDE or XFCE desktop with an older Antergos ISO-file?

    I installed Cinnamon with the June iso about 2 days before the July one came out without issue. I played around with XFCE and Mate as well. I think the XFCE errored towards the end, but I think it was because I didn’t wait for Cnchi to update before I started. The Mate seemed odd, but I don’t recall the exact issue. I installed Mate with Cinnamon and now it works.

  • @Shryp

    It’s of course very difficult to find an older Antergos ISO-file after a new one is released, and right now, I can’t even try if old torrent files are still working.

    With only the latest ISO-file available, I tried to install the MATE desktop on virtual machine (VMware). The installation went through succesfully but when I rebooted the VM and Antergos booted up, I got stuck on a empty desktop and gray taskbar on top. That didn’t happen with Gnome, so there’s something wrong with the MATE installation, altough it gets installed without errors (at least on the virtual machine).

    Click to open full size image:
    Antergos MATE

  • @Gladiator I believe that might be what my Mate did. I think restarting it again fixed it though.

  • Well, it doesn’t work. I managed to download the previous ISO-image (antergos-2016.06.18-x86_64.iso) but the installer (Cnchi 0.14.94) crashes after finishing downloading the packages (at stage “Loading packages…”) but with the following error message:

    [Errno 28] No space left on device
    

    /tmp/cnchi.log shows quite familiar result:

    ...
    [ERROR] pac.py(155) finalize_transaction(): Can't finalize alpm transaction: transaction failed, pm_errno 34 (invalid or corrupted package), []
    [DEBUG] pac.py(157) finalize_transaction(): Releasing alpm transaction...
    [DEBUG] pac.py(159) finalize_transaction(): Alpm transaction done.
    [ERROR] process.py(128) run(): [Errno 28] No space left on device
    [ERROR] process.py(132) run(): OSError: [Errno 28] No space left on device
    ...
    

    This isn’t anything new, this has already been discussed here, over a month ago:
    https://github.com/Antergos/Cnchi/issues/605

    Looks like we are back to square one.

  • As I said:

    0.14.121 solves the zero size issue

    You’re getting the “no space left on device” because you’re using an old version of the installer.

  • @karasu

    Sorry, I didn’t know those two issues were related. I hadn’t read anyone write about “Errno 28” and zero length files in the same context before. Anyway, have you made any progress with figuring out the installer/mirror problem? Too bad there has been setbacks with the automated installation process and it’s still causing troubles.

Posts 12Views 1591
Log in to reply