• Problems with installation on Macbook White 2008 (4.1)


    Hello! Im am completely new to Linux. Couple of days ago my old MBW put me in a position, where I decided to try the antergos distro - Lion is to slow now and I am gonna have MBPro anyway. I can use the old hardware with this awesome OS. I don’t want any windows (and have any) and since I have 9 years experience with PC’s I decided I will try how hard Linux is. 8 years of Mac comfort and windows support slowed my mind I think… I downloaded the .iso file and tried to install it under Virtualbox (4.3). No luck. I went through whole installation process and since two days it freezes at the end task. Last time I waited 4 hrs. Nothing. It stops and do not progress or finish or spit any error msg.

    I can’t run the .iso from dvd - no dvd burner available. Couldn’t create a boot usb like on arch wiki article - at some points it was unclear what I suppose to do - I do not need .exe file in my ‘download’ and even so - I couldn’t find any in files linked in the article. Not to mention - how to create a file on a Mac OS? On windows it is left click and voila. Anyway. I manage to start the installation process from .iso file which I copied on the 16GB fat32 USB. And at the end it froze. Both - live and minimal. The same story with .iso file on the HDD of my mac. Everything went just great and exactly like on vids from linux channels on youTube until the finishing of the installation which never came.
    I have no access to grub from virtualbox, because I suppose options which are on it from ver. 5 are not on the older version.

    Any ideas?

    Specs:
    MBW 2008. Intel core 2 duo., 2,5 GB RAM, 120 GB HDD, Intel GMA X3100 144 MB. Mac OS X 10.7.5 Lion. 35 GB free space.

    On VB it got 1 core, 1,4 GB RAM, 20 GB HDD, 3d acceleration.
    Live session starts normally. Installation can’t be finished. Tried Gnome and Openbox.

    Thanks.
    Luke

  • @und3dpix

    On VB, 1,4GB is a bit low, but I understand you don’t have much available RAM for your VM. On the other hand, you don’t need 20GB (you can test it with 10GB) and I’d remove the 3D acceleration option, too.

    Having said that, I see no reason why the installation does not work. Could you try again and post here the log? The file is created in /tmp/cnchi.log (if I recall correctly). Oh, if it’s to big use pastebin or some similar service.

    Thanks!

macbook white1 mac os lion1 virtualbox 4.31 Posts 2Views 358
Log in to reply