• Virtualbox 5.1 will not start


    Hi

    I have installed Virtualbox in the past by using;

    pacman -S linux-headers

    pacman -S virtualbox virtualbox-guest-iso

    pacman -S vde2 net-tools virtualbox-ext-vnc

    modprobe vboxdrv

    nano /etc/modules-load.d/virtualbox.conf

    Then pasted the following;
    vboxdrv
    vboxnetadp
    vboxnetflt
    vboxpci

    gpasswd -a user vboxusers

    I also installed QT4

    Today I did a fresh install of Antergos, and tried to install Virtulabox 5.1 (as above) afterwhich it would not launch.

    Any suggestions or help is appreciated in advance!

    Steve

  • @deepthought42

    https://wiki.archlinux.org/index.php/VirtualBox#Install_the_core_packages

    i havent used virtualbox in a while myself but apparently there are some recent changes in how it works on Arch. check out this thread
    https://bbs.archlinux.org/viewtopic.php?id=209780

    maybe someone else here can chime in if they have a recent install on Antergos.

    ill get it added to the wiki once we have clear instructions on the installation. this seems to be a popular question on here.

  • (OFF TOPIC)
    For peace of mind, you could have a look at Gnome Boxes. Not must configurability but it does work perfectly out of the box.
    Check this out:
    https://www.youtube.com/watch?v=SilubPpjBuI

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Maybe just me but Virtualbox 5.1 has some issues. My Windows7 VM would just crash randomly. Transparent mode is extremely laggy, and the mouse cursor is not displayed correctly. I rolled back my Virtualbox packages to 5.0.24. Now everything runs fine, so it is definitely an issue with 5.1.

  • @bmeister @megaman @anarch
    Guys, I have just tried Boxes but sadly it rejects my USB devices.
    As for rolling back, could anyone please tell me how to install Virtualbox any other version than 5.1 such as 5.0.24. which I had before but can not find now.

    Thanks
    Steve

  • The wiki page is here: https://wiki.archlinux.org/index.php/downgrading_packages

    I did this as root user using su -

    # cd /var/cache/pacman/pkg/
    

    If you look in that directory you will find the files starting with the name virtualbox. These are the packages I downgraded too, I am not sure if you are using all of these but I was:
    virtualbox-5.0.24-1-x86_64.pkg.tar.xz
    virtualbox-ext-vnc-5.0.24-1-x86_64.pkg.tar.xz
    virtualbox-guest-iso-5.0.24-1-any.pkg.tar.xz
    virtualbox-host-dkms-5.0.24-1-x86_64.pkg.tar.xz

    Downgrade to each of those packages as root user using:

    # pacman -U <file_name_of_the_package>
    

    You will need to reboot once completed. You should then be using 5.0.24.

  • Hi @bmeister

    Firstly, I’m sorry for not making myself clear, which I should of by pointing out that I do not have any Virtualbox (of any verison) installed!
    Being a noob, could you kindly tell me how to install 5.0.24 from scratch, as your
    suggestion above (if I am not wrong) applies to a downgrade?

    I would appreciate any help, as I can not find any otehr help in installing 5.0.24 from scratch. I am sure it exists but I may not be looking in the right place!
    Many Thanks
    Steve

  • You will need to use the Arch Linux Archive to download and then install the older packages.
    Link:
    https://wiki.archlinux.org/index.php/Arch_Linux_Archive

    Basically download the files I have listed above (I am using 64bit architecture) to your download directory. Then run the command I have listed above from that same download directory. Virtualbox package files can be found here:
    https://archive.archlinux.org/packages/v/

  • @deepthought42 said i

    I have just tried Boxes but sadly it rejects my USB devices

    That s strange. Have you checked that your live media is functional? Also, are there any error messages when your USB media is rejected? Please, try to be as accurate as possible when describing issues.
    A workaround you can do. Fire boxes again but this time use the “file” option you have, not the ISO one. This will open your downloads file. Choose the downloaded ISO file and you will be ready to go.
    Bear in mind that this option is an equivalent to the “try it” option, so after exiting it will be deleted automatically. You have 2 options here. Either you keep it that way and reload it every time (used for testing purposes), or using the installer from therein to install it for good.
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • The latest version of vbox is definitely having some issues, the mouse doesn’t display correctly and I cannot click any options in the options bar, the earliest version did work fine.

    O/S: Antergos Plasma 5 (KF5) 64-bit
    CPU: Pentium Dual-Core CPU E5300 @ 2.6GHz
    GPU: Intel 4 Series Integrated Graphics Controller
    GPU driver: Mesa DRI Intel® G41
    "If you like Antergos, Please donate!"

  • Mine wouldn’t start either. If you start from a terminal you will get

    VirtualBox: supR3HardenedMainGetTrustedMain: dlopen("/usr/lib/virtualbox/VirtualBox.so",) failed: libQt5X11Extras.so.5: cannot open shared object file: No such file or directory

    You will need to add qt5-x11extras.

5.11 virtualbox22 Posts 12Views 1661
Log in to reply