• Steam not starting


    Today I tried to start steam. It failed to start this is the terminal output:

    [[email protected] ~]$ /usr/bin/steam %U
    /home/cubbybear/.local/share/Steam/steam.sh: line 161: VERSION_ID: unbound variable
    /home/cubbybear/.local/share/Steam/steam.sh: line 161: VERSION_ID: unbound variable
    Running Steam on antergos 64-bit
    /home/cubbybear/.local/share/Steam/steam.sh: line 161: VERSION_ID: unbound variable
    STEAM_RUNTIME is enabled automatically
    Installing breakpad exception handler for appid(steam)/version(0)
    libGL error: unable to load driver: i965_dri.so
    libGL error: driver pointer missing
    libGL error: failed to load driver: i965
    libGL error: unable to load driver: swrast_dri.so
    libGL error: failed to load driver: swrast

    Is there any fixes for this?

  • Execute this command before and after data download:

    find ~/.steam/root/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete
    
  • The command produce this error. syntax error near unexpected token `('
    thanks for your help

  • @ralphdewitt Fixed. Now the command should work.

  • Thanks for your help. This has gotten steam working. One more question will I have to run this every time I run steam?

  • @ralphdewitt Nope, only after client updates. Or you can just set environment variables for libraries.

steam64 starting22 Posts 6Views 1240
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.