• Pulsaudio problem


    I installed antergos with Cinnamom, works fine, but if i go to Sound settings and change the Output device, sound from my speackers disappears and never returns.
    I can fix it by removing the

    rm ~/.congig/bla-bla-bla--card-database.tdb
    

    and restarting pulsaudio

    pulsaudio -k && pulsaudio --start
    

    But it’s the only way to do it. Any ideas?

    >>>pacmd list-sinks | grep -e 'name:' -e 'index'
       index: 0
    	name: <alsa_output.pci-0000_01_00.1.hdmi-stereo>
        index: 2
    	name: <alsa_output.pci-0000_00_14.2.iec958-stereo>
        index: 3
    	name: <combined>
      * index: 12
    	name: <alsa_output.usb-C-Media_Electronics_Inc._Bloody_Gaming_Audio_Device-00.iec958-stereo>
    >>>cat /proc/asound/cards                                      
     0 [SB             ]: HDA-Intel - HDA ATI SB
                          HDA ATI SB at 0xfbff4000 irq 16
     1 [NVidia         ]: HDA-Intel - HDA NVidia
                          HDA NVidia at 0xfe77c000 irq 19
     2 [U0x46d0x825    ]: USB-Audio - USB Device 0x46d:0x825
                          USB Device 0x46d:0x825 at usb-0000:00:12.2-4, high speed
     3 [Device         ]: USB-Audio - Bloody Gaming Audio Device
                          C-Media Electronics Inc. Bloody Gaming Audio Device at usb-0000:00:12.0-1, full
    >>>aplay -l                                                    
    **** List of PLAYBACK Hardware Devices ****
    card 0: SB [HDA ATI SB], device 0: ALC892 Analog [ALC892 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: SB [HDA ATI SB], device 1: ALC892 Digital [ALC892 Digital]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 3: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 7: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 8: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 1: NVidia [HDA NVidia], device 9: HDMI 0 [HDMI 0]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 3: Device [Bloody Gaming Audio Device], device 0: USB Audio [USB Audio]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    
    
  • Hi,

    Can you install pavucontrol and test if it has the same behaviour as Cinnamon’s sound settings?

    Cheers!

  • @karasu tested it and i believe it’s a Cinnamon Sound Applet’s bug. Befor touching anuthing in it i have

    pactl list sinks

    index: 2
    name: <alsa_output.pci-0000_00_14.2.iec958-stereo>
    ports: analog-output-lineout:
    Line Out (priority 9900, latency offset 0 usec, available: no)
    properties: analog-output-headphones: Headphones
    (priority 9000, latency offset 0 usec, available: no) properties:
    device.icon_name = "audio-headphones"
    active port: <analog-output-lineout>

    but after it changes soud card properties and ports to

    ports: iec958-stereo-output: Digital Output (S/PDIF) (priority 0, latency offset 0 usec, available: unknown)
    properties: active port: <iec958-stereo-output>

    And obviously i don’t hear anything. pavucontrol is ok.

  • Well, then you should report it upstream ;)

pulsaudio1 Posts 4Views 398
Log in to reply