• Like 0

    Chinese characters indication problem


    I have already installed many Chinese fonts, but I don’t think that it is caused by fonts because those Chinese characters are not squares, but just disappeared. The disappearing of Chinese characters happens in chromium (Web Pages) and even the Chinese input itself (I cannot see selectable characters in list.) Please help me!

    My locale is en_US, UTF8.

    Some screenshots:
    http://i.imgur.com/1trLmRp.png
    http://i.imgur.com/SlY7gWZ.png —> Really weird it works perfectly when browsing my history…
    http://i.imgur.com/KejsB0K.jpg —> Even the selection list in Chinese input broke…

  • Like 0

    To be honest, it looks like a font problem, but I might be wrong, of course.

    Can you give us a link that does not work for you? This way we can test it.

  • Like 1

    Sorry I forgot to update this post, I solved it by reinstalling ibus and fonts (only preserve Han Sans TW font), it was exactly a font problem, thx for replying me karasu!!! Your answer is very accurate btw xD

  • Like 0

    @mmartin20tw said

    I solved it

    I eddited your thread title so that it reads as “solved”.
    You can do the same if needed in the future.
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Like 0

    @anarch Oh yeah sorry I forgot to mark it as solved, thanks a lot anarch!!!

  • Like 0

    @mmartin20tw , you are always welcome! :+1:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.04 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Like 0

    @mmartin20tw I’m having the same problem. What are the exact font packages you uninstalled? I can’t seem to find any Chinese font installed on my system (idk how it’s even displaying anything in the first place…)

  • Like 0

    Ok for future reference I uninstalled ttf-google-fonts, restarted and everything was fine

  • Like 0

    @arch-of-autumn curious, I didn’t have this installed but I had some font in FF show up as unicode squares, installed ttf-google-fonts and the issue seemed solved. However, I can also confirm that I have some Korean characters not appearing…I can’t remember before or after ttf-google-fonts but the affected site was on a random chinese youtube livestream (in the chat section.) I just tested out some streams now, I found a Vietnemese one without issues and the Jaxa channel appears to render fonts on the “normal” videos fine…

    A bit off-topic, I also installed an emoji font for FF as well: emojione-color-font – it’s pretty cool as it renders full color within FF but reverts to black and white gliph fonts for apps outside of FF (like Corebird for example.) It does change the main system font slightly, but the only issue I’ve had so far while using it is that “lennies” ( ͡° ͜ʖ ͡°) don’t render normally in CS:S, lol.

  • Like 0

    I found some examples of unicode breakage: https://www.youtube.com/watch?v=mkwvc8cwTUA …the Korean set appears heavily broken…however that may be related to my using the system font emojione-color-font…I can’t say for sure. Copying and pasting however, seems to carry over normally to apps like mousepad – which is weird. Can someone do me a solid and see if their Firefox is showing the same behavior?

characters3 indication1 chinese1 Posts 10Views 602
Log in to reply