• Radeon driver problem


    during installation i get an error related to hardware.py:

    2014-02-01 23:45:11,586 - process.py:select\_packages() - DEBUG: Added ['ati'] graphics drivers to the installation  
    2014-02-01 23:45:11,591 - hardware.py:\_\_init\_\_() - ERROR: Error importing I915 from hardware.i915 : No module named 'i915\_db'  
    Traceback (most recent call last):  
    File "/usr/share/cnchi/src/hardware/hardware.py", line 112, in \_\_init\_\_  
    class\_name = getattr(\_\_import\_\_(package, fromlist=[name]), "CLASS\_NAME")  
    File "/usr/share/cnchi/src/hardware/i915.py", line 31, in <module\>  
    from i915\_db import DEVICES  
    ImportError: No module named 'i915\_db'  
    2014-02-01 23:45:11,593 - hardware.py:\_\_init\_\_() - ERROR: Error importing Nvidia from hardware.nvidia : No module named 'nvidia\_db'  
    Traceback (most recent call last):  
    File "/usr/share/cnchi/src/hardware/hardware.py", line 112, in \_\_init\_\_  
    class\_name = getattr(\_\_import\_\_(package, fromlist=[name]), "CLASS\_NAME")  
    File "/usr/share/cnchi/src/hardware/nvidia.py", line 28, in <module\>  
    from nvidia\_db import DEVICES  
    ImportError: No module named 'nvidia\_db'  
    2014-02-01 23:45:11,594 - hardware.py:\_\_init\_\_() - ERROR: Unexpected error importing hardware.i915\_db: 'module' object has no attribute 'CLASS\_NAME'   
    Traceback (most recent call last):  
    File "/usr/share/cnchi/src/hardware/hardware.py", line 112, in \_\_init\_\_  
    class\_name = getattr(\_\_import\_\_(package, fromlist=[name]), "CLASS\_NAME")  
    AttributeError: 'module' object has no attribute 'CLASS\_NAME'  
    2014-02-01 23:45:11,595 - hardware.py:\_\_init\_\_() - ERROR: Error importing Catalyst from hardware.catalyst : No module named 'amd\_ati\_db'  
    Traceback (most recent call last):  
    File "/usr/share/cnchi/src/hardware/hardware.py", line 112, in \_\_init\_\_  
    class\_name = getattr(\_\_import\_\_(package, fromlist=[name]), "CLASS\_NAME")  
    File "/usr/share/cnchi/src/hardware/catalyst.py", line 28, in <module\>  
    from amd\_ati\_db import DEVICES  
    ImportError: No module named 'amd\_ati\_db'  
    2014-02-01 23:45:11,603 - hardware.py:\_\_init\_\_() - ERROR: Unexpected error importing hardware.amd\_ati\_db: 'module' object has no attribute 'CLASS\_NAME'   
    Traceback (most recent call last):  
    File "/usr/share/cnchi/src/hardware/hardware.py", line 112, in \_\_init\_\_  
    class\_name = getattr(\_\_import\_\_(package, fromlist=[name]), "CLASS\_NAME")  
    AttributeError: 'module' object has no attribute 'CLASS\_NAME'  
    2014-02-01 23:45:11,610 - hardware.py:\_\_init\_\_() - ERROR: Unexpected error importing hardware.nvidia\_db: 'module' object has no attribute 'CLASS\_NAME'   
    Traceback (most recent call last):  
    File "/usr/share/cnchi/src/hardware/hardware.py", line 112, in \_\_init\_\_  
    class\_name = getattr(\_\_import\_\_(package, fromlist=[name]), "CLASS\_NAME")  
    AttributeError: 'module' object has no attribute 'CLASS\_NAME'  
    2014-02-01 23:45:11,612 - hardware.py:\_\_init\_\_() - ERROR: Error importing Nouveau from hardware.nouveau : No module named 'nvidia\_db'  
    Traceback (most recent call last):  
    File "/usr/share/cnchi/src/hardware/hardware.py", line 112, in \_\_init\_\_  
    class\_name = getattr(\_\_import\_\_(package, fromlist=[name]), "CLASS\_NAME")  
    File "/usr/share/cnchi/src/hardware/nouveau.py", line 29, in <module\>  
    from nvidia\_db import DEVICES  
    ImportError: No module named 'nvidia\_db'  
    2014-02-01 23:45:11,614 - hardware.py:\_\_init\_\_() - ERROR: Error importing Catalyst-legacy from hardware.catalyst-legacy : No module named 'amd\_ati\_db'  
    Traceback (most recent call last):  
    File "/usr/share/cnchi/src/hardware/hardware.py", line 112, in \_\_init\_\_  
    class\_name = getattr(\_\_import\_\_(package, fromlist=[name]), "CLASS\_NAME")  
    File "/usr/share/cnchi/src/hardware/catalyst-legacy.py", line 28, in <module\>  
    from amd\_ati\_db import DEVICES  
    ImportError: No module named 'amd\_ati\_db'  
    2014-02-01 23:45:11,615 - hardware.py:\_\_init\_\_() - ERROR: Error importing Radeon from hardware.radeon : No module named 'amd\_ati\_db'  
    Traceback (most recent call last):  
    File "/usr/share/cnchi/src/hardware/hardware.py", line 112, in \_\_init\_\_  
    class\_name = getattr(\_\_import\_\_(package, fromlist=[name]), "CLASS\_NAME")  
    File "/usr/share/cnchi/src/hardware/radeon.py", line 29, in <module\>  
    from amd\_ati\_db import DEVICES  
    ImportError: No module named 'amd\_ati\_db'  
    We have more than one driver for this device!  
    What should we do? Ask the user?  
    We have more than one driver for this device!  
    What should we do? Ask the user?  
    We have more than one driver for this device!  
    What should we do? Ask the user?  
    We have more than one driver for this device!  
    What should we do? Ask the user?  
    We have more than one driver for this device!  
    What should we do? Ask the user?  
    We have more than one driver for this device!  
    What should we do? Ask the user?  
    2014-02-01 23:45:11,685 - process.py:select\_packages() - WARNING: Unknown error in hardware module. Output: 'dict' object has no attribute 'extend'
    

    using “lspci -v”(or a different one atleast it was lspci something) it says its using the radeon driver but glxinfo does not exist?

    i am using a HD7870 GHz edition

    also

    2014-02-01 23:45:11,614 - hardware.py:\_\_init\_\_() - ERROR: Error importing Catalyst-legacy from hardware.catalyst-legacy : No module named 'amd\_ati\_db'
    

    catalyst legacy?
    that is for HD4000 and less…

  • during installation i get an error related to hardware.py:

    2014-02-01 23:45:11,586 - process.py:select\_packages() - DEBUG: Added ['ati'] graphics drivers to the installation  
    2014-02-01 23:45:11,591 - hardware.py:\_\_init\_\_() - ERROR: Error importing I915 from hardware.i915 : No module named 'i915\_db'  
    Traceback (most recent call last):  
    File "/usr/share/cnchi/src/hardware/hardware.py", line 112, in \_\_init\_\_  
    class\_name = getattr(\_\_import\_\_(package, fromlist=[name]), "CLASS\_NAME")  
    File "/usr/share/cnchi/src/hardware/i915.py", line 31, in <module\>  
    from i915\_db import DEVICES  
    ImportError: No module named 'i915\_db'  
    2014-02-01 23:45:11,593 - hardware.py:\_\_init\_\_() - ERROR: Error importing Nvidia from hardware.nvidia : No module named 'nvidia\_db'  
    Traceback (most recent call last):  
    File "/usr/share/cnchi/src/hardware/hardware.py", line 112, in \_\_init\_\_  
    class\_name = getattr(\_\_import\_\_(package, fromlist=[name]), "CLASS\_NAME")  
    File "/usr/share/cnchi/src/hardware/nvidia.py", line 28, in <module\>  
    from nvidia\_db import DEVICES  
    ImportError: No module named 'nvidia\_db'  
    2014-02-01 23:45:11,594 - hardware.py:\_\_init\_\_() - ERROR: Unexpected error importing hardware.i915\_db: 'module' object has no attribute 'CLASS\_NAME'   
    Traceback (most recent call last):  
    File "/usr/share/cnchi/src/hardware/hardware.py", line 112, in \_\_init\_\_  
    class\_name = getattr(\_\_import\_\_(package, fromlist=[name]), "CLASS\_NAME")  
    AttributeError: 'module' object has no attribute 'CLASS\_NAME'  
    2014-02-01 23:45:11,595 - hardware.py:\_\_init\_\_() - ERROR: Error importing Catalyst from hardware.catalyst : No module named 'amd\_ati\_db'  
    Traceback (most recent call last):  
    File "/usr/share/cnchi/src/hardware/hardware.py", line 112, in \_\_init\_\_  
    class\_name = getattr(\_\_import\_\_(package, fromlist=[name]), "CLASS\_NAME")  
    File "/usr/share/cnchi/src/hardware/catalyst.py", line 28, in <module\>  
    from amd\_ati\_db import DEVICES  
    ImportError: No module named 'amd\_ati\_db'  
    2014-02-01 23:45:11,603 - hardware.py:\_\_init\_\_() - ERROR: Unexpected error importing hardware.amd\_ati\_db: 'module' object has no attribute 'CLASS\_NAME'   
    Traceback (most recent call last):  
    File "/usr/share/cnchi/src/hardware/hardware.py", line 112, in \_\_init\_\_  
    class\_name = getattr(\_\_import\_\_(package, fromlist=[name]), "CLASS\_NAME")  
    AttributeError: 'module' object has no attribute 'CLASS\_NAME'  
    2014-02-01 23:45:11,610 - hardware.py:\_\_init\_\_() - ERROR: Unexpected error importing hardware.nvidia\_db: 'module' object has no attribute 'CLASS\_NAME'   
    Traceback (most recent call last):  
    File "/usr/share/cnchi/src/hardware/hardware.py", line 112, in \_\_init\_\_  
    class\_name = getattr(\_\_import\_\_(package, fromlist=[name]), "CLASS\_NAME")  
    AttributeError: 'module' object has no attribute 'CLASS\_NAME'  
    2014-02-01 23:45:11,612 - hardware.py:\_\_init\_\_() - ERROR: Error importing Nouveau from hardware.nouveau : No module named 'nvidia\_db'  
    Traceback (most recent call last):  
    File "/usr/share/cnchi/src/hardware/hardware.py", line 112, in \_\_init\_\_  
    class\_name = getattr(\_\_import\_\_(package, fromlist=[name]), "CLASS\_NAME")  
    File "/usr/share/cnchi/src/hardware/nouveau.py", line 29, in <module\>  
    from nvidia\_db import DEVICES  
    ImportError: No module named 'nvidia\_db'  
    2014-02-01 23:45:11,614 - hardware.py:\_\_init\_\_() - ERROR: Error importing Catalyst-legacy from hardware.catalyst-legacy : No module named 'amd\_ati\_db'  
    Traceback (most recent call last):  
    File "/usr/share/cnchi/src/hardware/hardware.py", line 112, in \_\_init\_\_  
    class\_name = getattr(\_\_import\_\_(package, fromlist=[name]), "CLASS\_NAME")  
    File "/usr/share/cnchi/src/hardware/catalyst-legacy.py", line 28, in <module\>  
    from amd\_ati\_db import DEVICES  
    ImportError: No module named 'amd\_ati\_db'  
    2014-02-01 23:45:11,615 - hardware.py:\_\_init\_\_() - ERROR: Error importing Radeon from hardware.radeon : No module named 'amd\_ati\_db'  
    Traceback (most recent call last):  
    File "/usr/share/cnchi/src/hardware/hardware.py", line 112, in \_\_init\_\_  
    class\_name = getattr(\_\_import\_\_(package, fromlist=[name]), "CLASS\_NAME")  
    File "/usr/share/cnchi/src/hardware/radeon.py", line 29, in <module\>  
    from amd\_ati\_db import DEVICES  
    ImportError: No module named 'amd\_ati\_db'  
    We have more than one driver for this device!  
    What should we do? Ask the user?  
    We have more than one driver for this device!  
    What should we do? Ask the user?  
    We have more than one driver for this device!  
    What should we do? Ask the user?  
    We have more than one driver for this device!  
    What should we do? Ask the user?  
    We have more than one driver for this device!  
    What should we do? Ask the user?  
    We have more than one driver for this device!  
    What should we do? Ask the user?  
    2014-02-01 23:45:11,685 - process.py:select\_packages() - WARNING: Unknown error in hardware module. Output: 'dict' object has no attribute 'extend'
    

    using “lspci -v”(or a different one atleast it was lspci something) it says its using the radeon driver but glxinfo does not exist?

    i am using a HD7870 GHz edition

    also

    2014-02-01 23:45:11,614 - hardware.py:\_\_init\_\_() - ERROR: Error importing Catalyst-legacy from hardware.catalyst-legacy : No module named 'amd\_ati\_db'
    

    catalyst legacy?
    that is for HD4000 and less…

  • Hi Fpsgamer101,

    Thanks for your tests!!!

    OK, I’m in the middle of rewriting the hardware module, so don’t pay attention to all these errors…

    Also I think you tested lots0logs version, which has an outdated version of the hardware module.

    Please, ignore these errors.

    Cheers!

  • @“karasu”:7ol6ki47 said:

    Hi Fpsgamer101,

    Thanks for your tests!!!

    OK, I’m in the middle of rewriting the hardware module, so don’t pay attention to all these errors…

    Also I think you tested lots0logs version, which has an outdated version of the hardware module.

    Please, ignore these errors.

    Cheers![/quote:7ol6ki47]
    ok but that means my driver wil no be working out if the box for now…
    let the waiting game begin

  • ok but that means my driver wil no be working out if the box for now…

    Don’t worry, we’re still using the old method, so if it worked before it will work now.

    Cheers!

  • @“karasu”:r8kmypo0 said:

    ok but that means my driver wil no be working out if the box for now…

    Don’t worry, we’re still using the old method, so if it worked before it will work now.

    Cheers!

    well about that…
    it seems the drivers are not realy working correctly
    (at least mesa is not)since i cant use glxinfo
    and(i dont know if its still there but) on the last install i did with cinnamon i got the problem where the screen will not update and when i grab a window it will “draw” that window wherever it goes past(think windows xp program not responding window)

Posts 6Views 1414
Log in to reply