• Can't choose Manjaro from Grub


    I’m trying to post my problem but I get a message that akismet says my post is spam.

  • I just replaced my old hard drive with a new AAD. I first installed a version of Manjaro which worked fine. I then installed the current version of Antergos and it works fine. However, after the Antergos installation, when I boot up and get the Grub menu, if I select the Manjaro installation, it wont boot up. The Antergos is still fine, but I can’t get to the Manjaro.

    When I select the Manjaro I get the following messages.

    Some lines that were similar to the lines below but I don’t think are useful (but I could be wrong).

    [   0.245472] [<ffffffff81908274>] kernel offset disbled
    [   0.245472] [<ffffffff81908274>] - not syncing:VFS: Unable to mount root fs on unknown-block (0,0)
    

    What should I do? I’d prefer NOT to RE-install the Manajaro if that can be avoided.[link text]([link url](link url))

  • This post is deleted!
  • Hi,

    The Akismet problem can be that your post was too long, and then it thinks it’s spam. Sorry for that.

    Anyway, let’s back to your real problem.

    It seems that grub didn’t setup your Manjaro installation correctly. As you installed Antergos afterwards, it’s Antergos Grub who manages your boot. Boot into Antergos and check:

    1. Reinstall Grub: sudo grub-install /dev/sda
    2. Recreate boot menu: sudo grub-mkconfig -o /boot/grub/grub.cfg

    When doing ‘2’, check that your Manjaro installation is found.

    It could be that grub is not finding your Manjaro installation where it should. In Antergos, check your partition’s uuids with ls -l /dev/disks/by-uuid. Write them down. Then, reboot and select the Manjaro option but do not hit enter but the key ‘e’. This way you will be able to check where grub is trying to boot Manjaro. You should check that the UUID’s for your Manjaro partition are correct.

  • Before I did steps 1 and 2 I did the last paragraph and the UUID in the GRUB entry for the Manjaro is correct. Should I still reinstall Grub?

  • Actually, I decided to try reinstalling Grub anyway. When I did the config I got:

    Generating grub configuration file …
    Tema encontrado: /boot/grub/themes/Antergos-Default/theme.txt
    Imagem Linux encontrada: /boot/vmlinuz-linux
    Imagem initrd encontrada: /boot/initramfs-linux.img
    Found fallback initramfs image: /boot/initramfs-linux-fallback.img
    Encontrado Manjaro Linux (16.06-pre1) em /dev/sda2
    concluído

    Sorry this is in Português but my system is in Português. It basically says that it found Manjaro Linux (16.06-pre1) on /dev/sda2 but there are no Linux image or initrd lines for the Manjaro. What should I do?

  • After reinstalling and rebooting, I still have the same result.

  • Sorry this is in Português but my system is in Português.

    Do not worry, I can understand it ;)

    Can you post here the result of lsblk -a -o NAME,TYPE,UUID from the Antergos system ?

  • NAME TYPE UUID
    sda disk
    ├─sda1 part 98e59c7e-2a9f-4e7b-81ee-49ff5e1f130a
    ├─sda2 part 6866e75c-cf8b-49a2-bb86-9e552eeffb97
    ├─sda3 part 15af6e2a-b2ca-4617-b7ec-3da37941820e
    └─sda4 part b22ef976-ea38-4bf4-8a79-b5091fd69061

    Notes: sda1 is pretty small, 1049 MB and was originally intended for boot.
    sda2 is the Manjaro installation 26.2 GB
    sda3 is the antergos installation 26.2 GB
    sda4 is the partition Iuse for storing all of my files so they’re easily accessible to both Linux installations 187 GB

  • Also, despite sda1 originally being INTENDED for boot, it is unused and sda3 is the partition with the boot flag.

  • Also, despite sda1 originally being INTENDED for boot, it is unused and sda3 is the partition with the boot flag.

    Do you mean that sda1 is neither used by Manjaro nor Antergos?

    OK. Now we need to see Grub setup file. Can you post /boot/grub/grub.cfg elsewhere (like paste2.org) and post the link here so we can see it?

  • Yes, as far as I know, sda1 is not used by either os and is empty.

    the grub.cfg is at:
    http://paste2.org/DbVbZ640

  • Hi

    Something is clearly wrong here. Your grub.cfg says that:

    Your Antergos installation is in /dev/sda4 (b22ef976-ea38-4bf4-8a79-b5091fd69061) which is wrong ¿?

    Your Manjaro installation is in /dev/sda2 (6866e75c-cf8b-49a2-bb86-9e552eeffb97) which is ok ¿?

    Can you boot Antergos and check which one is your root partition? Also, can you run this command from Antergos so we know for sure you’re using Antergos’ grub and not Manjaro’s ?
    sudo grub-install /dev/sda

  • "If you are basing your statement “Your Antergos installation is in /dev/sda4 (b22ef976-ea38-4bf4-8a79-b5091fd69061) which is wrong ¿?” on the information below (which I originally provided above), I need to apologize. I see that what I typed wasn’t correct. I typed them in the order they appeared in my terminal, but didn’t notice that they weren’t in numerical order, i.e. sda1 then 2, 3 and 4. They were actually in order sda1, sda2, sda4, sda3. I’ve copied the original INCORRECT note below and the corrected note below that. And below that, I’ve printed out the output of the print command in parted. This output indicates sda4 has an option of “boot”, which I assume means this is the boot partition. Regarding root, I’m not sure how to check that, but in the left pane of Thunar, when I go to the three volumes listed there (and I have to mount them to go to them) the only uuid not accounted for is b22ef976-ea38-4bf4-8a79-b5091fd69061, which I assume is the root partition, which is as I’d expect.
    I’m not sure if this is the information you wanted, but I hope so. Also, as noted in a post above, I already reinstalled grub a few days ago.

    Notes: sda1 is pretty small, 1049 MB and was originally intended for boot.
    sda2 is the Manjaro installation 26.2 GB
    sda3 is the antergos installation 26.2 GB
    sda4 is the partition Iuse for storing all of my files so they’re easily accessible to both Linux installations 187 GB

    The correct note should have been:
    Notes: sda1 is pretty small, 1049 MB and was originally intended for boot.
    sda2 is the Manjaro installation 26.2 GB
    sda4 is the antergos installation 26.2 GB
    sda3 is the partition Iuse for storing all of my files so they’re easily accessible to both Linux installations 187 GB

    Número Início Fim Tamanho Tipo Sistema de arquivos Opções
    1 1049kB 1050MB 1049MB primary ext2
    2 1050MB 27,3GB 26,2GB primary ext4
    4 27,3GB 53,5GB 26,2GB primary ext4 boot
    3 53,5GB 240GB 187GB primary ext4

  • OK, this explains your grub.cfg, which looks good.

    I don’t see why is not booting. Select Manjaro option in grub but do not press enter. Press 'e' and remove the quiet parameter. Press F10 to boot. What do you see?

  • I’m not sure if I understand this, but I got to the edit screen for Manjaro, found a line that started with linux and near the end there was “rw quiet (and something else-I don’t remember what)”. I deleted the “quiet” and looked for a way to save, but didn’t see any. I thendid F10 and just got the same result as before. When I tried again, the word “quiet” was back in the place I had deleted it from before. Again, I looked for a way to save the edit, but couldn’t find a way to save.

  • You did it right. Removing the quiet parameter this way is not permanent. I wanted to see if it was hidding some information (the quiet parameter tells the kernel to not to show information to the terminal unless it’s a fatal error).

    Main problem here is that we are not able to determine exactly what is causing your boot issue.

    Let’s try this:

    1. When grub shows up, Instead of pressing e press c. That will take you to a command prompt.
    2. Type ls and press enter. This should list your disks and partitions. Post the result here, please.
    3. Type ls (hd0,1)/ You should see your Manjaro installation. Post the results here, please.
    4. Type ls (hd0,1)/boot/ You should see your Manjaro boot directory. Post the results here, please.

    The other option could be to boot with a livecd, chroot to your Manjaro partition and reinstall Manjaro’s grub from there (https://wiki.archlinux.org/index.php/change_root#Using_arch-chroot)

  • ls => (hd0) (hd0,msdos4) (hd0,msdos3) (hd0,msdos2) (hd0,msdos1)

    ls (hd0,1) => Partição hd0,1 Tipo de sistema de arquivos ext* - Hora da última modificação 2016-07-12 00:30:34 Terça-feira, UUID 98E59c7e-2a9f-4e7b-81ee-49ff5e1f130a - A partição começa em 1024 KiB – Tamanho total 1024000 KiB
    KiBENGLISH TRANSLATION: Partition hd0,1 file system type ext* - last modified 2016-07-12 00:30:34 Tuesday, UUID 98E59c7e-2a9f-4e7b-81ee-49ff5e1f130a - The partition starts at 1024 KiB – Total size 1024000 KiB

    ls (hd0,1)/boot/ => erro: arquivo ‘/boot’ não encontrado
    ENGLISH TRANSLATION: error: file ‘/boot’ not found

  • I looked at the link you provided for reinstalling the Manjaro Grub, but I didn’t understand it. I did a search and found easier to understand instructions. They are below. But these instructions don’t say anything about running grub-mkconfig. Do I need to do this also immediately after I reinstall Grub using this method?

    On this post, I’m going to explain a particular technique that works only on Arch Linux. First or all, we need to download the latest Arch Linux iso from here and boot it from a USB flash drive (you can use ImageWriter) or burn it on a CD.
    After you boot into the Arch Linux live CD, you need to run these commands:
    mount -t ext4 /dev/sda1 /mnt
    Where /dev/sda1 is the partition where Arch Linux is installed.
    After this step you need to run this command in order to chroot into your Arch Linux installation:
    arch-chroot /mnt
    This command only works with Arch Linux, but you can replace it with the correct chroot command if you’re using a different Linux distribution.
    Finally, it’s possible to reinstall Grub running this command
    grub-install /dev/sda
    Obviously you may need to replace /dev/sda by whatever drive you are booting from.

  • But these instructions don’t say anything about running grub-mkconfig

    Yes, you must run it or you won’t be able to boot Antergos then :grin:

    sudo grub-mkconfig -o /boot/grub/grub.cfg.

    In those instructions, you have to change sda1 for your Manjaro partition.

manjaro10 choose6 grub79 Posts 21Views 3139
Log in to reply