• Boot halt at white screen with antergos logo


    My spec: ASUS GL552VW laptop
    I wait for almost 10 minutes so I think it’s stuck…
    Please help me with it xD Thx a lot!

    http://imgur.com/vliOtQJ
    http://imgur.com/hHLT6Ux

  • @mmartin20tw I don’t remember the exact boot line in the Antergos ISO, but remove from it two parameters before booting:

    quiet splash
    

    This will remove the plymouth theme (the “white screen with antergos logo”) and will display (a lot of) text messages during boot.

    These messages may contain an info about the problem. It is usually contained in few final messages.

  • @just Thx for the info. I will post the error messages ASAP!

  • http://i.imgur.com/45QtNO0.jpg

    This is a pic about its final messages, I think it might be the problem with the two graphic cards (hybrid graphics with intel chip and nvidia GTX960M) in my laptop?

    So maybe adding “i915.i915_enable_rc6=0” to the boot parameters will help?
    https://bbs.archlinux.org/viewtopic.php?id=162017

    Thx for your fast reply Just :D

  • @mmartin20tw Rather than graphic cards, it seems to be the usual devastation generated by malefic nouveau driver on Optimus computers. Let’s start trying to exclude it from boot sequence.

    Try to boot adding only one of these parameter(s) at a time (so there will be four boot attempts):

    • nomodoset
    • modprobe.blacklist=nouveau
    • nomodeset, drm.modeset=0, nouveau.modeset=0
    • xdriver=intel

    Some parameters may be not suitable for the kernel, used by Antergos. Don’t worry, they won’t hurt anything - kernel will simply ignore them.

  • The first parameter works perfectly, I will keep trying other ones.

  • Second one works perfectly too :)

    BTW first parameter made my laptop fan run at full speed and failed to shutdown, is that normal?

  • Third one made me stuck at black login screen, just like last time I tried to boot it on vmware virtual machine xD

    http://i.imgur.com/pEKoMbB.jpg

  • The last one give me the exactly same halt as direct boot (stuck at “[ok] Started Accounts Service”)

    First one worked but it somehow set my fan at full speed and stop me from shutdown (some error messages kept popping up, but I forgot to record it)

    I think the best option now is the second one —> modprobe.blacklist=nouveau

    Since my dorm net was cut off because I exceed daily limit xD , I will tell you when I have internet and free time. Thx a lot Just! Thx for your fast reply and patience. :D

  • @mmartin20tw said in Boot halt at white screen with antergos logo:

    Second one works perfectly too :)

    OK. I highly recommend to uninstall the nouveau video driver - xf86-video-nouveau package - right after a fresh Antergos installation. It’s a root of all disasters on Optimus computers.

    BTW first parameter made my laptop fan run at full speed and failed to shutdown, is that normal?

    It doesn’t seem to be normal. But I’m trying to avoid Asus hardware at all costs. It always been a total disaster in my experience :) .

  • @just Thx for the info xD . So I need to install nvidia one instead right?
    (https://wiki.archlinux.org/index.php/Bumblebee
    "Installing Bumblebee with Intel/NVIDIA")

    Hope mine can work fine lol.

  • @mmartin20tw said in Boot halt at white screen with antergos logo:

    @just Thx for the info xD . So I need to install nvidia one instead right?
    (https://wiki.archlinux.org/index.php/Bumblebee
    "Installing Bumblebee with Intel/NVIDIA")

    Hope mine can work fine lol.

    Forget about ArchWiki article. It’s a huge overkill for novice Bumblebee users on Arch Linux. Use Antergos Wiki Bumblebee article instead.

    And remember to not enable proprietary Nvidia drivers during Antergos installation. Otherwise the system will not boot again.

  • @just So after I boot into live session and install with modprobe.blacklist=nouveau, I still need to use modprobe.blacklist=nouveau to boot into arch on my hard disk for the first time right? Later on with bumblebee installed I can boot normally?

    BTW the article mentioned that there are one type that is BIOS controlled. If there is no similar setting option in my BIOS means that my laptop is first one right?

  • @mmartin20tw said in Boot halt at white screen with antergos logo:

    @just So after I boot into live session and install with modprobe.blacklist=nouveau, I still need to use modprobe.blacklist=nouveau to boot into arch on my hard disk for the first time right?

    Right. But once xf86-video-nouveau has been uninstalled, the modprobe.blacklist=nouveau is not needed anymore. And may be removed forever from the boot line.

    Before installing Bumblebee, make sure that the system runs on xf86-video-intel driver. It should the only one installed. Just search in pamac for xf86-video-. None other video drivers are needed.

    Later on with bumblebee installed I can boot normally?

    Yes. Moreover, you’ll be able to boot normally immediately after the xf86-video-nouveveau uninstallation.

    BTW the article mentioned that there are one type that is BIOS controlled. If there is no similar setting option in my BIOS means that my laptop is first one right?

    Right. Computers without a BIOS that controls the video card are most Bumblebee-friendly. Bmb is usually installs and runs without a hitch on them.

    A final note about ArchWiki Bmb article. It’s way too perfect. Too exhaustive. If Bmb will work for you after following Antergos Wiki, most probably you’ll never be in need to read the ArchWiki about Bmb.

  • @just Thank you very much moderator! Your description is very clear :D . If I encountered any problem or error I will report again :) Thanks for your patience again :D

  • @mmartin20tw said in Boot halt at white screen with antergos logo:

    @just Thank you very much moderator!

    You’re welcome.

    Your description is very clear :D

    Rem tene, verba sequentur.

    Regards

  • @just I just finished installation, I boot into the system with e and added the second parameter. My fan is at full speed and I am not sure how to list drivers and uninstall nouveau. Please help me xD

    Edit: I just found out how to uninstall xf86-video-nouveau, but I don’t know how to check if xf86-video-intel is the only working one

    Edit: besides full-speed-fan, the reboot or shutdown stuck and there is an error message:

    shutdown[1]: Failed to finalize file systems ignoring
    INFO: task lspci:2478 blocked for more than 120 seconds.
    Not tainted 4.6.3-1ARCH #1

  • @mmartin20tw said in Boot halt at white screen with antergos logo:

    Please, follow the good rule - one problem, one post. Mixing many issues in one post is a bad practice.

    @just I just finished installation, I boot into the system with e and added the second parameter. My fan is at full speed and I am not sure how to list drivers and uninstall nouveau. Please help me xD

    If you have already installed Bumblebee, run once any command with optirun. For example:

    optirun pwd
    

    The command iself (pwd here) doesn’t matter. Cooling fans spinning at max speed mean that the system runs on Nvidia. Optirun on exit must switch Nvidia GPU off. After some seconds the fans should slow down.

    Then again, I hate Asus hardware. For me, everything works in a wrong way on it, so it’s almost impossible to manage it in a decent way.

    Edit: I just found out how to uninstall xf86-video-nouveau, but I don’t know how to check if xf86-video-intel is the only working one

    In two modes;

    1. Search for xf86-video- in pamac. Only xf86-video-intel must be marked as installed (checked). All other packages must be unchecked.

    2. Install inxi and mesa-demos packages. Run inxi as follow:

      inxi -Gxx
      

      It will display all info about video driver(s) in use in a human-readable format.

    Edit: besides full-speed-fan, the reboot or shutdown stuck and there is an error message:

    shutdown[1]: Failed to finalize file systems ignoring
    INFO: task lspci:2478 blocked for more than 120 seconds.
    Not tainted 4.6.3-1ARCH #1

    Never seen smth similar before. Have no idea what it could be.

  • @just Thank you for the info, I’ll open a new post for shutdown problem, I am sorry that I broke the rule.

  • @mmartin20tw No apologizes needed, we are all learning constantly. No problem.

    Take a look… No, read carefully How To Ask Questions The Smart Way article. It’s very instructive. Helps a lot to “survive” :) in forums .

boot150 halt2 white8 Posts 21Views 2255
Log in to reply