• Can't choose between bootloaders (grub or systemd-boot)


    Hi there,

    Long time Antergos user, first post here ;-)

    I’m trying to install Antergos on my new XPS 13, and I have the exact same problem than these guys here :
    https://forum.antergos.com/topic/4078/grub-error-no-such-device-after-install

    It seems like installing systemd-boot would solve my problem. They say they can choose the option in the GUI installer, but I can’t seem to find it. Immediately after the partition screen, I have a screen asking where to install the bootloader, but that’s it.

    Is this a bug, or am I doing something wrong?

  • Hi,

    systemd-boot is an UEFI loader. As you say it’s a new XPS, it should be UEFI based. Check your BIOS for a “Legacy BIOS” option and disable it. Also, check that “Secure boot” is disabled.

    Cnchi (Antergos Installer) does not let you choose systemd-boot if UEFI is not detected.

    Cheers!

  • It works!

    I should have thought of this sooner. Thanks!

  • @karasu It works also for me. Thanks for the help.

  • @pierrep56 Interesting, this thread is very old and I did not notice a systemd option for booting my Thinkpad, which was set to UEFI-only in the BIOS when I installed Antergos.

    I wonder what happened…

    Antergos x86_64 ZFS root w/Cinnamon est Nov 25, 2017 – because after a long week of struggling, I got tired of trying to put Arch on ZFS root…

    "Linux … is more a phenomenon than an OS" - Joekamprad

boot loader8 xps-131 grub80 systemd-boot4 Posts 5Views 4094
Log in to reply