• Partition Table Empty - Installing from USB


    Re: Partition Table empty!

    Hi, I am trying to install Antergos from a USB - dual boot with WIndows 10 - As with the guy in the referenced question the partition table is empty when I choose ‘Exactly’ where to install it. I have created a partition in WIndows.

    I tried to follow the advice in the above question but I am unable to install gparted.

    warning: could not get file information for usr/share/doc/nano/fr/nano.1.html
    warning: could not get file information for usr/share/doc/nano/fr/nanorc.5.html
    warning: could not get file information for usr/share/doc/nano/fr/rnano.1.html
    warning: could not get file information for usr/share/doc/nano/nano.1.html
    warning: could not get file information for usr/share/doc/nano/nanorc.5.html
    warning: could not get file information for usr/share/doc/nano/rnano.1.html
    warning: could not get file information for usr/share/info/nano.info.gz
    warning: could not get file information for usr/share/info/wget.info.gz
    error: Partition / too full: 10726 blocks needed, 615 blocks free
    error: not enough free disk space
    error: failed to commit transaction (not enough free disk space)
    Errors occurred, no packages were upgraded.
    

    Not sure why there shouldn’t be enough space, the USB stick is 64GB and only has Antergos’ exploded ISO on there.

    Can someone help? I just want my partition table to show the partition that I have created for Antergos.

    Thanks, Dec

  • @declan.treanor
    AFAIK When you properly make the USB live (from the latest ISO), there is a gparted already installed (with the gnome environment). I recommend using utility called “Rufus” on windows and “dd” or “pv” on linux. In installation wizard (Cnchi) you should install bootloader to your device and then check if boot flag was set to a correct partition.

  • You were quite right gparted was available already available on the live USB. I ran it but the partition I had created inside Windows does not appear. Only he memory stick shows up. Any ideas? I want install antergos as a dual boot on my Windows machine (not on the USB)

  • Hi,

    Did you change the device in GParted? It’s a combo box in the top right, you should select /dev/sda (which should be your first hard drive).

    (sorry if it was too obvious and only USB is showing there).

  • Don’t worry nothing is too obvious to me. I double checked and it does appear as though only my USB key appears. I tried refreshing devices but still only one. See screenshot. Thanks.0_1467699462025_gparted-screen.png

  • It sort of makes sense to me that it only shows my usb stick; I am in ‘Try it’ mode. However the original issue is that when I attempt to install it, the only drive that shows up when I want to choose where to install, is the USB key. Someone suggested that I could fix this in ‘Try It’ mode with gparted. However all I see in gparted is the USB key. It’s a vicious cycle :) . There is only one option in the drop down in the top-right in gparted.

    [antergos@ant-16 dev]$ lsblk
    NAME   MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
    sda      8:0    1 57.9G  0 disk 
    └─sda1   8:1    1 57.9G  0 part /run/archiso/bootmnt
    loop0    7:0    0  1.6G  1 loop /run/archiso/sfs/root-image
    
    

    That’s my USB key.

  • Hi,

    That’s odd. It should list your harddisk, too. Just out of curiosity, could you post here the result of running inxi? You have to install it first:
    sudo pacman -S inxi
    and then run it this way:
    sudo inxi -v 6

    Cheers!

  • Here’s the output:

    [antergos@ant-16 ~]$ sudo inxi -v 6
    Resuming in non X mode: xdpyinfo not found. For package install advice run: inxi --recommends
    System:    Host: ant-16.6 Kernel: 4.6.2-1-ARCH x86_64 (64 bit gcc: 6.1.1)
               Desktop: N/A dm: lightdm Distro: Antergos Linux
    Machine:   System: Dell (portable) product: XPS 15 9550 serial: 7870R72
               Mobo: Dell model: 0N7TVV v: A01 serial: /7870R72/CN1296364L02CC/
               Bios: Dell v: 01.02.00 date: 04/07/2016
               Chassis: type: 9 serial: 7870R72
    Battery    BAT0: charge: 58.8 Wh 82.5% condition: 71.2/73.7 Wh (97%)
               volts: 12.1/11.4
               model: SMP DELL 1P6KD54 serial: 1149 status: Discharging
    CPU:       Quad core Intel Core i7-6700HQ (-HT-MCP-) cache: 6144 KB
               flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 20745
               clock speeds: min/max: 800/3500 MHz 1: 800 MHz 2: 896 MHz
               3: 800 MHz 4: 800 MHz 5: 899 MHz 6: 800 MHz 7: 800 MHz 8: 850 MHz
    Memory:    Using dmidecode: dmidecode is not installed.
    Graphics:  Card-1: Intel Skylake Integrated Graphics
               bus-ID: 00:02.0 chip-ID: 8086:191b
               Card-2: NVIDIA GM107M [GeForce GTX 960M]
               bus-ID: 01:00.0 chip-ID: 10de:139b
               Display Server: X.org 1.18.3 drivers: nouveau,intel (unloaded: fbdev,vesa)
               tty size: 80x24 Advanced Data: N/A for root
    Audio:     Card Intel Sunrise Point-H HD Audio
               driver: snd_hda_intel bus-ID: 00:1f.3 chip-ID: 8086:a170
               Sound: Advanced Linux Sound Architecture v: k4.6.2-1-ARCH
    Network:   Card: Broadcom BCM43602 802.11ac Wireless LAN SoC
               bus-ID: 02:00.0 chip-ID: 14e4:43ba
               IF: N/A state: N/A mac: N/A
    Drives:    HDD Total Size: 62.2GB (2.9% used)
               ID-1: USB /dev/sda model: Ultra size: 62.2GB serial: 4C530001290224100050-0:0
               Optical: No optical drives detected.
    Partition: ID-1: /run/archiso/bootmnt size: 58G used: 1.7G (3%) fs: vfat dev: /dev/sda1
               label: ANTERGOS uuid: 0DE6-351E
               ID-2: / size: 320M used: 47M (15%) fs: overlay dev: /dev/root-image
               label: N/A uuid: N/A
    Unmounted: No unmounted partitions detected
    Sensors:   None detected - is lm-sensors installed and configured?
    Info:      Processes: 219 Uptime: 4 min Memory: 960.4/15601.7MB
               Init: systemd v: 230 Gcc sys: 6.1.1
               Client: Shell (sudo running in bash) inxi: 2.3.0 
    
    
  • @declan.treanor

    Which mode is selected in BIOS for your harddisk? It should read AHCI/SATA and I bet you have it in IDE mode.

    But be warned, if you change it you’ll have to reinstall windows as it won’t boot in AHCI/SATA mode without a reinstallation.

  • @karasu you were correct. The hard disk was in RAID mode; I switched it to AHCI mode and stuff started showing up in my partition table. It has lead to other issues, so I think I will reinstall Windows10 and choose AHCI mode during the process if that’s possible (I was able to switch it in BIOS without a reinstall). But I think this is solved as per the initial query.

    In case anyone has the same issue, My machine is a Dell XPS 15 with Solid State Disk.

    Sometimes Linux makes me feel like the candidates in Fight Club who had to stand outside the house and get treated like shit, and told to go away, for a week before being allowed in.

  • @declan.treanor said in Partition Table Empty - Installing from USB:

    …I think I will reinstall Windows10…

    Be sure to do it before installing Linux. Otherwise Win will destroy an existing Linux bootloader (Grub, Grub2).

installing58 table2 empty7 partition16 Posts 11Views 1837
Log in to reply