• Desktop is gray, can't change background.


    Hi! The problem is that I can’t change the background and the icons are missing. Also right clicking on the desktop doesn’t show the menu with the options.

    Im using the latest version of Antergos with Xfce 4.12.

    Things I tried already to fix the problem:

    1. Changing the theme.
    2. Uninstall Numix themes, because they are linked to the problem.
    3. Running “sudo nano /usr/share/themes/Numix-Frost-Light/gtk-3.20/dist/gtk.css” and changing the nautilus background value to transparent.
    4. Manually changing the background with dconf editor.
    5. Uninstall Nautilus

    0_1466958005932_Captura de pantalla_2016-06-26_19-17-35.png

  • @toni.ivelinov.petkov when did this start happening? after an update?

  • 1 week ago after updates. I update my system every day.

    The only thing that I didn’t try for now is to reinstall Xfce, but I think there is more simple solution.

  • @toni.ivelinov.petkov

    I update my system every day.

    Do you keep updating after this happened? Also, I suggest trying out the lts linux kernel, if you haven t already done.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Yes, I updated the system several times after this. I’ll check now the lts kernel now and post the results.

  • All right. Remember to regenerate the grub.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Same problem with LTS kernel.

    0_1466962240474_same.png

  • Unfortunatelly, this is as far as I can go. Unless somebody else comes up with a solution, my practice is searcing on line. Here, I can see similar problems to either the Arch or the xfce forums (and more).
    https://www.google.gr/search?q=Desktop+is+gray%2C+can't+change+background.+xfce4+&ie=utf-8&oe=utf-8&client=firefox-b&gfe_rd=cr&ei=nxhwV7rRFqmN8Qf76JLQBg

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Restoring Xfce to default settings also didn’t work. Last step is to reinstall completely the Xfce. I’ll try it now and post the results. Please, do not mark as solved.

  • @toni.ivelinov.petkov s

    Please, do not mark as solved
    Ok. Best of luck!
    You mark it as solved, not us…:+1:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Well, the only solution is to reinstall Xfce. Switching to Cinnamon due to instability with Xfce.

    GG!

  • @toni.ivelinov.petkov i would have to agree with that. xfce seems to be falling behind. if you are looking for something close to xfce i would say “mate” would be very close. cant go wrong with cinnamon though.

  • @megaman said in Desktop is gray, can't change background.:

    …cant go wrong with cinnamon though.

    If you do, the first thing you should do in freshly installed Cinnamon is to reset panel’s applets to default config:

    0_1467145307453_antergos-cinnamon-applets-restore.png

    It will save you a lot of headache with (initially) quircky applets in Antergos-Cinnamon.

gray2 background8 chage1 Posts 13Views 1347
Log in to reply