• No Wifi Live Boot


    Wifi Card: ASUS PCE-N53 PCI-E Adapater Dual-band Wireless-N600

    Idk if their is no support for this Wifi card or what just need some help please.

  • ifconfig wlan0 up
    if no feedback, this is good.
    if feedback, this will indicate a problem.

    prepare to scan for wireless.
    iwlist wlan0 scan
    find the network that is available along with (if it is using WPA2, for example).

    Now prepare to configure your wireless
    ifconfig wlan0 essid THE-NAME-OF-YOUR-NETWORK-ID key YOUR-WIRELESS_KEY

    Note the word key in between.
    iwconfig defaults to HEX keys.
    If you want to use ascii, then add the a prefix s
    iwconfig wlan0 essid THE-NAME-OF-YOUR-NETWORK-ID key s: YOUR-WIRELESS-KEY

    Now get your IP.
    dhclient wlan0
    If no output then you should be up and running.

    I cannot more strongly encourage you to make use of the Arch Wiki. The information there is vast. Check for “wireless” on the Arch Wiki.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc Here are the result’s I had. http://imgur.com/a/WdpQP

  • I found these drivers for the Wifi Card:

    http://dlcdnet.asus.com/pub/ASUS/wireless/PCE-N53/Linux_PCE_N53_1008.zip

    Now i’m looking for a way to install them on the live disk , could I just insert another USB with these drivers on them and install them that way on the live boot?

    I also own a Netgear WNDA3100 V2 USB adapter if I wanted to use this if it’d make it easier would I first need to remove the PCI-E? if so i’d rather not use that route, as I tried booting with this card as well plugged in and still no wifi.

    If not I could always purchase a PCI-E or USB that has high linux support if any suggestions.

  • I see your interface does not support scanning. Hmm. Nice.
    Ok, so first of all,

    1. Could you please use the code tags rather than images. There is a sticky somewhere in the forums on how to correctly use code tags for output.
    2. You have a driver. That is good.
    3. what alias is your adapter.
      Do ifconfig eth0
      ifconfig eth1
      ifconfig eth2
      If device not found for the 1 and 2, then that is good.
      If output for the last two, there might have to be some changes that we could try.
    4. What does ifconfig -a show.

    @Bartowski said

    Now i’m looking for a way to install them on the live disk , could I just insert another USB with these drivers on them and install them that way on the live boot?

    You could try.e

    You say that you tried the Netgear WNDA3100 V2 USB adapter and are asking if you would need to remove the PCI -E. That I am not familiar with. My guess could/might be wrong if I was to give you an answer pointing in one direction.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Yes I have been reading through the Arch Wiki avidly trying to find solutions etc trying different things, I managed to be able to hook up an ethernet cable for a short amount of time enough time that I could finish the install however I’m trying to configure a Dual Boot and I don’t want to mess up any partitioning so i’m currently looking into many things to make sure I don’t do anything wrong. Would it be easier to install the drivers after installing Antergos with the ethernet? Also Idk if you can help me with the partitioning but I’ll post these photos as i’m not sure how i’d post screenshots. http://imgur.com/a/r9Urs

    I’m trying to Dual Boot Windows 10 from my SSD , and than have Antergos on my HDD, I cleared the volume as you can see the free space on sdb , and i’m assuming i’d install the bootloader to where Windows is which would be the SSD, but i’m not sure how much space I should give each partition etc and what they should be named , I have 16gb of ram and some people say to give it 8gb from swap others say 16gb some say 4 is enough.

  • df| grep boot
    or
    fdisk -l /dev/sda

    call the partitions names that are appropriate to their function(s) and ones that you will be familiar with.

    16 GB of ram?
    Same here.
    I gave mine 32 GB of swap.
    Installer can also automatically take care of this for you, too.
    You can also follow a rule of thumb on this which is found everywhere on the net.
    So read about it here: link text

    Install drivers post install. If installed through live CD via RAM with the idea that it’ll be installed permanently, forget it (unless you decide to install via a chroot environment.
    Can try that.
    Should work.
    Have you read this? link text

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Yeah I did read that last article , just between the UEFI , and MBR and all that I just feel like somehow I’m gonna mess something up and everything is gonna go wrong. I’ll read over the things you sent me again before attempting anything. If you had some type of instant messaging i could get your help with that would be so solid.

  • @Modisc ,
    I’m pretty sure i’m in Legacy though as when i boot into BIOS it’s Legacy + UEFI and when I’m on Windows it reads Legacy on the Bios on System Info , so I’m thinking i need to make a /, /home, and /swap If there is one i’m missing and am misinformed i’ve been reading all over different opinions etc. Than i’m not sure which type to set them to should it be FAT32 for home or … , i’m reading all kinds of forums and people have different methods etc i just would like to have the most stable and smooth process possible.

  • if in BIOS, there will be no output
    dmesg | grep "EFI v"
    or
    sudo efibootmgr
    read the output. Should tell you.

    Does this directory exits after install? /sys/firmware/efi
    Some UEFI information from the wiki: link text

    Yes, that is correct.

    1. You need to make a /home partition.
    2. Also need to make a /.
    3. Also need to make a /swap.

    FAT32 as /home?
    Never heard of making /home as that kind of file system.
    I guess you could, am just saying I’ve never heard of doing it.
    For USB, sure. I can see that then.
    But for a persistent install?
    Stick with what Linux/GNU gives you.

    How old is this information that you have been reading?
    What is the strength of the knowledge base of these reports?
    What is the follow up critique of these reports?
    Remember to always read critically.

    The information you are reading should be no more than 2-3 years old.
    4 years old Max!
    Technology and some methodologies change. Some commands deprecate too.

    You want stable file system, then EXT4 is it.

    1. EXT 4 as /home.
    2. swap file system for /swap
    3. EXT4 for /

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc, hi there.
    I tried , out of curiosity, and confirm that the result of ifconfig wlan0 up is wlan0: ERROR while getting interface flags: No such device and
    iwlist wlan0 scan gives lan0 Interface doesn't support scanning
    I happened to have some nasty experience with configuring my conky network settings and I don t know if this is relevant.
    I could NOT get it to work with wlan0 but I had to change it to wlp12s0 instead…
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch
    Sorry. I’m a bit confused with your output. Are you saying that the command defaults to that output because of said output for not allowing to scan? Or something else such as the command needing to be replace with wlp12s0 instead of wlan0 ?
    Confused a bit there.

    @Bartowski
    I did some Googling for you. First of all, I am sorry to provide you with some unfortunate news.

    The card is not automatically supported by the Linux kernel. A Linux driver can be downloaded from the Asus homepage...but this driver only runs together with a Linux kernel of version 2.6.
    

    and

    The card can currently not be used together with other kernel versions (at least not with severe additional effort). There are some kernel patches available to use the driver together with other kernel version, but this approach needs detailed Linux knowledge and is often not successful. Therefore, it is not recommended to use PCE-N53 together with Linux.
    

    source

    I basically just Googled your wifi card with "linux"
    But that’s just only the research I did.

    My knowledge base is only so much and for that particular wifi card to go through the kind of extensive kernel work required… sorry. That is something I couldn’t help you with much. My knowledge base does not stretch towards the kernel.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc , sorry to have confused you. What I sai was, that I followed the commands you pointed out, to see what happens. It just reminded me of the completely different issue I had with configuring my conky. And I got the same output as @Bartowski
    I was trying wlan0 at first with no success, till I finally used wlp12s0.
    The reason I mentioned it was if it was any relevant to the issue here

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Alright marking as solved as I just drilled a hole to get to the ethernet lol, anyway my next move is to reinstall windows as only UEFI. Thanks everyone for all your great support!

  • @anarch
    I see. Ok.
    basically just a different command option as one is more/better useable than the other.
    @Bartowski
    Hope you were able to quickly read the “source” that I linked you to in the last post. Just for your own understanding.
    Again. Sorry that it turned out to be a bummer like this.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc
    Yes I did read over that post you sent , I found that post as well haha and thats when i brought out the drill.

wifi84 live34 boot163 Posts 16Views 3364
Log in to reply