• No authentication prompt


    0_1466640808277_help.png
    I just installed i3wm allong with my original install of openbox. In LightDm I just switch it from openbox to i3 via the button. As you can see rather than a prompt for me to put in my password, I get a message saying authentication failed. In openbox I do get the password box and everything works fine. It is only in i3 that I am unable to input my password. I tried mounting my second hard drive (ntfs) in i3 that has games on it, as well as remove a package to no avail. How can I get a password prompt in i3?

  • Anyone…

  • A polkit agent is needed. Check that you have one installed. What does the output of pacman -Qs polkit give to you?

  • Offtopic: I’ve been using i3 for a week now and I’m loving it.

  • @karasu something i still need to try 😎

  • local/polkit 0.113-4
    Application development toolkit for controlling system-wide privileges
    local/polkit-gnome 0.105-3
    Legacy polkit authentication agent for GNOME

  • [[email protected] ~]$ gufw
    ==== AUTHENTICATING FOR com.ubuntu.pkexec.gufw ===
    Authentication is required to run the Firewall Configuration
    Authenticating as: me
    Password:
    polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
    ==== AUTHENTICATION FAILED ===
    Error executing command as another user: Not authorized

    This incident has been reported.
    .
    This is what happens when I try and run things from lxterminal, i verified that i am no another user by running echo $USER
    .
    Also sorry for slow reply, been working alot

  • Hi,

    You must tell i3 to run your agent. Edit ~/.config/i3/config and add this line:

    exec --no-startup-id /usr/lib/polkit-gnome/polkit-gnome-authentication-agent-1

    Hope this fixes it.

  • That solved it, thanks

authentication9 prompt4 Posts 9Views 2168
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.