• Screen keeps dimming on battery, after every 5 seconds


    Hi,

    Since the last few updates, the screen when on battery keeps dimming down to almost 50% when it’s idle for 5 seconds. I have not put any such setting in place manually, and I always set the brightness at 100%. I’ve tried un-checking the dim screen settings, but no luck. Before this problem, the screen would dim down after about 20 mins of idle time, and that is how I would like it to be.

    Can anyone suggest what I should do, or where I should look to modify these settings on gnome.

    Thanks in advance!
    K

  • Please, be more specific. Antergos comes with 6 DEs (desktop environments) and each one has got its own settings and ways.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch said in Screen keeps dimming on battery, after every 5 seconds:

    Please, be more specific. Antergos comes with 6 DEs (desktop environments) and each one has got its own settings and ways.

    Thanks for your response! I should have mentioned earlier… I’m using gnome

    In case this is helpful –

    [[email protected] ~]$ ls /sys/class/backlight/
    intel_backlight
    [[email protected] ~]$ 
    
    

    Thanks for helping.

  • Edit: I also wanted to add that I’m using wayland with gdm.

  • I m running exactly the same, gnome on wayland, gdm, but I have no such issue. If you haven t touched settings (there is also a relevant extension) maybe it is hardware related?.

    It reminds me of me cannot adjust brightness under wayland. Well, after some digging I found out that I needed to disable a setting on the laptop that auto-configured brightness according to environment lighting…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Hmm… I do have the caffeine extension installed, but earlier, the screen would stay bright for about 15 mins or so of being idle, and then it would slowly begin to dim, now however, after 5 to 10 second of being idle the screen suddenly drops to 50% dimness. I have not changed any settings. Also, there are not tweaking options regarding this in GUI settings, I tried switching off the “dim screen when inactive” option in power settings, but that didn’t help. Also, light locker does not work well with wayland, so I can’t do much there either. Are there any other internal settings that I could change to see if it helps? I was thinking, if it is hardware related, then how come i didn’t face this issue earlier, it only started a few days ago, after I ran updates and rebooted.

    Thanks for your suggestions!

  • @KabirGandhiok

    how come i didn’t face this issue earlier, it only started a few days ago, after I ran updates and rebooted

    If it is so, why not give the lts kernel a try, then? More conservative, thus, more stable.
    sudo pacman -S linux-lts
    and then regenerate your grub
    sudo grub-mkconfig -o /boot/grub/grub.cfg

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Same result with lts kernel too… I think for the time being I’ll use caffeine, and wait, maybe it gets resolved in future updates. I really like the Gnome DE, I just wish they’d include more settings options…

    Thanks for your help!

  • Never mind! I wish I could have helped…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch said in Screen keeps dimming on battery, after every 5 seconds:

    Never mind! I wish I could have helped…

    Thanks! You helped as much as you could :) Antergos is an amazing community and distro! And I know this issue has more to do with the Gnome devs.

  • This issue has been resolved. I installed dconf-editor, and then org>gnome>settings-daemon>plugins>power, and there I changed the value of idle brightness from 30 to 90, so while the screen is still dimming down after every 5 seconds, I can hardly notice it :) , before this fix, I tried changing the value of the idle-dim option to ‘false’ but that didn’t help.

    I’m glad it’s fixed now, well not fixed, but I can’t notice it anymore, which works for me :)

  • Well done!:+1:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

seconds3 keeps6 dimming1 battery16 Posts 12Views 1106
Log in to reply