• SSH problem wifi/eth0 and xfce on old Acer & HP (celeron)


    Hi from the new guy.

    First, on both machines:
    sshd started and enabled
    Firewall (ufw/gufw) open for port 22 everywhere on all connections
    System locale sv_SE.utf8

    So. Having a really weird problem when trying to log in to Antergos from my main computer (Linux Mint KDE) to my two old lappers runing Antergos32/xfce:
    On one machine (Acer) I can only log in on one of the connections, namely the hardwire (eth1, there’s no eth0). On the wifi connection (wlp2s4) I just get “Permission denied, please try again”.
    On the other machine (HP/Compaq) I can’t log in period. Not on eth0, not on wlan. “Permission denied” etc.

    I have no problem logging in to the machines locally in xfce, but when I try the main terminals (ctrl+alt+F1->etc) not only can’t I log in, but the locale is not sv_SE.utf8 but some, I’m guessing (since I can’t log in), US-variant.
    However sudo in terminal on xfce gives me no problem.

    locale -a in terminal under xfce gives me (on both machines):
    C
    POSIX
    sv_SE.utf8

    /etc/locale.gen shows me sv_SE.utf8 uncommented (both machines)
    locale-gen hasn’t helped any. At all.

    I’m guessing the problem (i.e. locale) with the direct terminal access is the issue, and I can only guess it’s garbling upp my password or some other nuisance. I’ve tried simple passwords w/o any special characters, but it still doesn’t let me in. (Both connections on the HP, wifi connection on the Acer.)

    I’ve searched extensively, alas to no avail. I’m lost… so this is where I stop banging my head and ask my local, friendly Antergos community for some assistance.

    Kindly

    /m

    /m

  • @morpheo said in SSH problem wifi/eth0 and xfce on old Acer & HP (celeron):

    …I’m guessing the problem (i.e. locale) with the direct terminal access is the issue,…

    Excessive wording. About “terminal’s locale” only.

    It has almost nothing to do with usual locale settings tools you mention, used in GUI and DEs. Fonts and keyboard layouts for VTs are configured through /etc/vconsole.conf file:

    KEYMAP=uk
    FONT=
    FONT_MAP=
    

    In this example I set English (UK) keyboard layout to use in terminals, and leave default fonts unchanged. The keyboard to use is essential; it may be different from default GUI language(s) and must correspond to the physical keyboard layout(s). All other parameters may be omitted:

    KEYMAP=uk
    

    Make sure your file uses the correct KEYMAP= value. Probably, it should be se.

  • Hm. /etc/vconsole.conf KEYMAP=se on both machines already.

    /m

  • Okey. Changed /etc/vconsole.conf KEYMAP to sv-latin1 which gives me the correct keymap. However, can’t log in to TTY. GUI poses no problem.

    This a user management/rights issue?

    /m

xfce50 ssh7 acer4 wifieth01 Posts 4Views 585
Log in to reply