• glamor detected. failed to initialize EGL


    I wanted to try out the amdgpu driver for my sea islands card, but never did succeed in getting that to work. So, I tried to revert back to the open-source radeon driver. However, ever since doing so, I have been having issues with anything requiring graphics.

    When I try to start my desktop environment (Cinnamon), I receive the error “Cinnamon just crashed. You are currently running in fallback mode.” However, I do not have a mouse cursor and all keyboard commands (including alt+F2) seem to be ignored with the exception of starting a new session with ctrl+alt+F2. In the new command line session I have tried killing all cinnamon configurations, reinstalling cinnamon and cinnamon-session, as well as reinstalling the xf86-video-ati driver and the mesa-libgl and lib32-mesa-libgl drivers, all to no avail.

    Checking the Xorg log, I see a very suspicous looking “glamor detected, failed to initialize EGL.” When searching for how to fix that error, I can’t find anything recent. The problem with older posts being that between then and now the fixes proposed (try enabling USE=“gbm egl gles2 llvm” in the mesa builds) should be automaticallly included in the mesa packages.

    I am not sure how to fix this problem or what else to try next. Any suggestions are appreciated.

  • @dondy

    Cinnamon just crashed. You are currently running in fallback mode.”

    Just saying. There s been an upgrade to Cinnamon a while back. Did you get it?
    https://forum.antergos.com/topic/4605/antergos-repo-now-includes-latest-mate-cinnamon-packages

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch
    Everything should be the latest package. I re-installed everything with both -Syu and -Syyu flags.

    I really don’t think the problem is with cinnamon as I can’t get any graphical application working correctly, including using other desktop environments. If I disable the desktop environment from starting up and try to run x directly from the command line, I saw that it was still trying to load the amdgpu drivers somehow. Also, once within X, I still cannot get any graphical application to load, such as a media player (nor can I outside of X of course)

    So, I figured I would try to remove the xorg-server and re-install,
    which required I remove xserver-xorg-video-amdgpu-pro (I had no idea I had that on there until now)
    and amd-gpu-pro-graphics (had no idea that was there either),
    and many other things until I could finally remove the xorg-server, then reinstalled it.

    I think that fixed my original error in the X log, but I am still unable to get HW acceleration. However, now when I boot into a desktop environment, I at least maintain a cursor and keyboard control now, so I view that as progress. When I do startx from the command line, I get errors for being unable to start gbm_dri.so and some other things (including unable to start gallium).

    I’ll keep on digging through the logs to see if something else pops up now to continue with, but it is too late for me tonight to continue on.

    Thanks for the help and I will try to update this tomorrow evening (I won’t have time to continue investigation until then).

  • Problem is fixed now.

    I had followed the instructions at https://wiki.archlinux.org/index.php/AMDGPU for installing the amdgpu driver, and although I only installed the xf86-video-amdgpu package, it apparently installs about 20 different other packages. However, when I remove the amdgpu package, it only removes the specific one I asked to install. After searching through the pacman cache to identify and remove every package that had the letters amdgpu in it, I was able to reboot and have everything work fine again using the standard opensource radeon/ati driver again.

glamor1 ati8 radeon10 graphics driver5 Posts 4Views 1548
Log in to reply