• Installer doesn't show up, NVIDIA Optimus


    Hello everyone,

    Using the Minimal ISO 64-bit

    System is a Dell Inspiron 7559 (Skylake i5, with GTX 960M)

    I’ve done a lot of distros with optimus and at least I could get through the install process using the “nomodeset” option. Not with Antegros… I’ve tried all three options on the boot selection screen and each one doesn’t work. The normal one freezes at a white screen (understandable, because optimus). The non-graphical fallback just boots to the terminal with that message saying to go to the forums.

    Finally, the “nvidia fallback” ends up at the terminal with the X server crashing saying “no screens found”. I’ve gotten this before on other distros, but that was when I messed around after installation, trying to get bumblebee/nvidia-prime working.

    Anyone have any idea what is wrong? X server logs show nothing unusual, just the no screens found error.

    Help would be much appreciated, thanks.

  • Hi! Have you checked this?
    https://antergos.com/wiki/hardware/graphics/bumblebee-for-nvidia-optimus/

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Yes I have, however it’s for setting up after the install, something which I can’t do if the installer never shows up.

  • @jython234 Just a shot in a dark - instead of nomodeset, try to boot with vga= parameter. Some possible values are:

    • vga=895 (corresponds to 1920x1080 on Nvidia cards)
    • vga=789 (corresponds to 800x600 on most cards)
    • vga=normal (uses default card’s resolution on boot)
    • vga=ask (lists basic VESA modes to choose from)

    More about VESA modes is here .

  • @just Tried that with no success.

  • I have the same machine than yours. Did you try: “nouveau.modeset=0” ?
    It works for me!

installer37 optimus25 nvidia113 show16 Posts 6Views 1748
Log in to reply