• Unable to set the clock to network time, automatically turns off again


    Hey dear Antergos community!

    I am using Cinnamon and since the last installation of Antergos, my clock is grong (2 hours fast). It is weird, because when I open the Date and Time Settings, I can see that my region is set correctly. If I unlock the settings and turn network time on, nothing happens. I can lock the settings back again and the network time seems to stay on at this point, but if I close the window and reopen the Date and Time Settings, the network time is back off again.
    I also tried to just set the correct time manually, but it only lasts untill the next reboot and then turns back to 2 hours fast.
    What am I missing or doing wrong?

    Thanks in advance for your ideas and support!

  • @amo , hi! Have you looked into this?
    https://wiki.archlinux.org/index.php/time

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • hey, thanks for the advice. I looked over that article again and the troubleshooting section solved my problem for now.
    I installed ntp (I never doubted it was preinstalled), but still cinnamon isn’t able to turn on network time… might be a cinnamon bug?
    Anyway, marking as solved.
    Thanks!

  • You are welcome!

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Unfortunately, I just noticed a little more difficulty with this issue:
    I dual boot with windows 7 and after setting the clock at the correct time in antergos, the time is now wrong in windows. So I synced the time in windows with network time, but now back in antergos, the clock is 2 hours fast again. I believe the time was two hours slow in windows.
    The ArchWiki page mentioned something with the hardware clock, and there might be some issue with that between the operating systems, but I hardly know anything about that.
    Does anybody have an idea?

  • Still have not found any solution… Anyone with an idea on that issue?

  • It is hard to control the time and synchronize it over the network simultaneously by Linux and the virus called Windowz.

    • Bad solution

      Set Linux to use localtime. Disable time-related services, like ntp. Let Windowz totally control the hardware clock.

    • Smart solution

      Set Linux and Windowz to use UTC. Setting Windowz to use UTC needs some hacks. Disable time synchronization over the network in Windowz. Otherwise Windowz will turn the hardware clock back from UTC to localtime.

    • Best solution

      Remove Windowz. Use UTC in all Linuxes installed on the computer.

    More info, as usual, is in ArchWiki here.

    Good luck.

  • Thank you for your suggestions. As I do need windows for Ableton Live (serious audio production is still a mess under linux), I chose the smart solution :)

cinnamon72 wrong2 network time1 clock8 Posts 8Views 1187
Log in to reply