• Antergos hangs up on boot on MacBook Pro 8,2


    Hello everyone, this is my first post in this forum, so I take the chance to say hello, and congratulations for the OS. I think you are doing a great job. Everyone I ask says Antergos is the real deal.

    So, this weekend I crashed into this problem: I tried to install Antergos on a MacBook Pro 8,2 15", and as this thread I quote, it UNFORGIVINGLY FAILS to boot.

    I’m posting this not only to ask for advice, but also to post the progress, and things I try.

    Unforgivingly is a good term for this, because what happens is that it hangs up on startup, and the logs show variable messages before the death of the system, even if you use debug loglevel_ignore on startup options. It stays just there, if you try to boot normally it show a black screen with an unblinking underscore. Every try to get a response from the computer is futile, no tty change, no rootfs, nothing.

    After fiddling with startup options, it sorta came down to a Xorg start up problem:

    • using rescue on startup kicks me into a rootfs terminal, just after systemd has finished doing its business (i think). When you type startx you can get either two things: It hangs up after the message: (==) Using system config directory "/usr/share/X11/xorg.conf.d/" or you can get a (EE) screens found but none has usable configuration and exits back to rootfs.
    • If you fiddle with i915.modeset and radeon.modeset, it also hangs, but the last message shown on screen before clearing is fb: switching to nouveaufb from EFI VGA. Using nomodeset also renders the system unresponsive.
    • I also tried rebuilding vmlinuz and initramfs files (by booting the live USB and arch-chrooting into the disk) and putting block before autodetect in HOOKS in /etc/mkinitcpio.conf, but that has the same result: Black screen, frozen underscore
    • Examining journalctl --since=today reveals a lot of call traces with INFO: task Xorg:433 blocked for more than 120 seconds just before I push the startup button to hard reset. (after letting it sit there, hung up, for around 30 minutes)
    • Downdating Xorg to install catalyst drivers yields the same results: Black screen, frozen underscore

    I’m using refind, but grub doesn’t work either. I need the computer to keep working, so I fallback on Apricity OS for now, because is the closest thing to antergos that works. When I have a little more time, I’ll try again.

    As the cited post states, the solution has got to be something trivially simple, because the USB live boots flawlessly, it renders everything quick and clear. And it’s not a matter of drivers (although xf86-video-ati misbehaves when it comes to shaders) because Apricity got it right. lscpi reveals that xorg is using both Intel and Radeon GPUs.

    Is there anyone with antergos on a MBP 8,2? Is there anything I can try? I don’t know why I don’t have Xorg.log, I remember that some of the times, the log didn’t even generate. :full_moon_with_face:

    Greetings, and thanks for your attention

  • According to this topic, the root cause is lightdm, that hangs the whole system.

  • Finally installed Antergos successfully. lightdm was the guilty one, so I removed it and installed gdm instead. So let’s mark this thread as solved.

    Here’s how to do it:

    • After successfully installing Antergos, don’t restart, and open up a terminal.
    • Type su and hit enter to switch user to root user.
    • Mount the partition you choose as root on installation: Type mkdir /mnt and then mount /dev/sdXY /mnt. This will mount your partition on the /mnt folder (If you don’t know which partition your system is installed, use the df command, and look for the one that says that is Mounted On “/”
    • Then, change the root to the /mnt folder with this command: arch-chroot /mnt this will open a session with your installation as root folder, sorta like you logged in your computer.
    • Uninstall lightdm: use pacman -Rcns lightdm
    • Install gdm: pacman -S gdm and then activate it systemctl -f enable gdm
    • Reboot your system and you will be able to log in and use your MacBook 8,2 with antergos!

    Happy hacking!

  • I am running Antergos smoothly after a heavy battle on a MacBookPro5,1 and in dual boot on a MacBookPro9,1. The unknown and weird problem that i was encountering was to do with starting the Live USB from rEFInd.

    1 start Live USB with ALT key pressed
    2 choose DVD live start up (the first one in the list that time) not the other ones (again thanks to @karasu)
    3 test the Live USB session connected with internet thru ethernet cable wait because Cnchi has to be completely updated to latest version wait until the message Cnchi up to date
    4 install Antergos

    There are more bridges to take but i haven’t find time to put a complete MacBook Pro installation guide, but i will one of these day’s.

  • @elgambitero , @bartatantergos , it would be a nice idea if you also posted these guides in our wiki…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch: Yes, i will do that but no time for the moment.
    Same login as the forum for the Wiki, i think?
    @elgambitero: Strange, on my two Mac’s Lightdm works without problems? Can you do the Wiki for MacBookPro8,2, i will do the two that i have next week somewhere.

  • Thanks!:+1:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Hello, @bartatantergos .

    All those MacBooks (9,1 and 5,1) have nvidia graphic cards, that (I think) happen to have better open source drivers than the ATI Radeon 6750M MacBook 8,2 has under the hood. (For example, xf86-video-ati + mesa3D are unable to create shaders, because TGSI translation is buggy for some season. That makes me unable to play any 3D game)
    I don’t have a complete idea of how GPUs work, but I suspect that this kind of bugs snowball down to lightdm initialization, and crash the system.
    I have rEFInd installed from long ago, because I had a triple boot OSX+Windows+Linux MInt, so all the tests I made were made with rEFInd (except for that time Cnchi overwrote it with grub2)

    @anarch, I’m glad to do it. I’ll try to write it this sunday, if I have the time to understand the wiki structure and make an entry with a coherent style.

  • Hello

    I made the article the fast way, just in case I forget, the info is there. I haven’t had time to style it just yet because I felt weird with the editing toolbar, so I ended making some hybrid between HTML code and editor code.

    Can’t post the link because forum keeps flagging the post as spam, so all I can say is that the title is:
    installing-antergos-on-a-macbook-82-mid-2011/

    If there’s anything I left behind let me know.

  • @elgambitero: Oeps, it’s a Mac Book, yes then it has a ATI Radeon.
    In the Wiki after "Uninstall lightdm, and install gdm: the command lines are white so invisible, only visible when you hover it.
    Can i reuse your structure (titles, text blocks) from that Wiki page?

  • @bartatantergos

    The invisible lines seem to be the standard formatting of code of the antergos wiki, which I’m still not used to. I tried to change it without success. Maybe when I have more time.

    I don’t know what you mean by reuse the structure, you mean like, in another wiki?

  • Ok, the Antergos team has to fix the white formatting of code.
    I mean reuse the text formatting and titles you use to make on he Antergos wiki a wiki page for MacBookPro 9,1.

  • @bartatantergos

    I guess it’s ok to use it in your wiki but, does the MacBook Pro 9,1 suffer from the same lightdm problem? Because if it doesn’t maybe there is no need to include the lightdm part.

    I think the lightdm issue is actually a ATI free driver + Mesa issue. (That family of graphic cards had buggy drivers, and new versions of Mesa don’t seem to work) MacBook 9,x as I read, had Intel graphics 4000HD. (A well behaved hardware so far) and, on the 15" versions they packed an NVIDIA GeForce GT 650M).

    I’m curious: which parts of my wiki did you find interesting for MacBook 9,1?

  • I mean to reuse your text formatting and titles, to save time. But i have already started to do it my way. :) Will post in a few days.

macbook19 hangs15 boot163 Posts 14Views 1943
Log in to reply