• screen flickering after updating


    Hello,
    I have some really annoying screen flickering issues since I have updated some libaries via. package updater (gui). I had reinstalled antergos but when the login screen appears the screen starts flickering. While booting the UEFI, the BIOS or the installation there is no flickering at all.

    I am using:
    Lenovo Thinkpad E540 (notebook)
    with an Intel i7 a iGPU (Intel 4000HD) and a
    GT 740 from Nvidia.
    GUI: Gnome

    I’ve allready tried to fixing the problem with installing bumblebee or install gdm/lightdm but nothing seems to help.

    Does anyone have the same problem or could help me to fix it?

    greetings roid

    Logs:
    0_1465399704972_flickering_screen.tar

  • @roid s:

    I have some really annoying screen flickering issues since I have updated some libaries
    Was kernel 4.6.1-2,among these updates, too? If yes, I would suggest you try running the LTS kernel, instead.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Yes you are right I have choose the LTS Kernel in GRUB and it works. Next time I should double check the update list. Is there an option in GRUB where I can always boot the LTS Kernel?

    Thank you very much!

  • Did you regenerate the GRUB?
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    It would be a good idea to run this afterwards:
    sudo mkinitcpio -p linux
    If yes, you ll have both kernel entries, now.
    *** Double checking the update wouldn t have been much help in this case. You d simply have seen the kernel update. Not that it d make you screen flicker

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch
    I have regenerate my GRUB but it seems that Antergos is still booting with “wrong” kernel. If I not manually changing to the LTS Kernel while booting it is automatically booting the kernel with the screen flicker issue. My problem is that I can’t always run the LTS Kernel because I am developing with virtualbox and vagrant which needs a newer kernel version to run.

    Is there a workaround to get a newer, running version without this flicker bug? I am quite worried that this flickering could damage my screen.

    Edit:

    uname -r
    

    LTS Kernel:
    4.4.12-1-lts

    Current(normal) Kernel
    4.6.1-2 ARCH

  • Did you install the LTS kernel now or you had it already selected when you installed Antergos? If you installed it now, the LTS kernel should be default. If it was already installed, then the default should be the “stock” kernel. There s information in the Arch wiki on how to change the kernel order.
    As to your developing task, I really don t know if the LTS is that much “left behind”.
    It got updated just a couple of days ago…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I ticked LTS Kernel when I installed Antergos. So I have to change the kernel order but the bigger problem is the “old” LTS Kernel which is not compatible with virtualbox/vagrant. Is it’s possible to downgrade the stock kernel? Can’t find any repos for older arch linux kernels.

    and thank you a lot for your help!

  • @roid

    the bigger problem is the “old” LTS Kernel which is not compatible with virtualbox/vagrant

    I m not experienced with Virtualbox at all but is linux-lts-headers installed?
    I can t see a reason why the lts kernel is incompatible. It s no old at all.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I have now installed

    linux-lts-headers
    

    But if I start the virtualbox with vagrant it shows the same message at all:

    WARNING: The vboxdrv kernel module is not loaded. Either there is no module
             available for the current kernel (4.4.12-1-lts) or it failed to
             load. Please recompile the kernel module and install it by
    
               sudo /sbin/rcvboxdrv setup
    
             You will not be able to start VMs until this problem is fixed.
    5.0.20_OSEr106931
    
    

    and if I run sudo /sbin/rcvboxdrv setup it shows:

    Unloading modules: 
    Loading modules: modprobe: FATAL: Module vboxnetadp not found in directory /lib/modules/4.4.12-1-lts
    modprobe: FATAL: Module vboxnetflt not found in directory /lib/modules/4.4.12-1-lts
    modprobe: FATAL: Module vboxpci not found in directory /lib/modules/4.4.12-1-lts
    modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/4.4.12-1-lts
    

    vagrant provides preconfigured boxes for virtualbox and handles the file sync between the system and running boxes. With the stock/latest kernel (4.6.1-2 ARCH) I can run vagrant without errors.

  • I suggest you start a new topic providing all this information. Someone with better knowledge of Vitualbox could help you out.
    In the meantime, I dont know if this search could be any useful to you…
    https://www.google.gr/search?q=vitualbox+antergos&ie=utf-8&oe=utf-8&client=firefox-b&gfe_rd=cr&ei=9I1YV_TgHtPW8geOzoKIBg
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Do you have the Virtualbox “DKMS” kernel module installed? And I think you have to install additional host and guest modules too!

    O/S: Antergos Plasma 5 (KF5) 64-bit
    CPU: Pentium Dual-Core CPU E5300 @ 2.6GHz
    GPU: Intel 4 Series Integrated Graphics Controller
    GPU driver: Mesa DRI Intel® G41
    "If you like Antergos, Please donate!"

  • @roid
    This method is useful to you if you are using Jelly Bean version in your tablet.
    Go to settings >> More Tab >> About device.
    Find “Build number” and click 6 times fast on it.
    You will then get the message saying: "You are now a developer"
    Come back to Home Screen, and then go back to Settings >> More Tab >> Now you will see the "Developer Options"
    Now go to Developer options >> Drawing Section or Rendering Section >> Find “Turn off hardware overlays” or “disable hardware overlays” >> This will force the phone to always use GPU for screen compositing
    For other version’s solutions check Lenovo ThinkPad Edge E540 Manual.

screen17 flickering5 issues48 update45 Posts 12Views 2021
Log in to reply