hi there,

i use a QTX2900-itx board (beside some other computers), which includes the intel pentium j2900 cpu, i have experienced several system freezes every time i watched a video via firefox or even with vlc and also when reading the news with some pictures, the system freezed.

When you are also on an Intel Baytrail cpu, this might be helpful to you,
here is what i have found about the issue:

https://www.phoronix.com/scan.php?page=news_item&px=Intel-Linux-Bay-Trail-Fail
https://bugzilla.kernel.org/show_bug.cgi?id=109051
https://bugs.freedesktop.org/show_bug.cgi?id=88012
https://github.com/OpenELEC/OpenELEC.tv/issues/3726
https://wiki.archlinux.org/index.php/kernel_parameters#GRUB

As you can see, the problem is well known.
The solution, which is still working for me, is to add the kernel parameter “intel_idle.max_cstate=1”.

There are several ways to set kernel parameters,
i use grub to achieve this, see the last link above.

In short, open the “/home/boot/grub/grub.cfg” as root and
search for the line "linux /boot/vmlinuz-linux root=/dev/sdaX"
and append the parameter like this “linux /boot/vmlinuz-linux root=/dev/sdaX intel_idle.max_cstate=1”. The “sdaX” means you have to change the “X” according to your device number, for example “sda1” or “sda2” and so on.

Hope it helps, have a good time with Antergos.