• antergos - cnchi repeated installation failure

    Hi there,
    I have been trying to install Antergos on multiple attempts over the last few days. This is not usually an issue.
    I have tried both the latest full live ISO and minimal ISO on USB (not UEFI) with both systems failing to complete the install.
    Internet connection speed is good and dowload speeds are good however I have noticed some packages failing to be retrieved and alternate mirrors tried but the packages all still appear to be downloaded - cnchi log doesn’t indicate if any failed?
    Also have attempted using;
    sudo cnchi -dv
    sudo cnchi-dev
    sudo cnchi-dev development
    manually ranking mirrors then, cnchi/cnchi-dev --disable-rank-mirrors
    So running out of ideas… Basically the last few attempts have successfully (appeared to anyway) downloaded the required packages and fails as soon as alpm transactions are done, from what I can tell this is likely due to corrupt package(s)? Why would package coruption be occuring repeatedly? Bad mirrors?

    What would be required for cnchi to attempt to download packages again that fail to pass checksum integrity? This may make the installer more robust… I haven’t spent a lot of time in the cnchi source code so am not aware how this all works at this stage.

    See the attached cnchi.log,0_1464866165201_logs.tar note configuration was:
    sudo cnchi-dev
    cinnamon environment
    cnchi version 14.89
    any ideas much appreciated,

  • have the same issue, i give up and moved back to manjaro, in my case it could not find a package in the repo, the same package continues to be missing from the repo, the installation should have all the files in the disk for offline install and then update but that would go against the arch way, then again the fact that the installation scripts can’t find what they are looking for is moronic

  • @spider623 I’m having the same problem did anyone find a solution

  • I’m having the same problem also with both live and minimal.

  • @captkirk @spider623 @rwoodsmurphy @frabato56

    I brought this issue up on github and it’s been fixed. When the installer pops-up, close it and run the following:

    sudo rm -rf /usr/share/cnchi
    git clone https://github.com/Antergos/cnchi --depth=1
    cd cnchi
  • @Wyn
    Im getting this

    [[email protected] ~]$ git clone https://github.com/Antergos/cnchi --depth=1
    Cloning into ‘cnchi’…
    fatal: unable to access ‘https://github.com/Antergos/cnchi/’: error setting certificate verify locations:
    CAfile: /etc/ssl/certs/ca-certificates.crt
    CApath: none

  • @rwoodsmurphy sudo pacman -S ca-certificates then follow above steps again.

  • still getting the same message

installation321 cnchi161 repeated1 Posts 8Views 2741
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.