• Gnome + LightDM


    I run Antergos on a Dell XPS 13 notebook. My DE is Gnome 3.20. A while ago I had uninstalled lightdm and installed gdm. Today I reverted back to lightdm. I uninstalled gdm, installed

    lightdm lightdm-webkit2-greeter gnome-shell-extension-status-menu-buttons

    and did

    sudo systemctl enable lightdm

    I am unable to lock the screen. Suggestions are welcome.

  • Though not having the gnome-shell-extension-status-menu-buttons installed, I do have the lock icon.
    I know this is not much of a help, but there is an extetion you may want to use .
    https://extensions.gnome.org/extension/83/lock-screen/
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I don’t think the problem has to do with Gnome extensions. I installed gnome-shell-extension-status-menu-buttons because after uninstalling gdm and installing lightdm I no longer had a lock icon in the Gnome status menu. Regardless of Gnome buttons, I am unable to lock the screen. The keyboard shortcut for locking the screen (Super + L) does not work and the screen is not locked when the notebook resumes from suspend even though I have the following light locker settings:

    https://dl.dropboxusercontent.com/u/2171814/light-locker.png

    Suggestions are welcome.

  • The extension I suggested was an alternative to lock your screen. It adds a lock icon on your pane, in case locking your screen is urgent to you., till you find a solution. That s why I said I was not much of a help. Sorry, but I no longer use lightDM

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • The only way I can lock the screen is by using

    dm-tool lock

    P.S. I switched from gdm to lightdm because I believe gdm is linked to a pulseaudio bug that affects my notebook.

  • Takan from the G+ group:
    "…I installed lightdm lightdm-webkit2-greeter gnome-shell-extension-status-menu-buttons
    and did a sudo systemctl enable lightdm…"
    You did. disable gdm first, didn t you?

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Yes, I did. Stopped it and disable it. And after that I removed gdm from the system.

    I tried the hack proposed here (for Gnome 3.16):

    https://github.com/the-cavalry/light-locker/issues/54

    i.e., I added

    /usr/bin/light-locker &

    just before

    echo “X session wrapper complete, running session [email protected]

    in /etc/lightdm/Xsession . I was able to lock the screen, but the desktop was unresponsive after I unlocked it.

  • @edconocerte I would love to be able to go back to gdm. The problem is that I am almost certain that gdm (perhaps through pulseaudio) is causing the audio crashes I’m experiencing. I reported the problem here:

    https://bugzilla.kernel.org/show_bug.cgi?id=118051

    Suggestions are welcome.

  • Just an idea, taking in mind 2 factors. From your report I can see a stock kernel. On the other hand you didn t experience such problems in the past.
    I was just wondering if the use of the LTS kernel would take any effect, on either DMs.
    That is unless you haven t given it a try so far…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch My notebook is a Dell XPS 13 (model 9343, 2015): https://wiki.archlinux.org/index.php/Dell_XPS_13_(2015) . It has a Realtek ALC3263 chipset which is “dual-mode”, i.e., it supports both the HDA standard and the I2S standard. The the OS determines which mode the sound chipset initializes in at boot. Since kernel 4.4, Arch and Fedora chose to initialize I2S. Then my audio problems started. At the time, I was running Fedora and reported the bug. Sound worked for a while and then crashed. The same thing happened with Antergos. Kernel 4.5.2 was supposed to fix the problem, but my crashes persisted. A few other users reported similar crashes. I finally discoved tha the problem is caused by gdm. See https://bugs.archlinux.org/task/48936 . Somehow, gdm, through pulseaudio (I believe), causes the problem. Note that other users reported similar crashes. So far, I have been compiling my kernels using the option CONFIG_ACPI_REV_OVERRIDE_POSSIBLE=y in order not to use I2S audio.

    To make a long story short, gdm is causing crashes on my computer. I run Gnome 3.20 and then tried to replace gdm with lightdm. I then faced two problems: I was unable to lock the screen (which I reported here) and the screensaver no longer worked. If I can get lightdm to work properly, I will then be able to finally have I2S audio and I will no longer need to compile my kernels.

    That’s why I am asking for help.

  • @cribari s

    To make a long story short, gdm is causing crashes on my computer. I run Gnome 3.20 and then tried to replace gdm with lightdm. I then faced two problems: I was unable to lock the screen (which I reported here) and the screensaver no longer worked. If I can get lightdm to work properly, I will then be able to finally have I2S audio and I will no longer need to compile my kernels.

    Yes, so I saw in your bug file. Let me ask you 2 final things"
    From your light locker you seem to have screensaver settings OFF. In case you have set it from the Gnome Settings Center, bear in mind that you need to disable all settings from there and set them via the Light Locker Settings, to take effect. This only applies to lightDM, not GDM.

    This extension I sent you before doesn t work (as a n alternative workaround)?
    https://extensions.gnome.org/extension/83/lock-screen/
    *Also possible steps:
    I don t know about this package gnome-shell-extension-status-menu-buttons, but Gnome Extensions don t give me tis as compatible with Gnome 3.20.
    If you uninstalled it and used these instead?
    https://extensions.gnome.org/extension/826/suspend-button/
    (there is a shortcut in case you didn t know)
    https://extensions.gnome.org/extension/755/hibernate-status-button/https:
    (I don t hibernate but I think it is disabled by default/don t take my word on that)
    //extensions.gnome.org/extension/83/lock-screen/
    (sets a lock icon on the panel).
    By te way on adopting Antergos, some 2.5 years ago, I also did not have any way to lock the screen. It just appeared in my tools one day. All this time I went with the Lock Screen extension.
    Best regards+1:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch

    1. Screen lock Gnome extension: works with gdm but not with lightdm.
    2. Suspend button Gnome extension: works with gdm and lightdm. With lightdm the screen is NOT locked when the notebook resumes.
    3. The keyboard shortcut to lock the screen (Super + L) does not work with lightdm.
    4. I disabled the power settings in the Gnome Settings Center and enabled the screen saver in the Light Locker Settings. Result: still no screen saver.

    In a nutshell: with lightdm I unable to lock the screen and I have no screensaver.

gnome250 lightdm97 Posts 13Views 2472
Log in to reply