• Can't play movies and vlc doesn't start!


    Hi there,

    I’ve just installed Antergos with gnome and i downloaded an .mkv file and can’t play it because it says “could not initialize supporting library” so i downloade VLC and that doesn’t even start it’s so frustrating =/ playing a video should just work, can somebody help me please.

    PS I’am sorry if this topic was brought before but i couldn’t find a similiar here.

    Antergos Gnome
    Intel Core i5
    8 GB DDR3
    Nvidia GTX 560 Ti

  • @Hyllus just to test try downloading smplayer or mpv and see what happens.

  • It works but still i like VLC and the default gnome player oh well you cant have everything, thanks.

    Antergos Gnome
    Intel Core i5
    8 GB DDR3
    Nvidia GTX 560 Ti

  • @Hyllus i understand im a big fan of VLC also. i have seen quite a few people reporting playback issues in VLC recently. you might want to play with the playback outputs under the video settings.

    1. Gnome Videos (Totem)
      I only recently tried to give it a try, after reading reviews of it not working. I found out that grilo was missing among its mentioned dependencies (could something be done here on our side, @karasu, @lots-0-logs )?
      The easy fix:
      Open pamac and type totem to find it.
      Double-click on its name to get to its (hidden) information.
      Click on the dependencies tab. If this is your case, you ll find grilo is not installed. There is an option to install it right from there.
      2. VLC
      In my case, I could not even load. So, i completely uninstalled it
      sudo pacman -Rsnc vlc
      and re-installed it, this time with no problems
      sudo pacman -S vlc
      *Personally, i found myself to like the minimalist approach of Totem more than the "overloaded’ VLC. Still, my preference is KODI.:+1:
      Regards

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Grilo is already installed i just checked that and i also tried to uninstall and reinstall vlc still the same vlc does not load at all it’s very frustrating. I came from Ubuntu and i’am very pleased with Antergos it never crashes it’s rock solid and always modern but man they really need to fix these things, playing videos and loading vlc should not be a problem.

    Antergos Gnome
    Intel Core i5
    8 GB DDR3
    Nvidia GTX 560 Ti

  • Did you uninstall VLC the command way I said? Otherwise, you ll have remnants of it in your files and re-installing it will give you the same unsuccessful result.
    Do bear in mind that Antergos doesn t interfere with this as it uses upstream the Arch Linux repos.
    What I suggest you do is using pamac again and check possibly needed dependencies that need to be installed. Keep a note of them if you want to uninstall them afterwards in case they didn t take any effect.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @Hyllus as @anarch says Antergos doesnt work on VLC. if you want more direct help you probably want to go to the VLC forums. its pretty active.

    did you try changing any of the video outputs?

    could just be a bug that will be fixed in next update. these kinda things happen with all apps sometime.

  • Foolish of me, but I completely forgot to mention it first thing. Run them: from the terminal and you’ll get the info on missing dependencies if any. :+1:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • This is what i get when i load totem from the terminal.

    alt text

    Antergos Gnome
    Intel Core i5
    8 GB DDR3
    Nvidia GTX 560 Ti

  • Install QT4.

  • @mikelp1973 i have already done that. I managed to fix VLC all you had to do is install all dependencies for it via pamac but totem is still a mystery but it’s ok i guess. moderators can mark it as fixed or i have to do it i don’t know how this works.

    Antergos Gnome
    Intel Core i5
    8 GB DDR3
    Nvidia GTX 560 Ti

  • Glad! That was easy, wasnt it? Can t you manage totemfollowing the very exact procedure as fixing vlc?
    Anyway, from your screenshot (please use copy/paste instead because the whole output cannot be seen:+1: ) it looks like gstreamer is outdated. Try:
    sudo pacman -S gstreamer
    and let me know how it goes…
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch well i don’t get gstreamer error anymore but i still can’t play video on totem it’s just black screen but there is sound though. anyway thanks guys for helping me out.

    Antergos Gnome
    Intel Core i5
    8 GB DDR3
    Nvidia GTX 560 Ti

  • You need to dig into its plugins and/or dependencies (I doubt the latter).
    As I said, I only tried to see what s going on with reports of it not working. After installing my missing dependency, I was able to play internet radio and a couple of vids I happened to have saved in my home folder. No more digging.
    Cheers!

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @Hyllus Correct. I don’t recall how I figured this out before but when I installed VLC pamac put up a dialog of optional dependancies and I just went ahead and committed. Well none were selected, and I couldn’t remember which ones were required. So, being lazy I removed VLC and reinstalled and selected all when it popped up again.

  • Hyllus, my VLC was not able to open when I tried the right click on a movie file -> option “open with -> VLC”. Then I tried to open the player by itself first and then it started every time with no problems. I think the reason could be in the first dialog screen on which VLC asks the user something to confirm (I forgot what was it).
    So make sure that you open your player from its icon first. I hope that can help you. Regards.

  • I had same problem with VLC, turns out I had to install QT4 and it worked.

  • Why are you using sudo with totem?
    Open a terminal, and simply run totem without sudo.

  • You have tried other video files, right?

    Sounds like it doesn’t have the video codec, you can use VLC to find what codec each stream uses

movies1 vlc14 start3 Posts 30Views 9559
Log in to reply