• auto import fail after upgrade of zfs and spl from 0.6.5.6 to 0.6.5.7


    Using ‘yaourt -Syua’ today (2016-05-28) I updated zfs and spl from 0.6.5.6 to 0.6.5.7. Updated init ramdisks for linux (4.5.4-1) , linux-lts (4.4.11-1), and linux-zen (4.5.4-1) kernels using mkinitcpio as usual after kernel/module changes. I rebooted. System came up normally and I was able to login normally, but my storage zpool did not auto import correctly. I redid setting the cache file propperty and checked zfs.target using systemctl. zfs.target seems to be having problems starting correctly after the update. It times out the first time I try to check it using systemctl and seems to need to be stopped and restarted before it responds in a timely fashon. I tried downgrading to 0.6.5.6, but was unsuccessful – I seem to not know what all packages need to be downgraded to get the reversion to the old one to work. The auto-import worked correctly before today’s upgrade, but does not work now. I can export my storage zpool and re-import it to make it usable, but I want the auto-import function back.

    If there is someone on here with knowledge of how to either fix the problem or how to correctly downgrade to the old versions of zfs and spl I could use the help please?

  • Hi, I’ve identified the upstream bug causing this issue. I will patch our zfs packages here shortly. Cheers!

    Update: Actually, it looks like the current package already includes the fix for the issue I linked. This could be a different issue or perhaps the original issue was not fixed afterall. I have reported this to the zfs developers. It would be helpful if you could provide them with any information they might ask for so they can debug this. Thanks!

  • @lots.0.logs I can give them any information they need from my system – what are they likely to want? I have checked the system journal logs and did not see anything to do with zfs concerning any errors or problems – it all looks normal, but it does not work. Is there somewhere else I should look? What logs should I include to help find the problem?

  • @wdheideman While digging around in the posts about the upstream bug you mentioned I did
    systemctl list-unit-files | grep zfs and got this:

    zfs-import-cache.service disabled
    zfs-import-scan.service disabled
    zfs-mount.service disabled
    zfs-share.service disabled
    zfs-zed.service disabled
    zfs.target enabled

    From what I saw in the posts, these should be enabled not disabled. That may be the problem. I will search more.

  • My efforts to fix this have so far been fruitless, I just don’t have the knowledge yet. I am giving up on fixing this myself for now and will wait to see what those with more knowledge come up with.

  • I’m updating the package right now. It will take a couple hours to sync across the mirror network. Let me know if the issue remains after installing the update. Thanks!

  • @lots.0.logs I applied the update – it was leathal to my system – no longer boots and the processes in arch wiki to recover are not doing to work, as I have not been able to regress the zfs stuff to the previously working versions even when it still booted. I am giving up on antergos and arch for now and going back to PC-BSD for root on zfs use. I will check back at the beginning of 2017 and see if root on zfs linux for various distros (I have tried several) works reliably. Thus far my experience is that it does not yet do so. I hope you can work out the bugs, but I don’t currently have to time to devote to fixing this anymore. Good luck and happy coding to you.

auto8 upgrade40 import2 fail14 Posts 7Views 772
Log in to reply