• Installation Woes


    Having used Antergos many times, I wanted to give the latest iso a try. Currently I dual boot Win 10 and Mint 17.3. My goal was to triple boot. I prepared my USB stick as always per the Antergos Wiki.

    Unfortunately, when I reboot Grub is gone and I need to do a “Grub Rescue”. I reboot and repair Mint Grub and toss the stick aside. This issue has plagued me for the last several .iso updates. Not at all sure what i’m doing wrong, but I never had an issue like this previously with Antergos.

    Any help is appreciated as I am really bored of Mint, Debian & Ubuntu.

  • @parkslope im horrible with the dual and triple booting stuff. honestly never makes sense to me with the wine app.

    if you bored with mint clear it all out and let antergos be your single OS ;)

    i know this isnt the advice you want to hear.

  • @parkslope Hi!

    Computer using (U)EFI?

    Perhaps something like rEFInd could properly detect and let you boot all OSes.

    Arch Wiki contains (as per usual ;)) steps to get going.

    Hope this was of any help

  • Thanks for the replies everyone. Unfortunately, the USB stick just won’t boot so I never get anywhere. Strange as I never had any issue like this with Antergos.

    Edit: I took a look at the Wiki. Did I read it correctly that Antergos can’t be installed with a USB stick? When a Moderator has a moment can you give me some guidance? I don’t have blank DVD’s so this might explain my problem.

  • Hi,

    Of course Antergos can be installed from an USB stick. Sadly, UEFI doesn’t seem to work in the same way in all manufacturers.

    For instance, in a mac computer, I have to select the CD/DVD option (even I’m booting from an USB).

    when I reboot Grub is gone and I need to do a “Grub Rescue

    Do you mean after installing Antergos?

  • No, the USB stick never boots. I get the following error:

    “antergos error loading \arch\boot\vmlinuz not found”, so the installation never starts. There is a reference to it in the wiki. I make the stick in Windows using Rufus and Mint using the dd command.

    Not sure what’s up. :)

  • To be honest, me neither. I suppose you’ve checked the md5 of the iso, right?

    Also, when creating the USB, make sure it is not mounted.

    Try this to create it (from the Arch wiki):
    dd bs=4M if=/path/to/anetergos.iso of=/dev/sdx status=progress && sync

    You have to replace sdx with your usb device, of course.

    Have you tried building it in another computer? And does the usb you create boot in another computer?

  • Yup, first I do is check the mdsum. Unfortunately, I don’t have another computer at my disposal. I followed the instructions to the letter but unfortunately I get the same error along with a new error about ‘vmlinuz’.

    Probably time for me to move along as this has been going on for months, but I must say you are a classy guy being so patient with me. Thanks.

  • I’m glad you mentioned vmlinuz because there has been issues with this from other users. I know @LibreMichael had problems with it and even wrote a wiki on the matter. I think I may have originally stumbled across this issue and even mentioned it in my post here:

    https://forum.antergos.com/topic/4081/how-to-dual-boot-antergos-windows-uefi-expanded

    As for the solution I believe this may help from his wiki page:
    “The UEFI installation of Antergos is bugged. The default option for Antergos is the “Antergos USB” option, but the system will return a “antergos error loading \arch\boot\vmlinuz not found”. In this case you should try selecting Antergos CD/DVD. This should fix the issue.”

    https://antergos.com/wiki/install/uefi-installation-bug-solution-archbootvmlinuz/

    Hope this helps!

  • Do you mean burn a DVD or select Antergos CD/DVD? When I do that the computer freezes.

    Thanks

  • Yes, the idea was selecting DVD even you’re using USB, that works on my macbook pro.

    Go figure.

  • I’ll try again when time permits. Thanks for everything.

  • There is a way to make this work. I used Rufus again. When selecting Antergos .iso it is important to select 'gpt partition scheme for UEFI AFTER SELECTING THE ANTERGOS .ISO. If you select the Antergos .iso, Rufus reverts back to 'MBR partition scheme for BIOS or UEFI. That will leave you with a USB STICK THAT WILL NOT BOOT. Linux dd does not work, my preferred method.

    I installed KDE Plasma. There are some bugs, and not nearly as fast as the Beta versionof PcLinos. But at least it is installed and ready to use.

  • Nice findings! What’s odd is that dd works here (tested with all iso releases).

    Cheers!

  • Strange as I have done it so many times. Well at least the issue is solved.

grub224 instalation12 Posts 15Views 1619
Log in to reply