• \[SOLUCIONADO\] Grub no cambia entrada por defecto


    Hola ñ_ñ

    Le he instalado hace poco esta distribución a mi padre (a ver si lo hago ir usando linux, aunque sea para tareas rutinarias, y como Arch es mi distri favorita… :p) y… No encuentro manera de que el kjakñjfañ Grub me haga caso xD

    Mencionar que, por supuesto, lo primero que he hecho es mirar la wiki de Archlinux y nada.
    También he mirado el foro y no he encontrado nada que solucione el problema…

    En su portátil mi padre tiene Antergos y Windows 7.

    en

    , que es donde se supone que se debe cambiar esto, tengo   
      
      
    GRUB\_DEFAULT=4  
    GRUB\_TIMEOUT=10  
    GRUB\_DISTRIBUTOR="Arch"  
    GRUB\_CMDLINE\_LINUX\_DEFAULT="quiet"  
    GRUB\_CMDLINE\_LINUX=""  
      
    \# Preload both GPT and MBR modules so that they are not missed  
    GRUB\_PRELOAD\_MODULES="part\_gpt part\_msdos"  
      
    \# Uncomment to enable Hidden Menu, and optionally hide the timeout count  
    \#GRUB\_HIDDEN\_TIMEOUT=5  
    \#GRUB\_HIDDEN\_TIMEOUT\_QUIET=true  
      
    \# Uncomment to use basic console  
    GRUB\_TERMINAL\_INPUT=console  
      
    \# Uncomment to disable graphical terminal  
    \#GRUB\_TERMINAL\_OUTPUT=console  
      
    \# The resolution used on graphical terminal  
    \# note that you can use only modes which your graphic card supports via VBE  
    \# you can see them in real GRUB with the command \`vbeinfo'  
    GRUB\_GFXMODE=auto  
      
    \# Uncomment to allow the kernel use the same resolution used by grub  
    GRUB\_GFXPAYLOAD\_LINUX=keep  
      
    \# Uncomment if you want GRUB to pass to the Linux kernel the old parameter  
    \# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"  
    \#GRUB\_DISABLE\_LINUX\_UUID=true  
      
    \# Uncomment to disable generation of recovery mode menu entries  
    GRUB\_DISABLE\_RECOVERY=true  
      
    \# Uncomment and set to the desired menu colors. Used by normal and wallpaper  
    \# modes only. Entries specified as foreground/background.  
    \#GRUB\_COLOR\_NORMAL="light-blue/black"  
    \#GRUB\_COLOR\_HIGHLIGHT="light-cyan/blue"  
      
    \# Uncomment one of them for the gfx desired, a image background or a gfxtheme  
    \#GRUB\_BACKGROUND="/path/to/wallpaper"  
    \#GRUB\_THEME="/path/to/gfxtheme"  
      
    \# Uncomment to get a beep at GRUB start  
    \#GRUB\_INIT\_TUNE="480 440 1"  
      
    \#GRUB\_SAVEDEFAULT="true"
    

    Por defecto, Grub viene con

    , pero da igual por qué lo cambie, que siempre está marcada en Grub la misma entrada. La de Antergos.  
    No importa que active 
    

    y que luego entre a windows y reinicie: seguirá marcando la de Antergos.
    Da igual que en vez de valor númerico use el título del menú.
    He probado usando el título de la entrada también:

    GRUB\_DEFAULT="Windows 7 (loader) (en /dev/sda1)"
    

    Idéntico resultado

    No se puede usar

     o 
    

    como he visto usar en otras entradas, porque:

    sudo: update-grub: command not found
    

    y da igual que sudes o que tengas frío, no está. Y con

    locate update-grub
    

    tampoco aparece, por lo que imagino que ese script no está presente xD

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    Sólo me añade más entradas (correspondiente a actualizaciones del kernel) al menú grub, claro. Sigo sin poder establecer qué entrada quiero que se seleccione por defecto.

    En algunos sitios veo que conminan a editar directamente

    , pero el propio archivo lo deja bastante claro:  
      
    \#  
    \# DO NOT EDIT THIS FILE  
    \#  
    \# It is automatically generated by grub-mkconfig using templates  
    \# from /etc/grub.d and settings from /etc/default/grub  
    \#  
    
    

    Así que: ¿Qué puedo hacer? ¿Se puede cambiar o no la entrada por defecto de Grub en Antergos? Ô_ó

    Gracias ñ_ñ

  • Hola ñ_ñ

    Le he instalado hace poco esta distribución a mi padre (a ver si lo hago ir usando linux, aunque sea para tareas rutinarias, y como Arch es mi distri favorita… :p) y… No encuentro manera de que el kjakñjfañ Grub me haga caso xD

    Mencionar que, por supuesto, lo primero que he hecho es mirar la wiki de Archlinux y nada.
    También he mirado el foro y no he encontrado nada que solucione el problema…

    En su portátil mi padre tiene Antergos y Windows 7.

    en

    , que es donde se supone que se debe cambiar esto, tengo   
      
      
    GRUB\_DEFAULT=4  
    GRUB\_TIMEOUT=10  
    GRUB\_DISTRIBUTOR="Arch"  
    GRUB\_CMDLINE\_LINUX\_DEFAULT="quiet"  
    GRUB\_CMDLINE\_LINUX=""  
      
    \# Preload both GPT and MBR modules so that they are not missed  
    GRUB\_PRELOAD\_MODULES="part\_gpt part\_msdos"  
      
    \# Uncomment to enable Hidden Menu, and optionally hide the timeout count  
    \#GRUB\_HIDDEN\_TIMEOUT=5  
    \#GRUB\_HIDDEN\_TIMEOUT\_QUIET=true  
      
    \# Uncomment to use basic console  
    GRUB\_TERMINAL\_INPUT=console  
      
    \# Uncomment to disable graphical terminal  
    \#GRUB\_TERMINAL\_OUTPUT=console  
      
    \# The resolution used on graphical terminal  
    \# note that you can use only modes which your graphic card supports via VBE  
    \# you can see them in real GRUB with the command \`vbeinfo'  
    GRUB\_GFXMODE=auto  
      
    \# Uncomment to allow the kernel use the same resolution used by grub  
    GRUB\_GFXPAYLOAD\_LINUX=keep  
      
    \# Uncomment if you want GRUB to pass to the Linux kernel the old parameter  
    \# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"  
    \#GRUB\_DISABLE\_LINUX\_UUID=true  
      
    \# Uncomment to disable generation of recovery mode menu entries  
    GRUB\_DISABLE\_RECOVERY=true  
      
    \# Uncomment and set to the desired menu colors. Used by normal and wallpaper  
    \# modes only. Entries specified as foreground/background.  
    \#GRUB\_COLOR\_NORMAL="light-blue/black"  
    \#GRUB\_COLOR\_HIGHLIGHT="light-cyan/blue"  
      
    \# Uncomment one of them for the gfx desired, a image background or a gfxtheme  
    \#GRUB\_BACKGROUND="/path/to/wallpaper"  
    \#GRUB\_THEME="/path/to/gfxtheme"  
      
    \# Uncomment to get a beep at GRUB start  
    \#GRUB\_INIT\_TUNE="480 440 1"  
      
    \#GRUB\_SAVEDEFAULT="true"
    

    Por defecto, Grub viene con

    , pero da igual por qué lo cambie, que siempre está marcada en Grub la misma entrada. La de Antergos.  
    No importa que active 
    

    y que luego entre a windows y reinicie: seguirá marcando la de Antergos.
    Da igual que en vez de valor númerico use el título del menú.
    He probado usando el título de la entrada también:

    GRUB\_DEFAULT="Windows 7 (loader) (en /dev/sda1)"
    

    Idéntico resultado

    No se puede usar

     o 
    

    como he visto usar en otras entradas, porque:

    sudo: update-grub: command not found
    

    y da igual que sudes o que tengas frío, no está. Y con

    locate update-grub
    

    tampoco aparece, por lo que imagino que ese script no está presente xD

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    Sólo me añade más entradas (correspondiente a actualizaciones del kernel) al menú grub, claro. Sigo sin poder establecer qué entrada quiero que se seleccione por defecto.

    En algunos sitios veo que conminan a editar directamente

    , pero el propio archivo lo deja bastante claro:  
      
    \#  
    \# DO NOT EDIT THIS FILE  
    \#  
    \# It is automatically generated by grub-mkconfig using templates  
    \# from /etc/grub.d and settings from /etc/default/grub  
    \#  
    
    

    Así que: ¿Qué puedo hacer? ¿Se puede cambiar o no la entrada por defecto de Grub en Antergos? Ô_ó

    Gracias ñ_ñ

  • Hola,

    No encuentras update-grub o update-grub2 porque es específico de Debian/Ubuntu/Mint…

    Aquí, cada vez que cambies la configuración del Grub debes regenerar el grub.cfg:

    sudo grub-mkconfig -o /boot/grub/grub.cfg
    

    Haces bien en no editar el grub.cfg, por cierto, porque la instruccion anterior se cargaría tus cambios.

    Para que se inicie con el último seleccionado haz estos dos cambios:

    GRUB\_DEFAULT=saved  
    GRUB\_SAVEDEFAULT=true
    

    Y acuérdate de volver a generar el grub.cfg!

    EDIT: Olvidé mencionar lo del locate. El locate forma parte del programa mlocate.

    Lo instalas con

    sudo pacman -S mlocate
    

    Y para actualizar la base de datos

    sudo updatedb
    

    Y para utilizarlo, ya sabes,

    locate fichero
    

    Dime si te funciona correctamente.

  • Hola, Karasu.
    Primero de todo, gracias por la pronta respuesta

    Lo del

     lo mencionaba porque mirando el foro, vi que algún usuario comentaba que se usara.  
    Usando [b:tsvo3xzb]Arch[/b:tsvo3xzb] no lo he llegado a usar :p  
      
    Y sé como va 
    

    , lo uso a diario
    Ya comenté que regeneré el [b:tsvo3xzb]grub[/b:tsvo3xzb]… pero pensaba que lo único que hacía era el tema de añadir nuevos núcleos 😛
    Voy a probarlo ahora mismo y te digo aquí mismo. Este temita me ha tenido negro esta mañana xD
    [b:tsvo3xzb][u:tsvo3xzb]
    SOLUCIONADO[/u:tsvo3xzb][/b:tsvo3xzb]
    Ya está

    Muchas gracias otra vez, Karasu.

Posts 4Views 1636
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.