• Boot time improvement


    Need some help to improve my boot time I wonder why local-fs.target and home.mount take that long to process.

    graphical.target @1.605s
    └─teamviewerd.service @1.566s +39ms
    └─network.target @1.565s
    └─NetworkManager.service @1.318s +201ms
    └─basic.target @1.198s
    └─timers.target @1.138s
    └─systemd-tmpfiles-clean.timer @1.138s
    └─sysinit.target @1.066s
    └─systemd-update-utmp.service @1.017s +26ms
    └─systemd-tmpfiles-setup.service @947ms +23ms
    └─local-fs.target @902ms
    └─home.mount @221ms +680ms
    [email protected]\x2duuid-c5638e7f\x2d0ffd\x2d4b24\x2da648\x2d84aaaefb01ca.service @203ms +15ms
    └─dev-disk-by\x2duuid-c5638e7f\x2d0ffd\x2d4b24\x2da648\x2d84aaaefb01ca.device @201ms

    Startup finished in 584542y 2w 2d 20h 1min 34.266s (loader) + 1.984s (kernel) + 1.605s (userspace) = 3.590s

    specs:
    intel ssd 256gb --/root btrfs
    seagate 1TB - /home btrfs
    cpu i7-3930k
    ram 16gb
    gpu 760 oc
    mobo rampage iv gene

    fstab
    / btrfs defaults,noatime,compress=lzo,commit=600,ssd,discard 0 0
    /home btrfs defaults,noatime 0 1

  • Need some help to improve my boot time I wonder why local-fs.target and home.mount take that long to process.

    graphical.target @1.605s
    └─teamviewerd.service @1.566s +39ms
    └─network.target @1.565s
    └─NetworkManager.service @1.318s +201ms
    └─basic.target @1.198s
    └─timers.target @1.138s
    └─systemd-tmpfiles-clean.timer @1.138s
    └─sysinit.target @1.066s
    └─systemd-update-utmp.service @1.017s +26ms
    └─systemd-tmpfiles-setup.service @947ms +23ms
    └─local-fs.target @902ms
    └─home.mount @221ms +680ms
    [email protected]\x2duuid-c5638e7f\x2d0ffd\x2d4b24\x2da648\x2d84aaaefb01ca.service @203ms +15ms
    └─dev-disk-by\x2duuid-c5638e7f\x2d0ffd\x2d4b24\x2da648\x2d84aaaefb01ca.device @201ms

    Startup finished in 584542y 2w 2d 20h 1min 34.266s (loader) + 1.984s (kernel) + 1.605s (userspace) = 3.590s

    specs:
    intel ssd 256gb --/root btrfs
    seagate 1TB - /home btrfs
    cpu i7-3930k
    ram 16gb
    gpu 760 oc
    mobo rampage iv gene

    fstab
    / btrfs defaults,noatime,compress=lzo,commit=600,ssd,discard 0 0
    /home btrfs defaults,noatime 0 1

  • @“rusty”:2wzyrrfk said:

    (userspace) = 3.590s[/quote:2wzyrrfk]Improve your boot time? I don’t know how you get much better than 3.4 seconds…well unless you just don’t turn your system off at all
    @“rusty”:2wzyrrfk said:

    /home btrfs defaults,noatime 0 1[/quote:2wzyrrfk]
    I did notice this isnt right. Should be double zero’s at the end not “0 1”.

    Cheers!

  • Hi.
    You know out of the 3 different rolling releases that I have tried - and only kept 2 of them, Antergos and ArchBang are the fastest. The shutdown time for both of them also is phenomenal, to say the least.
    To get a boot up time of around 3 seconds is extremely good. I don’t think it will improve beyond that.
    Windows users would be embarrassed.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • We stay hungry all the time as “they” say
    Startup finished in 584542y 2w 2d 19h 51min 52.843s (loader) + 1.880s (kernel) + 2.246s (userspace) = 4.127s

    off topic: yesterday 1 of my old hdd drives came at boot with smart error then it was disappearing off and on in the system. I managed to get my data back out of it before a total collapse. I then decided to reformat it to btrfs from ntfs since it was the last drive that has ntfs from my previous dual boot situation. So I changed it to btrfs and it seems good so far, I’m not saying that it was caused by ntfs but btrfs would give me more peace of mind since it checks the integrity of the data on the drive and it no longer errors at boot, also smart doesn’t see it failing.

  • My turn

    [b:2vxidum9][i:2vxidum9]systemd-analyze blame[/i:2vxidum9][/b:2vxidum9]

      
    [[email protected] ~]$ systemd-analyze blame  
    5.017s udisks2.service  
    4.015s ModemManager.service  
    3.366s NetworkManager.service  
    2.837s systemd-vconsole-setup.service  
    2.439s lightdm.service  
    1.608s teamviewerd.service  
    1.598s systemd-remount-fs.service  
    1.563s systemd-logind.service  
    1.343s bluetooth.service  
    1.277s polkit.service  
    1.258s systemd-tmpfiles-setup-dev.service  
    1.162s run-media-i\\x2dsty-Egyeb.mount  
    952ms systemd-modules-load.service  
    952ms systemd-udev-trigger.service  
    843ms systemd-sysctl.service  
    842ms sys-kernel-debug.mount  
    697ms kmod-static-nodes.service  
    378ms sys-fs-fuse-connections.mount  
    349ms dev-disk-by\\x2duuid-e4c124f1\\x2db01a\\x2d4f2c\\x2daede\\x2dcfc6d18  
    303ms colord.service  
    271ms dev-mqueue.mount  
    271ms dev-hugepages.mount  
    270ms tmp.mount  
    246ms upower.service  
    237ms ntpd.service  
    213ms systemd-user-sessions.service  
    184ms [email protected]  
    176ms systemd-tmpfiles-setup.service  
    164ms sys-kernel-config.mount  
    147ms systemd-udevd.service  
    134ms systemd-tmpfiles-clean.service  
    120ms systemd-random-seed.service  
    119ms systemd-update-utmp.service  
    102ms systemd-journal-flush.service  
    40ms rtkit-daemon.service  
    8ms alsa-restore.service  
    
    

    [b:2vxidum9][i:2vxidum9]systemd-analyze time[/i:2vxidum9][/b:2vxidum9]

    [[email protected] ~]$ systemd-analyze time  
    Startup finished in 584542y 2w 2d 20h 1min 43.902s (loader) + 3.536s (kernel) + 31.363s (userspace) = 34.900s
    

    How do you do <10 seconds boot time? This mission is imposible to me

    [b:2vxidum9][i:2vxidum9]/etc/fstab[/i:2vxidum9][/b:2vxidum9]

    UUID=e4c124f1-b01a-4f2c-aede-cfc6d1860bbf swap swap defaults 0 0
    UUID=2d84dcc8-042a-4056-bde2-720b278877aa / btrfs rw,relatime 0 1
    /dev/sda6 /run/media/i-sty/Egyeb ntfs-3g auto,uid=i-sty,gid=users,relatime 0 0

    Don't forget to mark as [SOLVED], if your problem was solved!

  • @“rusty”:3w22ohls said:

    I’m not saying that it was caused by ntfs[/quote:3w22ohls]The ntfs kernel module is a little buggy, mostly because it’s meant for the “occasional” situation where you need to grab something off of your Windows partition. (Of course the word “occasional” is kind of broad and more of an excuse not to fix bugs than anything else). I’ve had great performance out of btrfs over the past year or so. I don’t know where I’d be without snapper and btrfs

    @“I-sty”:3w22ohls said:

    How do you do <10 seconds boot time? This mission is imposible to me [/quote:3w22ohls]Don’t feel bad, mine is 9.46s (which I think is great honestly). It looks like you also have “01” in fstab for btrfs. Change that to “0 0”. It likely won’t improve boot time by very much but it’s unnecessary to use “0 1” for btrfs regardless.

    Cheers!

  • @“lots.0.logs”:21bk0p6h said:

    Don’t feel bad, mine is 9.46s (which I think is great honestly). It looks like you also have “01” in fstab for btrfs. Change that to “0 0”. It likely won’t improve boot time by very much but it’s unnecessary to use “0 1” for btrfs regardless.

    Cheers![/quote:21bk0p6h]

    Okay, I changed it.
    But why my userspace’s time is ~35second?

    Don't forget to mark as [SOLVED], if your problem was solved!

  • What are your system specs?

  • have a look at this
    [https://wiki.archlinux.org/index.php/Improve_Boot_Performance#Filesystem_mounts][0]">[https://wiki.archlinux.org/index.php/Im][1] … tem_mounts
    i edited my fstab and # out root
    # /etc/fstab: static file system information.
    #
    # Use ‘blkid’ to print the universally unique identifier for a
    # device; this may be used with UUID= as a more robust way to name devices
    # that works even if disks are added and removed. See fstab(5).
    #
    # <file system> <mount point> <type> <options> <dump> <pass>
    #
    #UUID=76dbf8a7-ff4a-4209-bcb6-cdcba4bbdb57 / ext4 rw,relatime,data=ordered 0 1
    UUID=646500f4-6dee-4345-a578-a0303487e1ef /home ext4 defaults 0 0

    And added root details to grub some thing like this (dont forget to update grub)
    GRUB_DEFAULT=0
    GRUB_TIMEOUT=0
    GRUB_DISTRIBUTOR=“Arch"
    GRUB_CMDLINE_LINUX_DEFAULT=”"
    GRUB_CMDLINE_LINUX=“root=UUID=76dbf8a7-ff4a-4209-bcb6-cdcba4bbdb57 rw nmi_watchdog=0 radeon.dpm=1”

    Also you can run this(if u havent)
    sudo systemctl enable systemd-readahead-collect systemd-readahead-replay and reboot twice
    see if you get any improvement.(does a lot for me 13-15 sec from grub to desktop(i am using openbox))
    cheers

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/Im

    Don&#x27;t Kill the Dream-Execute It

  • @“lots.0.logs”:190c2tt6 said:

    What are your system specs?[/quote:190c2tt6]

    CPU: i5-3210m
    GPU: HD4000
    HDD: WDC WD5000LPVT-75G33T0 500GB/5400rpm
    RAM: 6GB @ 1600MHz

    I enabled/activated the read-ahead stuff.

    Edit:

    I am using this parameters in the kernel line:

    linux /boot/vmlinuz-linux root=UUID=2d84dcc8-042a-4056-bde2-720b278877aa rw quiet acpi\_osi=Linux acpi\_backlight=vendor selinux=0
    

    Don't forget to mark as [SOLVED], if your problem was solved!

  • My guess is your 5400rpm hd is going to be a big part of your slow startup.

    However, some of the other things that @snmurli suggested should at least help a little.

    In God's love,
    †MaNNa <{{{\>< …to You all thanks and glory Lord Yeshua!

    And Jesus prayed to The Father, "And this is the way to ete…

  • [https://drive.google.com/file/d/0B2_XIe25TBZFWlZZSDBMWm5sUFU/edit?usp=sharing][0]">[https://drive.google.com/file/d/0B2_XIe][1] … sp=sharing
    This is my plot.svg file.
    I have a large pause in the table? I think this is the cause why my time is too long.

    [0]: <a href=
    [1]: https://drive.google.com/file/d/0B2_XIe

    Don't forget to mark as [SOLVED], if your problem was solved!

  • @“I-sty”:1ylly7sm said:

    My turn

    [b:1ylly7sm][i:1ylly7sm]systemd-analyze time[/i:1ylly7sm][/b:1ylly7sm]

    [[email protected] ~]$ systemd-analyze time  
    > Startup finished in 584542y 2w 2d 20h 1min 43.902s (loader) + 3.536s (kernel) + 31.363s (userspace) = 34.900s
    

    How do you do <10 seconds boot time? This mission is imposible to me

    [b:1ylly7sm][i:1ylly7sm]/etc/fstab[/i:1ylly7sm][/b:1ylly7sm]

    UUID=e4c124f1-b01a-4f2c-aede-cfc6d1860bbf swap swap defaults 0 0
    UUID=2d84dcc8-042a-4056-bde2-720b278877aa / btrfs rw,relatime 0 1
    /dev/sda6 /run/media/i-sty/Egyeb ntfs-3g auto,uid=i-sty,gid=users,relatime 0 0

    I have an ssd that’s why it fast. I’m still trying to squeeze another second out of it

    your 5400rpm drive is slow. also check what services are running at boot.

  • @“rusty”:mu7k0ag6 said:

    also check what services are running at boot.[/quote:mu7k0ag6]

    I sent the plot file. see above. But I dont found any error.

    Don't forget to mark as [SOLVED], if your problem was solved!

  • [img:3uzyso7t]http://imagerz.com/QBZHCUtvAwMCAlhKEgVQ[/img:3uzyso7t]

    Don't forget to mark as [SOLVED], if your problem was solved!

  • If you have a ext4 partitioned system try looking at e4rat on the Arch Wiki[/url:ntzp83p5].

  • I use btrfs root partition with the latest ck kernel, without the readahead service.

    [[email protected] ~]$ systemd-analyze critical-chain  
    The time after the unit is active or started is printed after the "@" character.  
    The time the unit takes to start is printed after the "+" character.  
      
    graphical.target @25.579s  
    └─teamviewerd.service @23.708s +1.870s  
    └─network.target @23.707s  
    └─NetworkManager.service @19.923s +3.783s  
    └─basic.target @19.918s  
    └─timers.target @19.917s  
    └─systemd-tmpfiles-clean.timer @19.916s  
    └─sysinit.target @3.403s  
    └─systemd-update-utmp.service @3.218s +184ms  
    └─systemd-tmpfiles-setup.service @2.896s +322ms  
    └─local-fs.target @2.895s  
    └─local-fs-pre.target @2.895s  
    └─systemd-tmpfiles-setup-dev.service @2.736s +158ms  
    └─kmod-static-nodes.service @1.915s +820ms  
    └─systemd-journald.socket @1.404s  
    └─-.mount @1.403s  
    └─system.slice @1.404s  
    └─-.slice @1.404s
    
      
    [[email protected] ~]$ systemd-analyze blame  
    5.088s ModemManager.service  
    3.783s NetworkManager.service  
    2.167s lightdm.service  
    1.928s systemd-logind.service  
    1.870s teamviewerd.service  
    1.755s upower.service  
    1.531s systemd-vconsole-setup.service  
    1.363s polkit.service  
    1.167s systemd-udev-trigger.service  
    1.033s systemd-sysctl.service  
    1.032s sys-kernel-debug.mount  
    900ms systemd-modules-load.service  
    820ms kmod-static-nodes.service  
    539ms udisks2.service  
    322ms systemd-tmpfiles-setup.service  
    318ms run-media-i\\x2dsty-Egyeb.mount  
    283ms sys-fs-fuse-connections.mount  
    271ms dev-mqueue.mount  
    271ms dev-hugepages.mount  
    269ms systemd-remount-fs.service  
    268ms tmp.mount  
    264ms sys-kernel-config.mount  
    258ms colord.service  
    201ms [email protected]  
    184ms systemd-update-utmp.service  
    173ms bluetooth.service  
    169ms systemd-journal-flush.service  
    158ms systemd-tmpfiles-setup-dev.service  
    107ms systemd-user-sessions.service  
    107ms systemd-udevd.service  
    104ms systemd-random-seed.service  
    95ms ntpd.service  
    11ms rtkit-daemon.service  
    5ms alsa-restore.service
    
      
    [[email protected] ~]$ systemd-analyze time  
    Startup finished in 584542y 2w 2d 20h 1min 43.339s (loader) + 4.213s (kernel) + 25.579s (userspace) = 29.792s  
    [[email protected] ~]$   
    
    
     GNU nano 2.2.6 File: /etc/fstab   
      
    \# /etc/fstab: static file system information.  
    \#  
    \# Use 'blkid' to print the universally unique identifier for a  
    \# device; this may be used with UUID= as a more robust way to name devices  
    \# that works even if disks are added and removed. See fstab(5).  
    \#  
    \# <file system\> <mount point\> <type\> <options\> <dump\> <pass\>  
    \#  
    \#UUID=e4c124f1-b01a-4f2c-aede-cfc6d1860bbf swap swap defaults 0 0  
    \#UUID=2d84dcc8-042a-4056-bde2-720b278877aa / btrfs rw,relatime 0 0  
    /dev/sda6 /run/media/i-sty/Egyeb ntfs-3g auto,uid=i-sty,gid=users,relatime,noauto,x-systemd.automount 0 0  
      
    
    

    I don’t understand the systemd’s logic. The blame command shows ~3X seconds boottime, but the real is ~70-80 seconds

    Don't forget to mark as [SOLVED], if your problem was solved!

  • I dont understand systemd’s logic on the times it shows either

  • [https://plus.google.com/u/0/+IstvánSzőllősi/posts/5TH6Gi41Ff5][0]">[https://plus.google.com/u/0/+Istvá][1] … TH6Gi41Ff5

    [0]: <a href=
    [1]: https://plus.google.com/u/0/+Istvá

    Don't forget to mark as [SOLVED], if your problem was solved!

Posts 24Views 6159
Log in to reply