• HTML5 videos cause kernel panic


    Hi there,

    when I play html5 videos in my fresh Antergos system it is just a matter of seconds until the mouse pointer freezes and all input is ignored until the system does a hard reboot.
    I had the same issue in linux mint but changed graphics card and ssd and ram in the meantime. Also stress tested the system so I’m pretty sure it is not hardware-related.
    Using nvidia proprietary drivers for gtx 970 and intel 4790, 64bit system.

    Glad if you have ideas!

  • Is this a laptop with Intel and optimus nvidia? You should run an bumblebee setup.

    Check this out:
    https://antergos.com/wiki/ca/hardware/graphics/bumblebee-for-nvidia-optimus/

    Cheers!

  • Karasu, thanks for your reply!
    it is a desktop pc with a msi gtx970 graphics card, so I guess bumblebee is not an option.

  • A few more words on it…
    The freeze with reboot occurs in chrome-stable and in firefox.
    This video is a guarantee for a crash:
    https://www.youtube.com/watch?v=62N9gjn2Y8s
    Watching it in firefox in a virtual win 10 machine on the same computer runs like a charm.

  • Hi again,

    When it crashes, reboot and grab the logs. You can grab them with journalctl -xb

    Post them in pastebin and post a link here if you want us to check them out.

    To be honest, it looks like a driver issue, but I’m not 100% sure.

    Cheers!

  • Driver issue pointed me to the right direction :golfer:
    After a lot of reading in different forums I disabled ‘allow flipping’ in OpenGL settings for Nvidia proprietary driver - which did the trick for me.
    So far no freezes and reboots anymore.

  • Friends, that was too quick :-|
    System froze again with this video:
    https://www.youtube.com/watch?v=4E1uePkqwrE&feature=youtu.be
    journalct -xb:
    http://pastebin.com/ydXhWtG6

  • This guy has exactly the same issue - but no solution…
    http://unix.stackexchange.com/questions/215483/system-freezes-when-viewing-html5-content

    Thanks for having a look - I’m lost.
    :disappointed_relieved:

  • Have you tried another DE apart from Plasma?

  • Not with this system configuration.
    Did you have a look at the log? Do you have a clue of what it could be?

  • @karasu
    Just tried with mate and crashed…
    :collision:

  • Problem identified:

    I experience a reproducible kernel panic with my Gigabyte motherboard (z97-hd3 ) with newest stable bios (F9 ). It has an issue with the CPU turbo mode for Intel CPU I7-4790 Haswell. When activated or auto I get a kernel panic anytime I use a webkit (chrome, firefox, chromium, …) to watch html5 videos. So turning CPU Turbo Boost mode off makes a stable user experience.

    Thank you very much for reading and helping along the way to identify this issue!

html53 kernel71 cause1 videos5 Posts 12Views 1343
Log in to reply