• Antergos won't wakeup from suspend


    Hello everybody,

    Antergos goes in suspend to RAM like expected, after the set time or with systemctl suspend. But it won’t wake up, when a mousbutton, the mous lights up but PC stays of, when I press the power button the PC boots like it was shut down.
    Does anyone know how I can get suspend to RAM work correctly?

  • @Brown I’m not sure if you’re facing the same problem I did, but I got my laptop to go to suspend and then wake up successfully, by adding resume=/dev/sda4 (depends on what your swap partition is) in grub and then update grup. This is what it looks for me:

    GRUB_CMDLINE_LINUX_DEFAULT="resume=/dev/sda4"
    

    And then save and update grub. Hope it works for you too.

  • I don’t know how to get systemctl suspend to work, but for some hardware the right thing to do is just use sudo pm-suspend (you might need to sudo pacman -Syu pm-utils before that if you don’t have that package already)

  • @KabirGandhiok not exactly, I want to suspend to RAM not hybrid or swap… Since I’m using a SSD I don’t want a swap partition here. maybe I can set swappiness to 0 and use swap to suspend/hibernate?

    @saoded systemctl suspend already works, wakeup doesn’t work right…

  • @Brown said in Antergos won't wakeup from suspend:

    @KabirGandhiok maybe I can set swappiness to 0 and use swap to suspend/hibernate?

    How would you use swap if you set swappiness to 0, doesn’t setting it to 0 mean the swap disk literally does not exist? Sorry I’m not much help on how to suspend machine to RAM.

  • Hi
    May I ask which DE (Desktop Environment) are you using? This might be useful for other users to know and instruct you
    Cheers

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Hi all,

    first I’m using GNOME 3.20.2. Afaik setting swappiness prevents that data is written to the swap partition, the partition itself stays active and is only used if really all RAM is in usage. Please correct me if I’m wrong. But I’m in a little different situation now, my new hdd arrived and I took 8G of it to make the swap partition there instead of on my ssd. Swappiness is now 60 again. I managed to activate it, and modified the kernel parameter as mentioned above by @KabirGandhiok
    I also added the hook rebuild grub and mkinitcipo.
    Hibernation and suspend are both still not working. The PC shuts down very quickly, as expected, but on wakeup it just boots like normal…

  • @Brown said

    it won’t wake up, when a mousbutton, the mous lights up but PC stays of, when I press the power button the PC boots like it was shut down.

    Is it for sure that there is no activity at all, or maybe the screen is not active?
    For example, if you had some music while suspending, would you be able to hear it?
    Anyway, I hope you can find a solution one way or another. I have heard of lots of causes. Bios update, incompatible hardware, setting parameters to grub, to name a few…

    https://www.google.gr/search?q=won't+wakeup+from+suspend&ie=utf-8&oe=utf-8&client=firefox-b&gfe_rd=cr&ei=DQRGV6iTIaLS8AefjI_4BQ#q=won't+wakeup+from+suspend+Arch+Linux

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Stupid of me. Forgot the Archwiki…
    https://wiki.archlinux.org/index.php/Power_management/Suspend_and_hibernate

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • I already took a look in the arch wiki…
    But first a big facepalm! An empty BIOS battery forced me recently, to setup BIOS new and the wakeup events were all disabled! So it simply couldn’t wake up!
    Now as it wakes up, the trouble is my gfx card doesn’t feel like going to work again and I got a messy but colourful pixel-art screen…
    I have an MSI Radeon 5850 TwinFrozr2 installed, I didn’t install any other drivers for it…
    This happens when I hibernate the PC, suspend is still the same, it goes quickly in suspend but on wakeup it just boots

suspend26 wakeup2 Posts 10Views 1489
Log in to reply