• Steam installed but won't start


    just installed antergos, and also choosed steam during install. it’s pre installed now but when i click it won’t start. what to?

  • Open terminal and start steam by putting steam. Show the output.

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • /home/terminal/.local/share/Steam/steam.sh: line 161: VERSION_ID: unbound variable
    /home/terminal/.local/share/Steam/steam.sh: line 161: VERSION_ID: unbound variable
    Running Steam on antergos 64-bit
    /home/terminal/.local/share/Steam/steam.sh: line 161: VERSION_ID: unbound variable
    STEAM_RUNTIME is enabled automatically
    Installing breakpad exception handler for appid(steam)/version(0)
    libGL error: unable to load driver: radeonsi_dri.so
    libGL error: driver pointer missing
    libGL error: failed to load driver: radeonsi
    libGL error: unable to load driver: radeonsi_dri.so
    libGL error: driver pointer missing
    libGL error: failed to load driver: radeonsi
    libGL error: unable to load driver: swrast_dri.so
    libGL error: failed to load driver: swrast

  • @mr.such

    Run LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so' steam to preload your system libraries.

    https://wiki.archlinux.org/index.php/Steam/Troubleshooting

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • Thank you, it’s working now

  • it’s happening again when i quit steam and try to enter again

  • @mr.such

    Delete Steam’s libraries then run the previous command.

    find ~/.local/share/Steam/ \( -name "libgcc_s.so*" -o -name "libstdc++.so*" -o -name "libxcb.so*" -o -name "libgpg-error.so*" \) -print -delete

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • looks like it’s ok now

  • @mr.such

    For future use I’d recommend changing your steam desktop shortcut to follow through on the new libaries instead of doing it manually yourself:

    env LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so' /usr/bin/steam %U

    :+1: .

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

steam55 Posts 9Views 1928
Log in to reply