• Cannot get Bumblebee service active


    I tried to follow the Bumblebee guide on Antergos Wiki (can’t link because it blocks it as spam for some reason). I turned off the Discrete graphic setting in my BIOS (it’s now set to UMA),
    and installed all of the written packages (and nothing else - my laptop is basically Antergos+Openbox clean-installed from an hour ago).
    I added my user to the Bumblebee group and enabled the service; now, I want to check whether or not I need to install the power-saving patch, but when I get the following output:

    $ optirun --status
    [ 1826.825923] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect.
    [ 1826.826001] [ERROR]Could not connect to bumblebee daemon - is it running?
    

    Does anyone know how to handle that? did I forget something or did something wrong in the process?

  • @bsayar Please, post back here the full output of these commands, including the command itself, as you have entered it at the bash prompt.

    1. Basic info about you video card
      lspci -vnn | grep '\''[030[02]]'
      
    2. Human readable info about your video card
      inxi -Gxx
      
    3. Your groups
      groups
      
    4. The state of bumblebee daemon
      systemctl status bumblebeed
      
    5. Finally, did you reboot after installing Bumblebee and before entering the optirun --status command (Yes/No) ?
  • Hi, @Just, thanks for your time

    00:02.0 VGA compatible controller [0300]: Intel Corporation Broadwell-U Integrated Graphics [8086:1616] (rev 09) (prog-if 00 [VGA controller])
    04:00.0 3D controller [0302]: NVIDIA Corporation GK208M [GeForce 920M] [10de:1299] (rev a1)
    
    Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends
    Graphics:  Card-1: Intel Broadwell-U Integrated Graphics
           bus-ID: 00:02.0 chip-ID: 8086:1616
           Card-2: NVIDIA GK208M [GeForce 920M]
           bus-ID: 04:00.0 chip-ID: 10de:1299
           Display Server: N/A drivers: nouveau,intel (unloaded: fbdev,vesa)
           Resolution: 80x24
    
    wheel bumblebee users
    
    ● bumblebeed.service - Bumblebee C Daemon
       Loaded: loaded (/usr/lib/systemd/system/bumblebeed.service; enabled; vendor p
       Active: active (running) since Tue 2016-05-17 20:06:36 IDT; 8min ago
     Main PID: 406 (bumblebeed)
        Tasks: 1 (limit: 512)
       CGroup: /system.slice/bumblebeed.service
               └─406 /usr/bin/bumblebeed
    
    May 17 20:06:36 archmage systemd[1]: Started Bumblebee C Daemon.
    May 17 20:06:40 archmage bumblebeed[406]: [   15.820024] [INFO]/usr /bin/bumblebe
    May 17 20:09:37 archmage bumblebeed[406]: [  193.046676] [WARN][XORG] (WW) `font
    May 17 20:09:37 archmage bumblebeed[406]: [  193.046688] [WARN][XORG] (WW) `font
    May 17 20:09:37 archmage bumblebeed[406]: [  193.046695] [WARN][XORG] (WW) Open 
    May 17 20:09:37 archmage bumblebeed[406]: [  193.046698] [WARN][XORG] (WW) Warni
    May 17 20:09:37 archmage bumblebeed[406]: [  193.046706] [WARN][XORG] (WW) NVIDI
    May 17 20:09:37 archmage bumblebeed[406]: [  193.046711] [WARN][XORG] (WW) Warni
    
    1. and as of the restart, I tried it first without rebooting, because it says to check before it says to reboot and I was afraid it won’t and I’ll have to reinstall alll over again. but then I read that the systemctl changes should take place only after rebooting, so I did, but the output to optirun --status is still the same (4’s output changed however, as expected)
  • @bsayar OK. Everything looks quite well. Except one thing - you aren’t a member of the video group. It is very strange - any user should be video member by default. Antergos Wiki speaks about it. Very strange.

    Anyhow. Add yourself to video group:

    1. Check that USER environmental variable is set correctly

      echo $USER
      

      It should return your user login name. For me it returns just.

    2. If the above command returns you user login, then add yourself to video group with

      sudo gpasswd -a $USER video
      

      If the echo $USER command didn’t return your user login name, then add yourself to video explicitely with

      sudo gpasswd -a [you-login-name] video
      
    3. Log out and back in. A full reboot is not needed here.

    4. Retry

      optirun --status
      
  • ok, it seems to have worked

    My current output is

    Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.
    

    Also, running the check for power-saving-thingy went well, so I guess there is nothing left to do about it, right?

    Many thanks

  • @bsayar said in Cannot get Bumblebee service active:

    ok, it seems to have worked

    My current output is

    Bumblebee status: Ready (3.2.1). X inactive. Discrete video card is off.
    

    It’s hard to interpret your answers. Does Bumblebee work for you now (Yes/No) ?

    Also, running the check for power-saving-thingy went well, so I guess there is nothing left to do about it, right?

    Right. There’s no need to apply the power-off patch.

    Though it also seems a bit strange - AFAIK, missing power-off bug depends not on hardware but on bumblebee package. But I don’t have computers with BIOS that controls video cards - maybe on such computers the situation is different.

    To be sure, please execute in sequence, one after another, three commands below, and post back here their output. It will also answer to my first question - does Bmb work or not:

    optirun --status
    optirun pwd
    optirun --status
    
active2 bumblebee34 service8 Posts 6Views 1138
Log in to reply