• Trouble with NAS


    Hello,

    I’m not shure if this is the right place to ask, but I need expert help with my problem.
    I have a WD MYCloud NAS storage which I want to sync/mirror my files to. The problem is, that every sync tool (rsync and various gui for it) simply see a change where no change was made to the files. My own research showed, that this is related to some changes in the date/time format, which is adjusted to match windows’ needs, by the MyCloud software. But even if I use the “check only file size” option in (g)rsync, every file is considered as new/updated…
    For now it seems, only copy/paste works like expected.

    I hope anyone of you has a solution that I can sync my files like it’s supposed to. I wouldn’t mind to do changes on the MyCloud itself if necessery. Thank you in advance for your help.

  • @Brown Imnot sure what would b causing that. Id say either your NAS’s settings. or a glitch in grync.

    I would check both to see if you could change anything.

    If all else fails you could write a bash script to automaticaly copy and paste files for you.

    Or you could use a program like Syncthing to ync your files.

    Cheers! I don't know what I'm talking about!

  • As grsync is only a GUI for rsync, I don’t think any other tool based on rsync would do it any better. For now I got it at lest working one way. When not using --perms and --group options to preserve permission and group settings, I can sync to my NAS like expected. New files are recoginzed, files which already exist are not synced again.
    In FreeFileSync for example, which is also based on rsync, I didn’t find where to change these options, so that’s why I would stick with grsync for now.
    But still I have the old issue when dry run a sync task from my NAS to my internal storage, even without --perms and --group (g)rsync “thinks” all files on the NAS as newer or even don’t exist on my internal storage. This can only be avoided by --ingore-existing or --size-only option, the --update option is always set, so for rsync the files on my NAS defenitely seem newer than those on my PC.
    As I mentioned erlier, this seems to be related to the MyCloud software which “optimzes” the files (date/time stamps) to match windows requierments.
    The rsync options above are workarounds, I hope these can help some others with similar problems.
    But maybe someone knows other ways or NAS drives - WD MyCloud modifications to work properly with linux…

trouble11 nas9 Posts 3Views 764
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.