• SSH Server Setup


    Hey guys,
    I have recently put new instalation of Antergos with Mate on one of my computers. I want to enable ssh server capabilities on there because this box is not staying at my house and I really want to be able to control it remotely. How do I do that? I tried installing openssh from repos, editing sshd_conf but nothing worked. I can’t connect from any other computer. If I type ssh localhost on the machine itself, it works.

    Whare is the problem? Thanks in advance.

  • When you try to connect to it what error message do you get?

    Cheers! I don't know what I'm talking about!

  • I get connection timed out error. I tried connection from different machines and different ssh clients.

  • Are you sure you have the correct IP address?

    Cheers! I don't know what I'm talking about!

  • I checked with ifconfig so I am pretty sure.

  • Are you using a firewall?

    Cheers! I don't know what I'm talking about!

  • On the machine itself - I don’t know. I kept everything stock after fresh install.

  • Well the firewall is a checkbox in Cnchi. It installs the ufw package. If you have that installed then it could be blocking access to port 22.

    But if it’s not installed then I have no idea. I’ve had the same problem and not having the correct internal IP and having the firewall block that ports traffic were my mistakes.

    Sorry, I cant help further. Maybe someone else has a suggestion?

    Cheers! I don't know what I'm talking about!

  • I know this is a little old, but I ran into the same issue. After a fresh install where I opted to enable both ssh and the firewall in Cnchi, I had to do the following.

    sudo systemctl enable sshd
    sudo systemctl start sshd
    sudo ufw allow 22
    

    During the install, it implied that port 22 would be allowed by default in the firewall, but I still had to allow it manually.

    Also, not sure if this is necessary, but I also edited /etc/ssh/sshd_config and added the following line

    AllowUsers yourSshUser
    
    

    Hope that helps!

  • @greyson.parrelli This time i say o.k. because there was no solution for the problem and this will help for users with Firewall enabled wanting to connect via ssh!

    [updates once a week] = [90% less problems]
    [Li{u}n//u//{i}x] since 1988 - overcoming failure means success
    http://kamprad.net/howto-installing-antergos/
    https://forum.antergos.com/topic/1883/how-to-include-system-logs-when-asking-for-help

  • I stopped using that machine for a while and when I returned I was able to figure it out on my own using Arch Wiki.

    Still many thanks to you, sir. Help very much appreciated!

ssh7 Posts 11Views 1229
Log in to reply