• How to change ownership of files....

    So I ran this command

    sudo chown -R root:root /usr

    now nothing works

    I cant use sudo or su to undo it

    anyone got any suggestions on how I can fix this?

  • Are you sure that that is the cause?

    What do you mean by “nothing works” ? What do you get when you try to run “sudo” ?

  • Yeah I’m pretty sure.

    The only things I did before this were install limux-headers qt4 virtualbox and the virtualbox dkms thingie

    When I tried to elevate my privileges it gave me a password prompt


    But when I typed in the password it said authentication failure.

    Since then I have rebooted. And on startup systemd fails and says it doesn’t have access to /sbin

  • http://ubuntuforums.org/archive/index.php/t-1681431.html #4 cheered me up a bit - Don’t think there’s a quick fix for this one

  • I just did an ls -lsR /etc and every file is
    root root
    So what you did, imo, should not have messed anything up.
    HOWEVER, did you do something prior to what you said you did?

    And last, but not least,
    Why were you executing that command on /usr
    In my experience, NEVER, I repeat NEVER, change ownership on system directories RECURSIVELY unless you know exactly what you are doing.
    My reply may not help now, but perhaps in the future it might, just might, be useful.

  • Yeah, I didnt think it would mess anything up either.

    And like I said, the only thing I did was install a couple of packages.

    The reason I did it is because virtualbox was complaining about /usr not being owned by root.

    I’m going to try and repair it using chroot on a live cd of Fedora.

    Thanks for helping out so far. Will report back soon.

  • So when I mount my drive from a live cd all it shows it two folders. labled 1 and 2.

    Inside bothe of these folders is an xml file when I open it it has informationn about a snapper snapshot.

    Does anyone jnow what I can do to solve this? and see all my files?

  • Which filesystem are you using?

  • I found this on a Google search for your problem:
    Realmente …

    após instalar o plugin flashPlayer, este indivíduo troca o dono/grupo dos diretórios: /usr /usr/lib/ e /usr/share

    retorne as coisas ao normal [ sudo chown root.root /usr /usr/lib /usr/share ] e as VM’s voltam do túmulo … :)

    Really …

    [quote] after install flashplayer plugin, this guy changes the owner / group of the directory: / usr / usr / lib / and / usr / share

    return things to normal [ sudo chown root.root / usr / usr / lib / usr / share ] and VM’s return from the grave … :)
    The only difference is that he didn’t change with -R option.
    I think you’re on the right track though.
    Good luck

    Posts: 1
    Joined: 7. Aug 2013, 14:20

  • @karasu said in How to change ownership of files....:

    Which filesystem are you using?


  • @herbie I cant run that command as systemd fails on boot up

  • You have to boot with an USB or liveCD and chroot to your installation, then you can run whatever command you want.

    Check your /sbin with ls -la / it should point to /usr/sbin (I think, I’m on a MAC atm).

  • @karasu I tried to chroot in to the rive. but it said it could not find /bin

    I think it is because when I mount it all I see is those two folders.

help19 emergency4 Posts 13Views 3086
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.