• Desktop PC stops starting X successfully


    I have a desktop PC with a NVIDIA GTX 570 running the proprietary driver.

    A game froze, I had to forcibly shut down the PC. I restarted it, then X started but became extremely unresponsive. I had to shut it down forcibly again. I tried to uninstall the proprietary NVIDIA driver and put Nouveau back but to no avail. Manually running startx says there are no displays connected (despite having 2 working monitors, and the command line looking and working fine).

    Now, I’m not able to use KDE at all anymore, only the command line works (through Ctrl+Alt+F1). I tried the fallback mode but it’s stuck at a gray blinking cursor (just like the default X screen is, when using Nouveau).

    I did not run any particular update before that issue, so I don’t think there is a regression due to an update.

    Is it possible to either reinstall the NVIDIA driver and get it to work, or at least switch to Nouveau in the meantime?

  • @Calinou https://wiki.archlinux.org/index.php/NVIDIA

    sudo pacman -S xf86-video-nouveau
  • @gaim

    I have tried this and Nouveau outputs fatal errors (from dmesg). I tried booting the Antergos live ISO (which worked fine on the installation) but it also freezes at graphics initialization.

    I suspect a damaged graphics card, although command line still works (and looks) fine.

nvidia159 xorg29 Posts 3Views 798
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.