• Locked out root after "input source" changed and then logged out


    Hi
    I am in a very annoying situation:
    Right at the moment i was enjoying Antergos and putting all settings in the way i want and need, the system logged me out.

    Automatic logged out after that i have changed the keyboard “input source”. Why i was logged out is a mistery.
    I know the root password but because of the changed “input source” i can’t type it anymore with my keyboard.
    The password has one special character that isn’t available now.

    Already tried but without succes:

    • change the “input source” back thru Live usb and chroot
    • reset the root password with chroot and passwd

    The weird thing is that when i after the reset try to login with the new password Antergos doesn’t login or show password error.

    Has this something to do with “shadow”?

    Please help

  • Supposing you used English locales for your password, try this out. Get to a tty screen pressing
    Alt + Control + F2
    Enter your user name and password when prompted and then type
    passwd username thotgh just passwd should be enough and change the password in numbers.
    Then, press Alt+Control+F1 to get back to the GUI and give the numeric password to enter.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Alt + Control + F2
    

    Doesn’t do anything. My system is a dual boot MacOS and Antergos with rEFInd. How to get in that?

    But i can get into recovery shell and have tried already the

    passwd
    

    without succes.
    Please more tips and tricks because i can’t put more time in getting a system working. I have also work to get done.

    Above

    [rootfs ]#
    

    I get

    sh: can't access tty: job control turned off 
    

    So, how to get in tty?

  • Nothing that i found on the internet worked, so it seams that it’s difficult to change root password while not logged in as root.
    A good thing for security. Because of “shadow” used in Arch?

    “Solved” because i have managed to recover my one week older /etc folder. And i am back in! 🙂
    I start to like linux!

    On ipad not possible to mark post as solved?

  • Glad you found a way back, sorry for being unable to get any assistance.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 18.04 64bit Gnome
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

login105 login keyboard2 Posts 5Views 948
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.