• Steam not starting


    I know this has been solved a lot of times, but i’ve tried all the solving methods but nothing :/
    I start, my steam don’t start with nouveau drivers installed (i can’t use nvidia driv.) so:
    *I’ve tried deleting the famous libstdc++ and libgcc_s libraries, but after that, i start steam and the same.
    *I’ve tried using multilib libraries what i don’t understand, so i can’t know if i did it correctly, all what i know it’s that it don’t worked.
    *Why i must use nouveau

    steam
    
    /home/ecomaikgolf/.local/share/Steam/steam.sh: línea 161: VERSION_ID: variable sin asignar
    /home/ecomaikgolf/.local/share/Steam/steam.sh: línea 161: VERSION_ID: variable sin asignar
    Running Steam on antergos  64-bit
    /home/ecomaikgolf/.local/share/Steam/steam.sh: línea 161: VERSION_ID: variable sin asignar
    STEAM_RUNTIME is enabled automatically
    Installing breakpad exception handler for appid(steam)/version(1461972496)
    libGL error: unable to load driver: nouveau_dri.so
    libGL error: driver pointer missing
    libGL error: failed to load driver: nouveau
    libGL error: unable to load driver: swrast_dri.so
    libGL error: failed to load driver: swrast
    
    
    LIBGL_DEBUG=verbose steam
    
    /home/ecomaikgolf/.local/share/Steam/steam.sh: línea 161: VERSION_ID: variable sin asignar
    /home/ecomaikgolf/.local/share/Steam/steam.sh: línea 161: VERSION_ID: variable sin asignar
    Running Steam on antergos  64-bit
    /home/ecomaikgolf/.local/share/Steam/steam.sh: línea 161: VERSION_ID: variable sin asignar
    STEAM_RUNTIME is enabled automatically
    Installing breakpad exception handler for appid(steam)/version(1461972496)
    libGL: OpenDriver: trying /usr/lib32/xorg/modules/dri/tls/nouveau_dri.so
    libGL: OpenDriver: trying /usr/lib32/xorg/modules/dri/nouveau_dri.so
    libGL: dlopen /usr/lib32/xorg/modules/dri/nouveau_dri.so failed (/usr/lib32/libgcrypt.so.20: symbol gpgrt_lock_lock, version GPG_ERROR_1.0 not defined in file libgpg-error.so.0 with link time reference)
    libGL error: unable to load driver: nouveau_dri.so
    libGL error: driver pointer missing
    libGL error: failed to load driver: nouveau
    libGL: OpenDriver: trying /usr/lib32/xorg/modules/dri/tls/swrast_dri.so
    libGL: OpenDriver: trying /usr/lib32/xorg/modules/dri/swrast_dri.so
    libGL: dlopen /usr/lib32/xorg/modules/dri/swrast_dri.so failed (/usr/lib32/xorg/modules/dri/swrast_dri.so: no se puede abrir el fichero del objeto compartido: No existe el fichero o el directorio)
    libGL error: unable to load driver: swrast_dri.so
    libGL error: failed to load driver: swrast
    
    
  • Preload your system’s libraries instead of Steams.

    Run this in terminal: LD_PRELOAD='/usr/$LIB/libstdc++.so.6 /usr/$LIB/libgcc_s.so.1 /usr/$LIB/libxcb.so.1 /usr/$LIB/libgpg-error.so' steam

    More info here: https://wiki.archlinux.org/index.php/Steam/Troubleshooting#Steam_runtime_issues

    :+1: .

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • Thanks! Working like a charm!

steam55 not starting1 nouveau13 Posts 3Views 1490
Log in to reply