• \[SOLVED\]After boot Nautilus running with --no-default-window


    Hello,

    after booting antergos ( Using Gnome ) nautilus is running with --no-default-window argument. It is kinda annoying since I have the dock addon. ( I have to kill the nautilus before pressing the nautilus icon in a dock, by executing “kill -15 `pidof nautilus`” ).

    There is an output of ps ax.

    ps ax | grep nautil
    643 ? Sl 0:00 /usr/bin/nautilus --no-default-window
    1049 pts/0 S+ 0:00 grep nautil

    Is there a way how to find out which program/service has started nautilus with --no-default-window argument and did not kill it?

    Or how to fix it?

    Thank you.

  • Hello,

    after booting antergos ( Using Gnome ) nautilus is running with --no-default-window argument. It is kinda annoying since I have the dock addon. ( I have to kill the nautilus before pressing the nautilus icon in a dock, by executing “kill -15 `pidof nautilus`” ).

    There is an output of ps ax.

    ps ax | grep nautil
    643 ? Sl 0:00 /usr/bin/nautilus --no-default-window
    1049 pts/0 S+ 0:00 grep nautil

    Is there a way how to find out which program/service has started nautilus with --no-default-window argument and did not kill it?

    Or how to fix it?

    Thank you.

  • Hi,

    Do you have it setup to allow file manager to control the desktop? (GNOME Tweak Tool) If yes then the desktop background is being controlled by nautilus which is why it is automatically started with --no-default-window option by GNOME Shell (Otherwise you would have an open nautilus window every time you start your computer.).

    Cheers!

  • Could you please tell me where the “allow file manager to control the desktop” option is located in Gnome-tweak-tool? I can not find it. But I think that I did not set this option.

  • Sorry, Looks like they changed it since the last time I used GNOME. Do you have any desktop icons enabled in GNOME Tweek Tool>[email protected]:32xmiu9v said:

    It is kinda annoying since I have the dock addon. ( I have to kill the nautilus before pressing the nautilus icon in a dock, by executing “kill -15 `pidof nautilus`” [/quote:32xmiu9v]What Dock extension do you have installed and what exactly happens when you try to open Nautilus without killing it first?

    Regards,

  • @“lots.0.logs”:39rkxjwm said:

    Sorry, Looks like they changed it since the last time I used GNOME. Do you have any desktop icons enabled in GNOME Tweek Tool>[email protected]:39rkxjwm said:

    It is kinda annoying since I have the dock addon. ( I have to kill the nautilus before pressing the nautilus icon in a dock, by executing “kill -15 `pidof nautilus`” [/quote:39rkxjwm]What Dock extension do you have installed and what exactly happens when you try to open Nautilus without killing it first?

    Regards,[/quote:39rkxjwm]

    Some (GTT -> Desktop) icons were enabled. So I disabled them and it is working now.

    What Dock extension do you have installed and what exactly happens when you try to open Nautilus without killing it first?

    When I tried to run natilus from the dock, the activity moved to the Hidden window ( So nothing happened ).

    Thank you for your help

  • That sounds like a bug for sure. Perhaps report it to the GNOME devs if it “bugs” you enough (pun intended lol)

    Cheers!

Posts 7Views 1517
Log in to reply