• Grub goes into rescue mode everytime ASUS ZenBook Pro UX501VW

    Hello, I recently got an ASUS ZenBook Pro UX501VW with a SSD and decided to install Antergos on it.

    Naturally it has UEFI BIOS on it and it has been a nightmare since I got it. So far this is what I’ve done:

    In the BIOS I disabled/enabled Intel Virtualization Technology, Intel AES-NI, VT-d. I enabled/disabled CSM, PXE OpROM policy, and disabled secure boot. I’ve tried all of those options enabled and disabled and still no go.

    I’ve tried to get out of grub rescue mode by using the commands: set, ls, and insmod normal. Instead of doing the automatic partitioning, I made my own partitions and specified where I wanted grub to be installed and still it goes into rescue mode. I’ve tried installing ubuntu and the live USB just freezes, sometimes after a few reboots, the USB will boot without freezing.

    I also flashed a new BIOS hoping that it would fix the problem but it didn’t. I also tried running the live USB with the kernel option “nomodeset” hoping it would work. Fedora installed fine but I had some screwy HiDPI issues, and I want Antergos. Windows is my only option, but no way…

    At this point if I can’t get it going, I think I’m better off selling the laptop and getting a Linux friendly one. Never have I ever experienced this.

    If anyone has a solution, I would greatly appreciate it!

    Thank you so much in advance.

  • So the machine works fine from the live usb or how are you booting Antergos and doing the install?
    That laptop has several storage devices from the specs, nice lappy by the way :-), which one are you installing the OS on?
    It may be as simple as selecting the right default device to boot from is the bios, use the appropriate key press at power on (boot time) to select boot devices via the bios and pick each one until it boots up. Then change it to the default in the bios.
    Sorry I do not own uefi device, maybe this is not relevant. :-(

  • Hello, I want to apologize for not responding sooner! And I can boot the live USB (sometimes), and I can get the install to go, but when I reboot the computer, I get sent into grub rescue mode. I installed Xubuntu and had to choose which device to install grub to. Xubuntu worked like a charm. But when it comes down to Antergos, I cant seem to get grub to install correctly. I would just go ahead and install Arch and do everything manually but I don’t want to go through everything just for it not to work, and plus I really like Antergos. I am using a Sandisk drive and in the boot options it has ‘UEFI: Sandisk (with a number after it)’ and just ‘Sandisk.’

    Thanks for getting back to me!

  • Do you still have Windows on the laptop? Did you disable secure boot in the uefi bios settings? This guy does a good job of going over the basics of the install without me having to type it all out again.
    UEFI install

  • atwmll for me happens the same that you describe.

    The problem was that the installer don’t work well for me, but I don’t know why because previously I’ve Ubuntu without problems (grub installed incorrectly). I try to solve it with instructions from anika200 and also it don’t work for me.

    My solution was trying with this https://forum.antergos.com/topic/1380/solved-missing-grub-command-reinstall-grub/4 that is what I do other times that I’ve problems with grub.

    I’m not sure with this (never before I use UEFI and Secure Boot), but I think that UEFI BIOS is used if you have your hard disk is using GPT, and if you disable Secure Boot, you need your hard drive using the old msdos partition table.

  • Hello everyone, OP here on another account. I am so sorry I haven’t been getting back to you all but I have had some trouble logging in to the Antergos forums with my GitHub account. I really really appreciate your time and replies, it helps a lot and this is a very nice community. Antergos 4ever!! So I solved all of my issues with this laptop and i’ll list how I did so.

    Bootloader: Install systemd-boot instead of GRUB.

    Nouveau spamming on boot and loud fans: open the terminal and edit /boot/loader/entries/antergos.conf -> At the end of the “options” line, add (without the single quotes) ‘nouveau.nomodeset=0’.

    Touchpad: Even though it calls for an Elantech driver, it’s useless. Install xf86-input-synaptics instead, trust me.

    Other notes: GDM tends to hang sometimes so use another display manager, I use LXDM. This guide also may or may not work on other Asus models as well as other computers that have similar hardware.

    Good luck everyone!

    Unfortunately I cannot mark this thread solved since I cannot log in to the account I made the thread with, so if the mods could do so I would greatly appreciate it!

    Thanks again!
    – Tuxxx aka Atwmll

  • Hi, @tuxxx .
    I marked the topic as “solved” for you. If you want to restore your account, contact the devs by mail to sort it out.👍

grub127 goes11 rescue8 mode1 Posts 7Views 3100
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.