• alsa not configured properly


    I am unable to troubleshoot my alsamixer / pulseaudio / snd_hda_intel setup. I get my sound just fine. Great clarity. But if I try to adjust any of the settings, nothing happens. If i open up alsamixer, under card “PulseAudio” there is only one MASTER control that functions. But, if I switch to card “HDA Intel”, there are many volume controls and none of them work. Nothing changes when I adjust them. I tried downloading “gnome-alsamixer” and the same thing. Many volume controls but none do anything. The only thing that has any effect is the “IEC958” button that will turn sound off if I toggle it. I’ve looked through many forum threads, and none seem to match my problem. Everyone has an issue with sound working. Currently I am using my HDMI out to my TV. Sound is perfect. I would like to use my mixing tools though and this has really thrown me for a loop. Here are my stats:

    aplay -l
    
    **** List of PLAYBACK Hardware Devices ****
    card 0: Intel [HDA Intel], device 0: 92HD73C1X5 Analog [92HD73C1X5 Analog]
      Subdevices: 1/1
      Subdevice #0: subdevice #0
    card 0: Intel [HDA Intel], device 3: HDMI 0 [HDMI 0]
      Subdevices: 0/1
      Subdevice #0: subdevice #0
    
    pactl list sinks
    
    Sink #8
            State: RUNNING
            Name: alsa_output.pci-0000_00_1b.0.hdmi-stereo
            Description: Built-in Audio Digital Stereo (HDMI)
            Driver: module-alsa-card.c
            Sample Specification: s16le 2ch 44100Hz
            Channel Map: front-left,front-right
            Owner Module: 6
            Mute: no
            Volume: front-left: 53072 /  81% / -5.50 dB,   front-right: 53072 /  81% / -5.50 dB
                    balance 0.00
            Base Volume: 65536 / 100% / 0.00 dB
            Monitor Source: alsa_output.pci-0000_00_1b.0.hdmi-stereo.monitor
            Latency: 20540 usec, configured 23220 usec
            Flags: HARDWARE DECIBEL_VOLUME LATENCY SET_FORMATS 
            Properties:
                    alsa.resolution_bits = "16"
                    device.api = "alsa"
                    device.class = "sound"
                    alsa.class = "generic"
                    alsa.subclass = "generic-mix"
                    alsa.name = "HDMI 0"
                    alsa.id = "HDMI 0"
                    alsa.subdevice = "0"
                    alsa.subdevice_name = "subdevice #0"
                    alsa.device = "3"
                    alsa.card = "0"
                    alsa.card_name = "HDA Intel"
                    alsa.long_card_name = "HDA Intel at 0xfc700000 irq 31"
                    alsa.driver_name = "snd_hda_intel"
                    device.bus_path = "pci-0000:00:1b.0"
                    sysfs.path = "/devices/pci0000:00/0000:00:1b.0/sound/card0"
                    device.bus = "pci"
                    device.vendor.id = "8086"
                    device.vendor.name = "Intel Corporation"
                    device.product.id = "293e"
                    device.product.name = "82801I (ICH9 Family) HD Audio Controller"
                    device.form_factor = "internal"
                    device.string = "hdmi:0"
                    device.buffering.buffer_size = "352800"
                    device.buffering.fragment_size = "176400"
                    device.access_mode = "mmap+timer"
                    device.profile.name = "hdmi-stereo"
                    device.profile.description = "Digital Stereo (HDMI)"
                    device.description = "Built-in Audio Digital Stereo (HDMI)"
                    alsa.mixer_name = "IDT 92HD73C1X5"
                    alsa.components = "HDA:111d7675,102802a0,00100103 HDA:80862802,80860101,00100000"
                    module-udev-detect.discovered = "1"
                    device.icon_name = "audio-card-pci"
            Ports:
                    hdmi-output-0: HDMI / DisplayPort (priority: 5900, available)
            Active Port: hdmi-output-0
            Formats:
                    pcm
    
    sudo lshw -c multimedia
    
     *-multimedia
           description: Audio device
           product: 82801I (ICH9 Family) HD Audio Controller
           vendor: Intel Corporation
           physical id: 1b
           bus info: [email protected]:00:1b.0
           version: 03
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress bus_master cap_list
           configuration: driver=snd_hda_intel latency=0
           resources: irq:31 memory:fc700000-fc703fff
    
    pactl info
    
    Library Protocol Version: 30
    Server Protocol Version: 30
    Is Local: yes
    Client Index: 21
    Tile Size: 65472
    User Name: coldjoe
    Host Name: cold
    Server Name: pulseaudio
    Server Version: 8.0
    Default Sample Specification: s16le 2ch 44100Hz
    Default Channel Map: front-left,front-right
    Default Sink: alsa_output.pci-0000_00_1b.0.hdmi-stereo
    Default Source: alsa_output.pci-0000_00_1b.0.hdmi-stereo.monitor
    Cookie: 2f54:4361
    

    What am I missing?

  • @ThegoLopez What Desktop do you use, have you installed pavucontrol?

    Are you talking about controlling the volume or about a sound equalizer?

    If volume, have you tried switching off every sound device, which is not used in your Desktops sound configuration?

    I have only one input and one output device enabled, as you can see in the screenshot.

    0_1462441734932_pavucontrol.png

  • @nicolai.mladenoff

    Both. Being able to control the volume and using the “alsamixer -D equal” command.

Posts 3Views 646
Log in to reply